Last Comment Bug 708788 - Add telemetry probes for new/close tab animations
: Add telemetry probes for new/close tab animations
Status: RESOLVED FIXED
[Snappy] [Telemetry]
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Dão Gottwald [:dao]
:
: Dão Gottwald [:dao]
Mentors:
: 708672 708673 (view as bug list)
Depends on:
Blocks: 593680 671038 671039
  Show dependency treegraph
 
Reported: 2011-12-08 12:30 PST by Lawrence Mandel [:lmandel] (use needinfo)
Modified: 2013-12-27 14:34 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (4.25 KB, patch)
2011-12-14 07:36 PST, Dão Gottwald [:dao]
dietrich: review+
taras.mozilla: review+
Details | Diff | Splinter Review

Description Lawrence Mandel [:lmandel] (use needinfo) 2011-12-08 12:30:14 PST
As requested by product (see https://etherpad.mozilla.org/desktop-responsiveness) add a telemetry probe for new tab and closed tab animations.
Comment 1 Dietrich Ayala (:dietrich) 2011-12-09 11:03:14 PST
Is this to measure the time spent solely animating, as distinct from the full time to open/close a tab?
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-12-09 12:05:36 PST
It might be useful to track the time in between returning from removeTab, and _endRemoveTab (the end of the animation), to detect how much it varies from the specified animation time in practice.
Comment 3 Asa Dotzler [:asa] 2011-12-09 14:28:59 PST
yes, I want to know whether or not we're actually getting the user experience we've specified in the CSS. I'll have separate bugs for tuning that transition timing in the css.
Comment 4 Dão Gottwald [:dao] 2011-12-14 07:36:40 PST
Created attachment 581634 [details] [diff] [review]
patch

I don't know if my histogram definitions make sense -- when should LINEAR be used and what motivates the bucket size?
Comment 5 Dietrich Ayala (:dietrich) 2011-12-15 11:36:43 PST
Comment on attachment 581634 [details] [diff] [review]
patch

Review of attachment 581634 [details] [diff] [review]:
-----------------------------------------------------------------

code changes look fine. per Taras comment on other telemetry patch, should add the unit (eg: "_MS" or something) to the histogram name.

wrt to the maximum value - you should do some timings in a few different environments to see what the values look like to see what high/low values you get. we can also adjust later if the in-the-wild values are radically different.

wrt to buckets - i don't really know. am not sure about why/where it's important to have more or less buckets. maybe when variation in results is quite high?
Comment 6 (dormant account) 2011-12-16 13:43:34 PST
Comment on attachment 581634 [details] [diff] [review]
patch

I don't see value in measuring up to 3 seconds of tab anim, but up to you. Please add _MS to histogram names that measure milliseconds
Comment 7 Dão Gottwald [:dao] 2011-12-16 15:10:28 PST
3 seconds is the time after which tabbrowser gives up waiting for the animation to finish and forcefully removes the tab. Some users seem to still hit that limit.
Comment 9 Matt Brubeck (:mbrubeck) 2011-12-17 09:32:51 PST
https://hg.mozilla.org/mozilla-central/rev/5c428813b210
Comment 10 Dietrich Ayala (:dietrich) 2012-02-07 05:43:07 PST
Already paying back. Looks like this caught a regression between fx9 and fx10: bug 724349.
Comment 11 (dormant account) 2012-05-09 15:50:52 PDT
*** Bug 708673 has been marked as a duplicate of this bug. ***
Comment 12 Marco Castelluccio [:marco] 2012-05-09 15:53:52 PDT
*** Bug 708672 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.