Closed Bug 709385 Opened 8 years ago Closed 8 years ago

Passwords repository layer for Fennec local DB

Categories

(Firefox for Android :: Android Sync, defect, P1)

All
Android
defect

Tracking

()

VERIFIED FIXED
mozilla14
Tracking Status
blocking-fennec1.0 --- beta+
fennec + ---

People

(Reporter: ally, Assigned: liuche)

References

Details

(Whiteboard: [sync][qa!])

Attachments

(1 file)

might make the first drop if mobile gets us the content provider in time.
Where I left off:
Currently code will run if the patch from mobile is applied (Bug 704682). This should land soon. We also need to encrypt/decrypt passwords (Bug 711636).
Depends on: 711636
Waiting on the content provider interface for this, too.
Depends on: 704682
OS: Mac OS X → Android
Hardware: x86 → All
Summary: passwords repository layer for fennec local db → Passwords repository layer for Fennec local DB
Aiming for end of Jan, assuming that the Fennec CP is ready. Removing block for initial repository set, because we decided those were bookmarks and history.
Assignee: nobody → marina.samuel25
No longer blocks: 709285
Status: NEW → ASSIGNED
Priority: -- → P2
tracking-fennec: --- → ?
tracking-fennec: ? → +
Depends on: 718817
Assignee: marina.samuel25 → liuche
Duplicate of this bug: 728596
Depends on: 730557
Ready to work on as soon as Bug 718760 lands…

(Lifting that transitive dependency to here to make it easier to see.)
Depends on: 718760
Priority: P2 → P1
Depends on: 735912
blocking-fennec1.0: --- → beta+
the work is taking place on github, and is waiting review
No longer depends on: 711636
I made a build with this and form history enabled.  After sync, form history item for username is in Fennec moz_formhistory and password is in moz_logins (there is no form history item for password in Fennec moz_formhistory -- this seems correct).

I begin to enter username and form history correctly shows completion, but selecting unique completion does not complete password box.

What gives?
Depends on: 743411
what's the status here?
Whiteboard: [sync]
(In reply to Brad Lassey [:blassey] from comment #8)
> what's the status here?

Reviewing this afternoon.

https://github.com/mozilla-services/android-sync/pull/156
https://github.com/mozilla-services/android-sync/pull/155
Pushed with review comments self-addressed:

https://hg.mozilla.org/integration/mozilla-inbound/rev/3e5b3359a469
Whiteboard: [sync] → [sync][qa+]
Target Milestone: --- → mozilla14
Flags: in-litmus?
Attached patch Disabler.Splinter Review
Looks like the Fennec CP can be crashy. If that doesn't get resolved soon, here's a patch to disable password sync.
https://hg.mozilla.org/mozilla-central/rev/3e5b3359a469
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Depends on: 744816
(In reply to Richard Newman [:rnewman] from comment #13)
> Temporarily disabled until Bug 744816 is resolved.
> 
> https://hg.mozilla.org/integration/mozilla-inbound/rev/bbfe59782089

This was re-enabled by

changeset:   91647:190a237b1456
user:        Nick Alexander <nalexander@mozilla.com>
date:        Fri Apr 13 19:41:40 2012 -0700
summary:     Bug 739629 - Expose safe account creation API for profile migration. r=rnewman
Status: RESOLVED → VERIFIED
Whiteboard: [sync][qa+] → [sync][qa!]
Product: Mozilla Services → Android Background Services
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.