Closed Bug 709742 Opened 10 years ago Closed 9 years ago

Can't upload a media file in touch.facebook.com

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(blocking-kilimanjaro:+)

RESOLVED FIXED
blocking-kilimanjaro +

People

(Reporter: khris, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: top50, Whiteboard: [MTD])

Attachments

(1 file)

I think it is a fault of touch.facebook.com. Because when I change my user-agent with "Request desktop site", `Photo` button is enabled(in mobile site). And I can upload media files and it works.

It's not a bug in Fennec but I think it should be reported.
Whiteboard: [MTD]
Not sure, I'm pretty sure we support the technologies and API's they are using (i.e., local storage). Is there something Facebook is using on that page that Gecko does not yet support?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: General → Evangelism
QA Contact: general → evangelism
Attached image Screenshot
Duplicate of this bug: 717617
Keywords: top50
blocking-kilimanjaro: --- → ?
Facebook is the #2 site on alexa. Also happens a top app. This relates to mobile web compatibility story for k9o, so nominating for kilimanjaro.
blocking-kilimanjaro: ? → +
I sent a complaint to them via https://www.facebook.com/help/contact/?id=238478049542306. Not sure if some web form is the best way for this. Don't we have some Facebook contact in bugzilla which we can CC to such bugs?
This issue is still occurring on the latest nightly.
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Is there anything we can change on the Mozilla end to support this?  Thanks.
We may be able to get around this by spoofing the UA we send to Facebook to be the Android UA. We'll have to test well as this may introduce other issues.
Filed a bug internally at FB.
Duplicate of this bug: 829804
Duplicate of this bug: 854311
Duplicate of this bug: 854318
Has Facebook acknowledged the issue?
Duplicate of this bug: 854311
(In reply to Aaron Train [:aaronmt] from comment #13)
> Has Facebook acknowledged the issue?

Yes. Harald is working with Facebook on a shortlist of outstanding issues that includes this one.
How about this issue?
Duplicate of this bug: 865097
I'm seeing different behavior here on FxAndroid today - haven't had the chance to fully test yet. qawanted for retest.
Keywords: qawanted
Note - FF OS vs. FxAndroid from what I quickly saw now get entirely different content served to each other.
Aaron has confirmed with a simple test pass that this is now working on FxAndroid. I'll file a separate bug though for FF OS, given that we'll still have to do outreach there separately.
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: qawanted
Resolution: --- → FIXED
Filed bug 867357 for the FF OS specific issue.
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.