If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Block sales to pending paypal accounts

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: andym, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Sales of apps seems to be occurring to accounts that are: "The payment is pending because it was made to an email address that is not yet registered or confirmed.". This despite our best attempts. We should be blocking sales of those or coping more gracefully with the outcome.

But the sale shouldn't go through in my opinion.
Sounds like we shouldn't even mark an add-on as requiring payment until we can confirm the account.  Hopefully something that can be done via API?
(Reporter)

Comment 2

6 years ago
Yeah, I'd like the get paykey check in bug 697805 to block the paypal setup form. Also because a user can alter their paypal settings at any time, I'd like 710388 done too.

All this is pending investigation with what happens when the payment chain is setup to mozilla. All bets are off until I see how Paypal responds to this in that scenario.
(Reporter)

Updated

6 years ago
Depends on: 719203
(Reporter)

Updated

5 years ago
Assignee: amckay → nobody
Priority: P1 → --
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.