Last Comment Bug 711515 - Opening links from external apps doesn't work if session restore is active
: Opening links from external apps doesn't work if session restore is active
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal with 1 vote (vote)
: Firefox 12
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
: Sebastian Kaspari (:sebastian)
Mentors:
: 712001 712077 714742 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-16 10:02 PST by Joe Drew (not getting mail)
Modified: 2016-07-29 14:21 PDT (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified
11+


Attachments
patch (3.36 KB, patch)
2012-01-03 14:47 PST, Mark Finkle (:mfinkle) (use needinfo?)
mbrubeck: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description User image Joe Drew (not getting mail) 2011-12-16 10:02:29 PST
If Fennec isn't running and I click on a link from (for example) Twitter, Fennec starts up to about:home, and never loads the URL. If, however, it's already running, the link opens in a new tab as expected.
Comment 1 User image Mark Finkle (:mfinkle) (use needinfo?) 2011-12-16 10:20:40 PST
This works for me. The about:home screen does appear, but then we load the external page.

bug 711184 should fix the flash of about:home

Can you check this with a new nightly?
Comment 2 User image Joe Drew (not getting mail) 2011-12-16 11:08:17 PST
Yeah, seems like this works now. Weird.
Comment 3 User image Joe Drew (not getting mail) 2011-12-17 16:12:50 PST
OK, it seems as though this doesn't work if Fennec is killed by Android (I guess the session is being restored), but it *does* work if you explicitly quit Fennec from the menu.
Comment 4 User image :Margaret Leibovic 2011-12-19 08:12:35 PST
Phil and I have been experiencing this as well, and it's pretty annoying.
Comment 5 User image Aaron Train [:aaronmt] 2011-12-19 08:18:51 PST
*** Bug 712001 has been marked as a duplicate of this bug. ***
Comment 6 User image Kevin Brosnan [:kbrosnan] 2011-12-19 15:45:56 PST
*** Bug 712077 has been marked as a duplicate of this bug. ***
Comment 7 User image David Burns :automatedtester 2011-12-20 04:07:25 PST
This is an FYI

I can't open any links from twitter app. First time opens about:home the next time says the URL is invalid. I detailed it in bug 712001. Not sure if it is related to OOM.
Comment 8 User image Henrik Skupin (:whimboo) 2011-12-21 08:58:49 PST
David, I have the same problem and see the same failure. I can verify that the workaround from comment 3 (explicitly quit Fennec) works. Beside the non-loading I also see a lot of flickering across the whole screen.
Comment 9 User image Philipp von Weitershausen [:philikon] 2011-12-28 21:29:43 PST
(In reply to Margaret Leibovic [:margaret] from comment #4)
> Phil and I have been experiencing this as well, and it's pretty annoying.

Indeed. And I hate to pile on this with a "me too", but given that this bug is two weeks old now and hasn't seen any progress, let me say this: It is actually the biggest offender among the several bugs that don't make me want to use Fennec Nightlies. Largely because of it I have now started using the built-in browser or older versions of Fennec for some things, just because Fennec doesn't do the *one* thing it's supposed to do: browse.
Comment 10 User image Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-28 21:37:25 PST
(In reply to David Burns :automatedtester from comment #7)
> This is an FYI
> 
> I can't open any links from twitter app. First time opens about:home the
> next time says the URL is invalid. I detailed it in bug 712001. Not sure if
> it is related to OOM.

I believe that bug 712761 is more closely related to what you are experiencing.  The command line that I am running to open a link is similar to what other apps are using to open fennec.
Comment 11 User image Tim Abraldes [:TimAbraldes] [:tabraldes] 2011-12-29 02:22:03 PST
I'm seeing this issue as well:
  1) Open Fennec (doesn't matter if I navigate anywhere)
  2) Switch to another app and try to launch a link
  3) Fennec will flicker and resize a bunch, then will show whatever page was up at the beginning of step 2

If I close Fennec (using the "Quit" menu item) between steps 1 and 2 then the link launches just fine
Comment 12 User image Pedro Alves 2011-12-29 02:38:03 PST
In addition to the previous, sometimes I also get a 'url is invalid' and nothing gets loaded
Comment 13 User image Mark Finkle (:mfinkle) (use needinfo?) 2011-12-29 07:14:27 PST
Comment 11 and comment 12 are exactly bug bug 712761
Comment 14 User image Henrik Skupin (:whimboo) 2011-12-30 05:19:39 PST
Those are not only comment 11 and comment 12, but even the initial comment. Sadly this bug hasn't been picked up and work happens on another one. So lets get it duped to bug 712761.

*** This bug has been marked as a duplicate of bug 712761 ***
Comment 15 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-02 12:29:40 PST
Working under the assumption that this is happening because of a conflict with session restore.
Comment 16 User image Randell Jesup [:jesup] 2012-01-03 14:35:57 PST
I've been seeing this for weeks as well, this makes fennec native basically useless.  Droid Charge (i510.06)  (now running Android 2.3.6)

Fails with nightly and aurora.  I hadn't realized the Quit workaround worked well, this has basically driven away from using fennec on a daily basis as I had been.  I was working around by touching the URL bar, making an innocuous change and loading.
Comment 17 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-03 14:42:13 PST
*** Bug 714742 has been marked as a duplicate of this bug. ***
Comment 18 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-03 14:47:09 PST
Created attachment 585565 [details] [diff] [review]
patch

This patch steals some code from XUL Fennec:
* Add more code to browser.js to handle opening an external URL _and_ handling session restore.
  * We open the external URL and then do the restore
  * The external URL should be active and in front, not the restored tabs
* SessionStore.js needs to respect the aBringToFront param

I tested this on my nexus one. After loading a few tabs and then waiting so the session is saved, I killed Fennec. I then used twitter to open an external URL into Fennec. The URL was opened and made active, while the old tabs were created as phantom tabs.
Comment 19 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-03 17:23:56 PST
*** Bug 714972 has been marked as a duplicate of this bug. ***
Comment 20 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-03 22:23:48 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/acd18cd340b0
Comment 21 User image Ed Morley [:emorley] 2012-01-04 17:30:14 PST
https://hg.mozilla.org/mozilla-central/rev/acd18cd340b0
Comment 22 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-10 12:51:49 PST
Comment on attachment 585565 [details] [diff] [review]
patch

[Approval Request Comment]
Needed for proper application behavior. Baked on m-c for several days.
Comment 23 User image Alex Keybl [:akeybl] 2012-01-11 13:35:22 PST
Comment on attachment 585565 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 24 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-16 22:40:00 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/d4551d31292d
Comment 25 User image Catalin Suciu [:csuciu] 2012-01-19 02:40:40 PST
Verified fixed on Nightly 12.0a1 (2012-01-18) and on Aurora 11.0a2.
Device: Samsung Galaxy S2 (Android 2.3.4)

Note You need to log in before you can comment on or make changes to this bug.