Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 674718
6 years ago
12 days ago

People

(Reporter: qdot, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 3 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tech-p1])

Meta bug for USB Implementation on B2G
Story so far: 

- WebUSB is somewhat implemented but currently without a lead dev, jstraus is checking with jorendorff about linux status.
- gal is checking out how android implements USB without libusb, is worried about licensing
- jstraus has libusb built for gonk

Comment 2

6 years ago
jorendorff replied that he ended up never working on WebUSB.  He was working on game controllers and didn't need to talk directly to the USB.  May be completely orphaned?  Added the original WebUSB bug to this to keep track of it.
Depends on: 674718
Some clarifications:

- Bug 674718 seems to be around "usb host" implementation. For a phone, shouldn't acting as a "usb gadget" be considered, too?
- The implementation for windows and mac are notifications when a usb device is plugged/unplugged. On gonk this would be receiving uevent. Generic usb programmng is still to be implemented.
- libusb is for usb host implementation. For gadget implementation we might need something like "libusb-gadget".
- If there is concern using libusb, then we may implement it on our own (it doesn't seem to be a very heavy layer of implementation) by opening the device file and perform ioctl calls.

Updated

5 years ago
Depends on: 748350
Blocks: 844910
Needed for competitive parity.
Whiteboard: [tech-p1]

Updated

3 years ago
Blocks: 1035050

Updated

3 years ago
Blocks: 1029961

Updated

12 days ago
Status: NEW → RESOLVED
Last Resolved: 12 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 674718
You need to log in before you can comment on or make changes to this bug.