Closed Bug 711693 Opened 8 years ago Closed 8 years ago

Send the compatibility mode when loading the Discovery pane

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla12

People

(Reporter: Unfocused, Assigned: Unfocused)

References

Details

Attachments

(1 file)

For the discovery pane to show the most accurate recommendations, it needs to know what compatibility mode Firefox is in.
Note: I don't think this should hold up enabling compatible-by-default in Fx10. The impact is just in the accuracy of the recommendations displayed in the Discovery ("Get Add-ons") pane in the Add-ons Manager, where currently it won't display addons that aren't explicitly known to be compatible (ie, would be compatible only in "strict" mode). However, the Firefox version number is already sent - so AMO can just assume compatible-by-default for Firefox 10 onwards, and that will be correct for everyone that hasn't set one of the hidden preferences that affect the compatibility mode.
Depends on: 711698
Depends on: 711700
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Depends on: 711701
Attached patch Patch v1Splinter Review
Note: This can't land until bug 711701 is fixed and goes live on the production site.
Attachment #582741 - Flags: review?(dtownsend)
This fixes part 2 of bug 570033.
Blocks: 570033
Attachment #582741 - Flags: review?(dtownsend) → review+
https://hg.mozilla.org/integration/fx-team/rev/780d0952d028
Flags: in-testsuite+
Flags: in-litmus-
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla12
https://hg.mozilla.org/mozilla-central/rev/780d0952d028
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
You need to log in before you can comment on or make changes to this bug.