Last Comment Bug 692664 - Make add-ons compatible by default
: Make add-ons compatible by default
Status: VERIFIED FIXED
[qa!]
:
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: Trunk
: All All
: P1 normal with 4 votes (vote)
: mozilla11
Assigned To: Blair McBride [:Unfocused] (UNAVAILABLE)
:
Mentors:
https://wiki.mozilla.org/Features/Add...
Depends on: 570033 695581 527141 670302 691834 693897 693899 693901 693906 695977 698653 700201 704300 705530 706387 711693
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-06 17:11 PDT by Blair McBride [:Unfocused] (UNAVAILABLE)
Modified: 2013-04-23 13:17 PDT (History)
28 users (show)
hskupin: in‑testsuite?
virgil.dicu: in‑litmus+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified


Attachments

Description Blair McBride [:Unfocused] (UNAVAILABLE) 2011-10-06 17:11:06 PDT
Make add-ons compatible with new versions of Firefox by default.

Feature definition is at:
 https://wiki.mozilla.org/Features/Add-ons/Add-ons_Default_to_Compatible

See also the AMO side of this at bug 691834.
Comment 1 Lawrence Mandel [:lmandel] (use needinfo) 2011-11-17 07:02:34 PST
As per this discussion

http://groups.google.com/group/mozilla.dev.apps.firefox/browse_thread/thread/1c3162bb7989dd6b#

I don't see personas called out specifically as included or excluded from the feature. Will personas be included in the add-ons default to compatible work?
Comment 2 Lawrence Mandel [:lmandel] (use needinfo) 2011-11-17 07:05:10 PST
This question was also raised in bug 693901.
Comment 3 Dave Townsend [:mossop] 2011-11-17 09:36:08 PST
Personas are always compatible so there is no change to them
Comment 4 Maniac Vlad Florin (:vladmaniac) 2011-12-09 07:07:31 PST
Requesting in-litmus? flag for virgil since he is the Qa owner for this feature
Comment 5 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-12-11 17:19:37 PST
Cautiously but optimistically calling this "fixed". All the major parts are done, and it's just been enabled on Aurora. There are still some things to be done in followup releases, but IMO they're not required to call the feature "complete".
Comment 6 Virgil Dicu [:virgil] [QA] 2012-01-25 08:04:21 PST
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a2) Gecko/20120124 Firefox/11.0a2
Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Windows NT 6.1; rv:11.0a2) Gecko/20120124 Firefox/11.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:11.0a2) Gecko/20120124 Firefox/11.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0

Marking this as verified now that Firefox 10Beta 6 is available.

Implementation work has finished. QA has been tracking this feature starting with Firefox Nightly and all known issues are specified in dependencies. 

The test plan lists all the work done: https://wiki.mozilla.org/Features/Add-ons/Add-ons_Default_to_Compatible/TestPlan
Community testing did not reveal any issues as specified in the testday testplan: https://etherpad.mozilla.org/testday-20120113

Individual bug verification is complete (only bug 705530 remaining from the ones that can be checked outside AMO-no add-ons to use at the moment there)

Litmus test have been added in Firefox-Firefox 10-Basic Functional tests- Silent Update-Default Compatible Add-ons

Note You need to log in before you can comment on or make changes to this bug.