Closed Bug 71173 Opened 20 years ago Closed 20 years ago

find only works once in view page source window

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: vanbalen, Assigned: jag+mozbugs)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-21mdk i686; en-US; 0.8.1)
Gecko/20010306
BuildID:    2001030609

when viewing the source code for a page, one can only run the search window
once. After hitting cancel, the search dialog will not run again until the view
source window is closed and reopened.

Reproducible: Always
Steps to Reproduce:
1.) Go to any web page (this page should do) and select View->Page Source.
2.) Hit Ctrl+f with focus on the page source window to run the search dialog.
3.) search for something and hit cancel.
4.) You decide you want to search for something else so you hit Ctrl+f again
and, what's this?, the search dialog doesn't appear.
5.) You may not try clicking on the window to make sure it's got focus or you
can repeatedly hit ctrl+f in frustration... all to no avail.
6.) Close the page source window and select View->Page Source again. You may now
run the search dialog one more time!

Actual Results:  Search dialog may only be run once per page source window.

Expected Results:  I should be able to run it as many times as I want.
I also see this behavior in Build 2001030605 on Windows 2000.
confirming. bill, would this be yours?
Assignee: ben → law
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta1, regression
OS: Linux → All
Hardware: PC → All
This looks like another one of those bugs that Jag's been puzzling over.

On the second Ctrl-F, I get this assertion (I'm using a debug build):
###!!! ASSERTION: No 'Components' in scope!: '0', file d:\serverMode\mozilla\js\
src\xpconnect\src\xpcwrappednativescope.cpp, line 202
Assignee: law → disttsc
depends on 71822
Depends on: 71822
No longer depends on: 71822
Summary: search only works once in view page source window → find only works once in view page source window
No longer blocks: 79518
Blocks: 79518
With the find rewrite/refactoring this problem seems to have gone away... can
anyone still reproduce it?  worksforme linux build 2001-05-08-14
I think you're right. Confirming on 2001050708/Linux
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
vrfy fixed with 16:44 debug build.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.