Graphite2 adds many compiler warnings

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: gps, Assigned: jfkthame)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
When Graphite was enabled, it created a bunch of new compiler warnings:

http://jenkins.gregoryszorc.com:9000/job/mozilla-central/223/

This recorded 94 new compiler warnings on Windows.

Most of the errors look like:

  'gr_tag_to_str' : inconsistent dll linkage

or

  locally defined symbol _gr_face_find_fref imported in function "public: virtual bool __thiscall gfxGraphiteShaper::InitTextRun(class gfxContext *,class gfxTextRun *,wchar_t const *,unsigned int,unsigned int,int)" (?InitTextRun@gfxGraphiteShaper@@UAE_NPAVgfxContext@@PAVgfxTextRun@@PB_WIIH@Z)

See http://jenkins.gregoryszorc.com:9000/job/mozilla-central/223/warningsResult/new/? for the full list. I can't guarantee that site will be available forever. To reproduce in case it is gone, just compile on Windows and watch the output.

Updated

7 years ago
Assignee: nobody → jfkthame

Updated

7 years ago
Duplicate of this bug: 712405
(Assignee)

Updated

7 years ago
Duplicate of this bug: 715880
(Assignee)

Updated

7 years ago
Depends on: 721068
(Assignee)

Comment 4

3 years ago
Closing this as WFM. We have taken numerous new graphite library versions since this was filed, and I don't see these warnings in current Windows build logs. Please re-open if I'm missing something and this is still an issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.