Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Add GPS-A support on android

RESOLVED FIXED in Firefox 11

Status

()

Firefox for Android
General
P3
enhancement
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Cristobal Arellano, Assigned: dougt)

Tracking

Trunk
Firefox 12
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox11 fixed, firefox12 fixed, fennec11+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.12 Safari/535.11

Steps to reproduce:

Terminal: Google Samsung Galaxy Nexus with Android Sandwich

In Firefox Mobile, go to http://html5demos.com/geo.
In Native Browser, go to http://html5demos.com/geo.


Actual results:

In Firefox Mobile:
If the GPS-D (normal GPS) has acquired the minimun number of satellites (4), it works. In other case it fails.

In Native Browser: It works without the acquistion of number of satellites (without GPS-D). It is supposed that GPS-A is used.


Expected results:

The same behaviour of Native Browser is expected.

I cannot find the exact line in the code but it is related with the usage of LocationManager.GPS_PROVIDER (LocationManager.NETWORK_PROVIDER should be added).
(Reporter)

Updated

6 years ago
OS: Windows 7 → Android
Hardware: x86_64 → ARM
(Reporter)

Updated

6 years ago
Severity: normal → enhancement
(Assignee)

Updated

6 years ago
Assignee: nobody → doug.turner
Priority: -- → P3
(Assignee)

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

6 years ago
Duplicate of this bug: 712575
tracking-fennec: --- → 11+
(Assignee)

Comment 2

6 years ago
i am not working on these right now.  resetting assignee.
Assignee: doug.turner → nobody
(Assignee)

Updated

6 years ago
Duplicate of this bug: 717935
(Assignee)

Updated

6 years ago
Assignee: nobody → doug.turner
(Assignee)

Comment 4

6 years ago
Created attachment 588535 [details] [diff] [review]
patch v.1
Attachment #588535 - Flags: review?(josh)

Comment 5

6 years ago
Comment on attachment 588535 [details] [diff] [review]
patch v.1

Seems reasonable.
Attachment #588535 - Flags: review?(josh) → review+
https://hg.mozilla.org/mozilla-central/rev/254f355a4a96
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
(Assignee)

Updated

6 years ago
Attachment #588535 - Flags: approval-mozilla-aurora?

Comment 7

6 years ago
Comment on attachment 588535 [details] [diff] [review]
patch v.1

[Triage Comment]
Mobile only - approved for Aurora.
Attachment #588535 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

6 years ago
status-firefox11: --- → fixed
status-firefox12: --- → fixed
You need to log in before you can comment on or make changes to this bug.