Yahoo Messenger within Yahoo Mail does not work in Firefox version 9

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: darleneclark2, Unassigned)

Tracking

({regression})

9 Branch
regression
Points:
---
Bug Flags:
in-litmus ?

Firefox Tracking Flags

(firefox9+ affected, firefox10- unaffected, firefox11- unaffected)

Details

(Whiteboard: workaround in Comment 7)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Posted image yahoo.png
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

I tried to use Yahoo Messenger within Yahoo Mail.  It does not work in version 9.  It worked in version 8.


Actual results:

Nothing.


Expected results:

You should click on a contact and a messenger window opens up.  It does not.  Yahoo referred me to you, they think it must be your problem.

Comment 1

7 years ago
Have you tried "Basic Troubleshooting"[1] procedures?

[1] https://support.mozilla.com/en-US/kb/Basic%20Troubleshooting
(Reporter)

Comment 2

7 years ago
I did the first 6, but when I reset my settings to the default, I had to manually set everything back.  So I'll stop there before I cause any more trouble.  Is there anyone who could check the Yahoo mail messenger and see if it happens to them?
I can reproduce this using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20100101 Firefox/9.0.1. I tried launching from under my contacts and it does work in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20100101 Firefox/8.0.1 - Firefox 9.0.1 nothing happens when I select the Yahoo Messenger ID under contacts.

The question is whether Yahoo made some kind of change on their side of whether this is our bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
This occurs on Mac as well, using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0.1) Gecko/20100101 Firefox/9.0.1 but works for me using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a1) Gecko/20111222 Firefox/12.0a1.

We will need to hunt down a regression range.
Keywords: qawanted, regressionwindow-wanted
OS: Windows 7 → All
Hardware: x86 → All
Duplicate of this bug: 712866
I found a workaround to get chat to work.

STR:
1. Go into your Yahoo Messenger Options - Change the Window in the dropdown to Tab and press OK.
2. Then go back and switch it to small window and press OK.

After that I can get the chat window to launch. I tested on Mac as well as that workaround works.
Whiteboard: workaround in Comment 7

Comment 8

7 years ago
Yes that seemed to work for me also.  

It would be nice to know why though.
(Reporter)

Comment 9

7 years ago
I've tried to access the messenger options about 25 times.  Usually it does not open, but the three times it did open, I got a circle with a line through it for a cursor and everything was grayed out.  Weird.
(Reporter)

Comment 10

7 years ago
I did get it to work after all.  I had to click on one of my contacts before it would open my messenger options.  It does fix it, but you have to do it every time you sign out and back in.  Thanks for the fix, though.

Comment 11

7 years ago
Yep it goes right back to the initial failure mode once you log back in again.

Comment 12

7 years ago
Firefox Upgrade to Version 9.0 on 25 Dec 2011. Had to switch to IE to use Yahoo Mail and see the IM/Chat window, which does not work now on Firefox. A large problem for a LOT of people. I don't like using IE ... It's very unfortunate. Please fix this as soon as possible. Thank you for a wonderful browser, otherwise.

Comment 13

7 years ago
Addition Comment on Firefox Upgrade to Version 9.0 and Inability to Access Instant Messenger (CHAT) on Yahoo Mail: Yahoo Mail Instant Messenger is also not available from the Yahoo Mail Options dropdown menu.

Comment 14

7 years ago
@val You have to go to Options > Messenger Options.
http://input.mozilla.com/en-US/?product=firefox&date_end=&date_start=&platform=win7&version=9.0.1&q=Yahoo are some other users reporting the same problem.

Adding Cheng from the SUMO side in case they are getting questions about this issue.
tracking-firefox10: --- → +
tracking-firefox11: --- → +
tracking-firefox9: --- → +
It should post in known issue list in current Firefox version
I cannot reproduce this in Firefox 10 beta 1 -  Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0 or the equivalent version on Mac. Before the break I also checked on the latest Windows nightly and it worked. So the issue seems to be confined to Firefox 9.
I'm inclined to let this issue ride assuming:
 * it's confined to Firefox 9
 * the workaround works 100% and is communicated

We need to get confirmation that this is confined to Firefox 9 though...
I tried the user agent switch which Cheng suggested in the channel meeting (Changing the user agent in a 9.0.1 build to 8.0.1) and Yahoo Messenger chat window still would not work for me unless I invoked the workaround in Comment 7.

I also confirmed that after you restart the browser you will have to invoke the workaround again.

I also went back and tried 9.0b1 and the issue existed in that build as well. I haven't been able to reproduce the issue in 8.0.1, trunk or Aurora as of yet.

Comment 20

7 years ago
I just installed 10b1 and it seems to work fine.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0) Gecko/20100101 Firefox/9 beta 1
Mozilla/5.0 (X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Mozilla/5.0 (X11; Linux i686; rv:9.0) Gecko/20100101 Firefox/9.0 beta 6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0 beta 6

STR:
1. Install Firefox 9.0.1.
2. Login to mail.yahoo.com
3. Sign in to yahoo messenger and wait for the contact list to get populated.
4. Click on one contact in the list.
Actual result for Firefox 9: No chat windows is opened

Reproducible on all platforms (checked on Mac OS 10.6, Ubuntu 11.10 i686, Windows 7).

Reproducible with any Firefox 9 (8b1, 9b2, ...9.0, 9.0.1, Firefox Aurora). 


Does not occur on any other Firefox: Firefox 8.0, 8.0.1, Firefox10Beta1, Beta2, Aurora (current Firefox11), Nightly (current Firefox12).


The workaround from comment 7 works for selecting a contact from the list, but produces a series of issues:  can't access Options-Messenger Options, can't sign-off (the messenger contact list remains stuck when selecting the sign-off button), sometimes two windows or one window which doesn't display the ID are opened for a particular contact.

The issue is reproducible on the last Aurora (Gecko/20111107) build before the merge, but not reproducible on the last Firefox 9 Nightly before the merge (Gecko/20110926). Still hunting the regression window.
(In reply to Virgil Dicu [QA] from comment #21)
> Reproducible with any Firefox 9 (8b1, 9b2, ...9.0, 9.0.1, Firefox Aurora). 
typo here: 9b1 instead of 8b1

In addition, these are the error messages from Error Console in Firefox 9.0.1:

Error: no element found
Source File: http://prod2.rest-core.msg.yahoo.com/v1/subscription/presence?blocking=0&sid=r5QnStHs3Bh3R6RakqXo0N3hR21MHYiaGrfu&c=JIIfq.mVMw%2F&msgrAppId=mim&cache=1325153038366
Line: 1

Error: no element found
Source File: http://prod2.rest-core.msg.yahoo.com/v1/session?action=mpop-activate&sid=r5QnStHs3Bh3R6RakqXo0N3hR21MHYiaGrfu&c=JIIfq.mVMw%2F&msgrAppId=mim&cache=1325153046214
Line: 2

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMHTMLDocument.queryCommandState]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: http://3cp9lcoq32dpn-c.c.yom.mail.yahoo.com/om/api/1.0/openmail.app.invoke/3cp9lcoq32dpn/66/1.0.35/us/en-US/yimapp.html#bn=1.0.35&.lang=en-US&.intl=us&rtl=0&proxyhost=us.mg5.mail.yahoo.com&sig=6fa6f587a8ee1959e3bc07ea11cc7971&vid=yimapp&app=3cp9lcoq32dpn&mailver=neo&crumb=eMF5XcowMwa&cb=1325153034158 :: <TOP_LEVEL> :: line 5"  data: no]
These are the messages we received using Firebug when clicking on a contact the first time:

uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMHTMLDocument.queryCommandState]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: http://3cp9lcoq32dpn-c.c.yom.mail.yahoo.com/om/api/1.0/openmail.app.invoke/3cp9lcoq32dpn/66/1.0.35/us/en-US/yimapp.html#bn=1.0.35&.lang=en-US&.intl=us&rtl=0&proxyhost=us.mg5.mail.yahoo.com&sig=6fa6f587a8ee1959e3bc07ea11cc7971&vid=yimapp&app=3cp9lcoq32dpn&mailver=neo&crumb=eMF5XcowMwa&cb=1325153034158 :: <TOP_LEVEL> :: line 5" data: no]
Complex(r="1.1.13|6fa6f587a8ee1959..."$apiVersion":"1.1.13"}", e=undefined)combo?...-min.js (line 16)
(?)(H=message )b (line 0)
throttle()combo?...-min.js (line 6)
[Break On This Error] b.Attribute.Complex=function(){};b.Att...L.after){L.after_map=j.hash(L.after);
combo?...-min.js (line 16
The first build on which the issue is reproducible seems to be the first Firefox 9 Aurora (after the merge from Nightly)
Mozilla/5.0 (X11; Linux i686; rv:9.0a2) Gecko/20110928 Firefox/9.0a2 

The last Firefox 9 Aurora before the merge to Beta still contained this issue: 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a2) Gecko/20111106 Firefox/9.0a2 

The issue wasn't reproducible on the last Firefox 9 Nightly before the merge to Aurora: 
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:9.0a1) Gecko/20110927 Firefox/9.0a1
Flags: in-litmus?

Comment 25

7 years ago
I'm not sure comment 24 makes sense:

* If it was an existing issue / caused while Fx9 was on mozilla-central, it should have shown up in Nightly. Testing says it did not

* If it was caused by not backporting a "fix" from Aurora8 to Aurora9 after the source migration, it should have shown up in Nightly (as the "fix" wouldn't have been there either). Testing says it did not

* If it was caused by something landed on Aurora after the migration, it wouldn't have been in the first Aurora build. Testing says it was

So, I'm stumped as to where to look, as comment 24 isn't what I would expect in any case.

Comment 26

7 years ago
I tracked an issue down one time by running a group of nigthlys until I found the bad one.  I went a few nightlys ahead and behind until I eventually stumbled across it.  I thought someone already did that though?  If comment 24 makes no sense, then move past it.
I think the key to comment 24 is that Vlad reports the issue regressing between 20110927 (Firefox 9.0a1 Nightly) and 20110928 (Firefox 9.0a2 Aurora). Assuming nothing would/should have landed between those dates as the tree should have been closed for the merge.

@donb, can you confirm testing with those two builds?
Confirming testing on Mac with those two builds:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0a2) Gecko/20110928 Firefox/9.0a2 - Yahoo Messenger Chat window does not work for me. I also sometimes get a popup that says Yahoo Messenger is loading with an OK button.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0a1) Gecko/20110927 Firefox/9.0a1 the Yahoo Chat Messenger window does work.

Comment 29

7 years ago
I highly suspect this changeset/bug:

  http://hg.mozilla.org/releases/mozilla-aurora/rev/6acb018b5a1b

Bug 689564. Only forward event attributes on body/frameset to the window if we also forward the corresponding on* property. r=smaug, a=legneato 

If true, it means this may be a manifestation of bug 696020 (the regression caused by the above bug)

Can you try applying the fix in bug 696020 on top of Fx9 and see if this goes away?

Comment 30

7 years ago
@Anthony

20110927 (Firefox 9.0a1 Nightly) worked with Yahoo! Messenger via Yahoo! Mail.

20110928 (Firefox 9.0a2 Aurora) did NOT work with Yahoo! Messenger via Yahoo! Mail.
So how it looks like the regression went in between the last Nightly build and the merge process because also the Nightly from 2011-12-28 fails.

WORKS: http://hg.mozilla.org/mozilla-central/rev/1f800c226837
FAILS: http://hg.mozilla.org/mozilla-central/rev/7f4867717226

Change log:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1f800c226837&tochange=7f4867717226

There are a lot of changesets in that timespan. I will try with the above mentioned patch on an affected nightly build.
I'm not able to build Firefox on my own due to build errors. So I checked which Nighty build continues to work. It is the one from 2011-11-05:

FAILS: http://hg.mozilla.org/mozilla-central/rev/3491b2f021bf
WORKS: http://hg.mozilla.org/mozilla-central/rev/ae9e5bf847fc

Changesets:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3491b2f021bf&tochange=ae9e5bf847fc

(In reply to Christian Legnitto [:LegNeato] from comment #29)
> Can you try applying the fix in bug 696020 on top of Fx9 and see if this
> goes away?

Not sure if this patch will help because it doesn't fit into the above regression range.

Comment 33

7 years ago
FWIW I 1s missed Yahoo! Messenger within Yahoo! Mail on Nightly Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:11.0a1) Gecko/20111206 Firefox/11.0a1 on this Mozillazine forum post[1] but no one could confirm.

Yahoo! Messenger within Yahoo! Mail works for me today on Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:12.0a1) Gecko/20111231 Firefox/12.0a1 ID:20111231034523

[1] http://forums.mozillazine.org/viewtopic.php?p=11541185#p11541185
So in Firefox 10 it has been implicitly fixed by the implementation of the event.stopImmediatePropagation feature on bug 698929.

Now I will try again if I can find the real regression range by compiling older builds. I hope that I can fix those build errors.
(In reply to Henrik Skupin (:whimboo) from comment #34)
> Now I will try again if I can find the real regression range by compiling
> older builds. I hope that I can fix those build errors.

Sorry but I can't really get it to build due to bug 697821. I hope the information I have provided is enough to find the cause.

Comment 36

7 years ago
Any fixes to the Yahoo mail and messenger problems as of yet. Mine are still valid. Yahoo mail is messed up when referencing messenger or mail preferences or contacts. Please help. Thanks.

Comment 37

7 years ago
@mike, just install the latest Beta.

Comment 38

7 years ago
thanks. How do I do this? Thanks for your reply and help. Have a good day. Mike

Comment 39

7 years ago
(In reply to donb from comment #37)
> @mike, just install the latest Beta.

Great. How do I do this donb? Thanks for your reply and help. Have a good day.

Comment 40

7 years ago
Please Mike, don't use the bug report as a general support board, there is https://support.mozilla.org/en-US/home or http://forums.mozillazine.org/viewforum.php?f=49 for your questions.

Comment 41

7 years ago
i updated java runtime and after that it came back to normal.
(In reply to Henrik Skupin (:whimboo) from comment #34)
> So in Firefox 10 it has been implicitly fixed by the implementation of the
> event.stopImmediatePropagation feature on bug 698929.
> 
> Now I will try again if I can find the real regression range by compiling
> older builds. I hope that I can fix those build errors.

Please correct me if I set these flags incorrectly, but it does not appear that FF10 is affected, which means we no longer need to track.
status-firefox10: --- → unaffected
status-firefox11: --- → unaffected
tracking-firefox10: + → -
tracking-firefox11: + → -
Juan and I were given ownership of tracking down the regression range in this bug. I followed up with Henrik and he is still stalled by the issue in Comment 35. So we would have to go the tryserver route or find some additional help bisecting if we want to still spend additional cycles on this.

Firefox 10 is definitely not affected. Just trying to figure out where this should fall in the list of priorities.
(In reply to Marcia Knous [:marcia] from comment #43)
> Firefox 10 is definitely not affected. Just trying to figure out where this
> should fall in the list of priorities.

Drivers, if this bug is important enough to nail down the causing changeset, I would kinda like to see a statement. In such a case I will setup another build box and testing through the remaining range. Thanks.
I have setup a new 10.6 box for building Firefox. The build process doesn't fail due to errors. I will come up with the exact regression changeset later today.
Current bisect shows:

The first bad revision is:
changeset:   77651:e2f5052798cc
parent:      77594:1f800c226837
parent:      77650:6d691de3932b
user:        Matt Brubeck <mbrubeck@mozilla.com>
date:        Mon Sep 26 19:09:08 2011 -0700
summary:     Merge mozilla-central to mozilla-inbound

I have to extend bisecting to find the real changeset. I will not be able to give that today. I will start early tomorrow.

Comment 47

7 years ago
I reinstalled to an earlier version 7 of firefox for a temporary fix.

Comment 48

7 years ago
(In reply to darlene from comment #0)
> Created attachment 583845 [details]
> yahoo.png
> 
> User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101
> Firefox/9.0.1
> Build ID: 20111220165912
> 
> Steps to reproduce:
> 
> I tried to use Yahoo Messenger within Yahoo Mail.  It does not work in
> version 9.  It worked in version 8.
> 
> 
> Actual results:
> 
> Nothing.
> 
> 
> Expected results:
> 
> You should click on a contact and a messenger window opens up.  It does not.
> Yahoo referred me to you, they think it must be your problem.

Upgrading to the latest FF Beta version solved this for me.
Link - http://www.mozilla.org/en-US/firefox/channel/
status-firefox9: --- → affected
This has been regressed with:

https://hg.mozilla.org/mozilla-central/rev/c8e237c03adb

The first bad revision is:
changeset:   77617:c8e237c03adb
user:        Boris Zbarsky <bzbarsky@mit.edu>
date:        Mon Sep 26 17:27:13 2011 -0400
summary:     Bug 185236 part 5.  Fire load and error events on stylesheet linking elements.  r=peterv

I think everything QA can do has been done now. Removing keyword fields.
status-firefox9: affected → ---
Keywords: qawanted, regressionwindow-wanted
status-firefox9: --- → affected
(Reporter)

Comment 50

7 years ago
I want to thank everyone for their hard work on this bug.  I upgraded to the latest beta version as a temporary fix.
This is sounding like an evang bug, given comment 49 and comment 34.  At a guess, the page has a capturing load event listener, tries to stop propagation of those events, etc... and it started getting events it did not expect.

Updated

7 years ago
Duplicate of this bug: 718363

Comment 53

7 years ago
As expected, it works fine in Firefox 10. Yahoo Messenger chats are open normally (as tab or small window) and Yahoo Messenger options are reachable in the menu.
Given the release of Firefox 10, can we call this WONTFIX?
i cant reproduce this issue on Fx 10
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 723607
You need to log in before you can comment on or make changes to this bug.