Last Comment Bug 713067 - maps.google.com cannot determine the location after sharing Geolocation
: maps.google.com cannot determine the location after sharing Geolocation
Status: RESOLVED DUPLICATE of bug 713991
[fennec-10.0b1]
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 10
: ARM Android
: -- normal (vote)
: ---
Assigned To: Tony Chung [:tchung]
:
:
Mentors:
http://maps.google.com
: 713152 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-22 12:30 PST by Naoki Hirata :nhirata (please use needinfo instead of cc)
Modified: 2012-08-20 15:58 PDT (History)
12 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-22 12:30:48 PST
1. download install 10 beta 1
2. make sure that location is set on android device settings
3. launch fennec beta
4. make sure js setting is turned on
5. go to maps.google.com
6. click share for the geolocation notification

Expected: location is determined by maps.google.com
Actual: "Your location could not be determined."

Note: 
1. Beta 10 b1 ; samsung galaxy s II ; os 2.3
2. also tested with : http://mozqa.com/data/firefox/geolocation/wifi.html and it shows blank.
Comment 1 Aaron Train [:aaronmt] 2011-12-22 12:47:02 PST
Tried this out, no errors in console. Also tried, http://benwerd.com/lab/geo.php. 


D/WifiService( 2715): acquireWifiLockLocked: WifiLock{NetworkLocationProvider type=2 binder=android.os.BinderProxy@40911d98}
D/WifiService( 2715): releaseWifiLockLocked: WifiLock{NetworkLocationProvider type=2 binder=android.os.BinderProxy@40911d98}
D/WifiService( 2715): acquireWifiLockLocked: WifiLock{NetworkLocationProvider type=2 binder=android.os.BinderProxy@40911d98}
V/WifiMonitor( 2715): Event [ SCAN-RESULTS ]
I/wpa_supplicant( 2849): SCAN_RESULTS : [6] 
I/wpa_supplicant( 2849): SCAN_RESULTS : [6] 
D/WifiService( 2715): releaseWifiLockLocked: WifiLock{NetworkLocationProvider type=2 binder=android.os.BinderProxy@40911d98}
Comment 2 christian 2011-12-22 14:51:42 PST
[triage comment]
Possible topsite regression. Tracking.
Comment 3 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-22 18:01:46 PST
Happens in 9 as well.
Comment 4 Tony Chung [:tchung] 2011-12-22 18:04:02 PST
*** Bug 713152 has been marked as a duplicate of this bug. ***
Comment 5 Tony Chung [:tchung] 2011-12-22 18:08:47 PST
http://mozqa.com/data/firefox/geolocation/wifi.html is another testcase that fails the repro.   

Can we get a fix for this in the next beta?

QA will hunt for a regression range.
Comment 6 Matt Brubeck (:mbrubeck) 2011-12-22 18:18:00 PST
This is working for me in Firefox 9 (Market build) and 10 (recent Aurora build), on Samsung Galaxy Tab 7" and HTC T-Mobile G2, both running Android 2.3.

I tested several times, and I did see the "Location could not be determined" popup once during one of those trials.  I think there's a problem where geolocation is very slow on Android and some pages display errors if a location isn't returned soon enough.  I thought we had a bug on this but I can't find it now.

Does Google Maps find your location correctly if you wait ~30 seconds and then press the "my location" (target/crosshairs) button again?
Comment 7 John Hammink 2011-12-22 18:25:59 PST
On my tests Firefox 9 and 10, I am running Samsung Galaxy S II.  The page is completely blank.
Comment 9 Brad Lassey [:blassey] (use needinfo?) 2011-12-22 20:51:58 PST
bug 712575 says that we can't use non-gps based location. Can you make sure your gps is on and perhaps test outside with a view of the sky?
Comment 10 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-22 21:29:46 PST
When I wrote this bug, I used the default browser and the default browser worked fine.  I also asked several other people to confirm this bug.  I'll hunt the regression tomorrow along with a couple of other bugs.
Comment 11 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-22 21:30:34 PST
some how :mfinkle because a crash signature?  putting him in the :cc and removing him from the crash signature.  :)
Comment 12 Tony Chung [:tchung] 2011-12-23 07:39:04 PST
(In reply to Matt Brubeck (:mbrubeck) from comment #6)
> This is working for me in Firefox 9 (Market build) and 10 (recent Aurora
> build), on Samsung Galaxy Tab 7" and HTC T-Mobile G2, both running Android
> 2.3.
> 
> I tested several times, and I did see the "Location could not be determined"
> popup once during one of those trials.  I think there's a problem where
> geolocation is very slow on Android and some pages display errors if a
> location isn't returned soon enough.  I thought we had a bug on this but I
> can't find it now.
> 
> Does Google Maps find your location correctly if you wait ~30 seconds and
> then press the "my location" (target/crosshairs) button again?

i just tried this on my Galaxy Nexus, and got the same results.  "location not determined" showed up twice.  Continue tapping the location button a few times, wait around 30 seconds, and yes, eventually i got my dot to show up where i'm at.

I dont recall this always being this way.   we'll try and hunt down a regression.
Comment 13 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-29 13:32:43 PST
see : https://bugzilla.mozilla.org/show_bug.cgi?id=713991#c16
Comment 14 Cristian Nicolae (:xti) 2011-12-30 04:28:56 PST
I tried to reproduce this issue, but it works fine both on Firefox 9 and Firefox 10 Beta 2.

I did some exploratory testing around this bug using the following cases for Firefox 9, Firefox 10 Beta 2, Android Stock browser:


Case 1:

- I disabled these options from Location and security settings:
    * Use wireless networks   on | [off]
    * Use GPS satellites      on | [off]
    * Use sensor aiding       on | [off]
- I browsed to maps.google.com
- I tapped on Share button
Actual result: "location not determined" showed up for all 3 apps mentioned above


Case 2:
- I enabled the following option from Location and security:
    * Use wireless networks   [on] |  off
    * Use GPS satellites       on  | [off]
    * Use sensor aiding        on  | [off]
- I browsed to maps.google.com
- I tapped on Share button
Actual result: Location was shared correctly for all apps, no matter how many times I tapped on the Share button.


Case 3:
- I enabled the following option from Location and security:
    * Use wireless networks    on  | [off]
    * Use GPS satellites      [on] |  off
    * Use sensor aiding        on  | [off]
- I browsed to maps.google.com
- I tapped on Share button
Actual result (indoor): "location not determined" showed up due to low/no signal of A-GPS sensor.
Actual result (outdoor): until the gps connection will be established, the same message is displayed as for indoor result. I opened a couple of 3rd party apps wich need GPS connection (like Google Maps app, or any driving GPS app) and the same popup was displayed while GPS sensor trid to connect to satellites: "Your location is temporary unavailable".


In my opinion this bug is not because of Fennec. It depends of the GPS sensor settings and GPS connection quality.

--
Mozilla/5.0 (Android;Linux armv7l;rv:9.0)Gecko/20111216
Firefox/9.0 Fennec/9.0
Device: Samsung Galaxy S
OS: Android 2.2
Comment 15 Alex Keybl [:akeybl] 2012-01-05 18:04:47 PST
(In reply to Naoki Hirata :nhirata from comment #13)
> see : https://bugzilla.mozilla.org/show_bug.cgi?id=713991#c16

Naoki, can you verify that this is a duplicate of 713991 by testing in today's nightly? If it still reproduces, please assign to Doug for investigation.

(In reply to Cristian Nicolae (:xti) from comment #14)
> Case 3:
> - I enabled the following option from Location and security:
>     * Use wireless networks    on  | [off]
>     * Use GPS satellites      [on] |  off
>     * Use sensor aiding        on  | [off]
> - I browsed to maps.google.com
> - I tapped on Share button
> Actual result (indoor): "location not determined" showed up due to low/no
> signal of A-GPS sensor.

This sounds like another issue - can you file a new bug? Thanks!
Comment 16 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-05 18:29:53 PST
This may be a duplicate, I am able to get the location where I currently at with the Use wireless networks turned on, Use GPS satellites turned on, and enable location (within the default browser) turned on.

In order to properly verify, someone would have to test in the mountain view office.
Comment 17 Alex Keybl [:akeybl] 2012-01-06 15:39:29 PST
Sending over to Tony for MV testing and to (hopefully) close this out.
Comment 18 Alex Keybl [:akeybl] 2012-01-17 13:58:48 PST
QA ping
Comment 19 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-17 16:32:23 PST
Looks like it works in MV.  Samsung Galaxy S II, build 20120117, Android 2.3.3; closing it off as a duplicate.

*** This bug has been marked as a duplicate of bug 713991 ***

Note You need to log in before you can comment on or make changes to this bug.