[Mac Default] tabbrowser tab title text styling is wrong in Lion

RESOLVED FIXED in seamonkey2.9

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: stefanh, Assigned: stefanh)

Tracking

({regression})

SeaMonkey Tracking Flags

(seamonkey2.8 fixed)

Details

Attachments

(1 attachment)

On Lion, text in native tabs turns white on selection. Also, a text-shadow is applied. This comes from toolkit/themes/pinstripe/global/tabbox.css:

48 
49 @media (-moz-mac-lion-theme) {
50   tab[selected="true"] {
51     color: #FFF;
52     text-shadow: rgba(0, 0, 0, 0.4) 0 1px;
53   }
54 }

This makes our tabbrowser tabs look really bad when you select them. We need to override these rules.
Posted patch v1.0Splinter Review
I just added some overrides to the existing selector instead of adding a new just for Lion.
Assignee: nobody → stefanh
Status: NEW → ASSIGNED
Attachment #584263 - Flags: review?(mnyromyr)
Oh, and this happens of course with bottom tabs as well. That's a toolkit issue, though (will file a bug for that).
This was caused by bug 681425 (fixed for Firefox 11), so we'll need this for comm-aurora.
(In reply to Stefan [:stefanh] from comment #2)
> Oh, and this happens of course with bottom tabs as well. That's a toolkit
> issue, though (will file a bug for that).

Bug 713446.
Comment on attachment 584263 [details] [diff] [review]
v1.0

Note: Since I'm on 10.6.8 still, I commented out the Lion media designator to test this.
Attachment #584263 - Flags: review?(mnyromyr) → review+
Comment on attachment 584263 [details] [diff] [review]
v1.0

This is very safe and it fixes a highly visible regression (looks quite bad).
Attachment #584263 - Flags: approval-comm-aurora?
http://hg.mozilla.org/comm-central/rev/c878fa4dd773
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.9
Comment on attachment 584263 [details] [diff] [review]
v1.0

a=me for c-a
Attachment #584263 - Flags: approval-comm-aurora? → approval-comm-aurora+
(In reply to Ian Neal from comment #8)
> Comment on attachment 584263 [details] [diff] [review]
> v1.0
> 
> a=me for c-a

Thanks, will try and land this tomorrow.
You need to log in before you can comment on or make changes to this bug.