Status

defect
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: nrlacasse, Unassigned)

Tracking

12 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:12.0a1) Gecko/20111225 Firefox/12.0a1
Build ID: 20111225031006

Steps to reproduce:

Hi,

I can not send and receive email. The program seems to send and receive but does not download new messages. I do have email to download from the server. I have several POP email accounts. I am not having internet issues. My POP and SMTP setting are all correct. Below is what the error message is when trying to send an email and what the Error Console says.



Actual results:


Sending of message failed.
The message could not be sent because connecting to SMTP server xx.server.xx failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP server settings are correct and try again, or contact the server administrator.

smtpout.secureserver.net
outgoing.yahoo.verizon.net
mail.gmx.com
smtp.live.com
smtp.mail.yahoo.com

----------------------------------

Error Console: All Errors, Warnings and Messages


Native module at path 'C:\Users\NRL\AppData\Roaming\Thunderbird\Profiles\4ewq531b.default\extensions\{8620c15f-30dc-4dba-a131-7c5d20cf4a29}\platform\WINNT_x86-msvc\crashme.dll' doesn't export symbol `NSModule`.

Failed to load native module at path 'C:\Users\NRL\AppData\Roaming\Thunderbird\Profiles\4ewq531b.default\extensions\{8620c15f-30dc-4dba-a131-7c5d20cf4a29}\platform\WINNT_x86-msvc\accessory.dll': (80004003) error 126

While creating services from category 'profile-after-change', service for entry 'AboutNightly', contract ID '@mozilla.org/network/protocol/about;1?what=nightly' does not implement nsIObserver.

Timestamp: 12/25/2011 05:14:59 PM
Error: (new component).QueryInterface is not a function
Source File: resource://gre/modules/XPCOMUtils.jsm
Line: 301

While creating services from category 'profile-after-change', could not create service for entry 'nttAddonCompatibilityService', contract ID '@mozilla.com/nightly/addoncompatibility;1'

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Error: menupopup is null
Source File: chrome://new.toolbar/content/patch.js
Line: 5

Timestamp: 12/25/2011 05:15:00 PM
Warning: XUL box for toolbarbutton element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Timestamp: 12/25/2011 05:15:02 PM
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Interface module loaded.

Initializing timer.

Timer made.

Registering observer for startup completion.

Timestamp: 12/25/2011 05:15:03 PM
Warning: XUL box for box element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Timestamp: 12/25/2011 05:15:03 PM
Warning: XUL box for box element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Timestamp: 12/25/2011 05:15:03 PM
Warning: XUL box for box element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Timestamp: 12/25/2011 05:15:03 PM
Warning: XUL box for box element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://messenger/content/messenger.xul
Line: 0

QuickFolders:QuickFolders.init() - QuickFolders Version 2.9hc-AddonManagerVersionPending
Running on Thunderbird Version 12.0a1

Timestamp: 12/25/2011 05:15:05 PM
Warning: XUL box for toolbarbutton element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Timer got called back!.

Impoting setup

globally globalStartuping

Did it.

Timestamp: 12/25/2011 05:15:13 PM
Error: no element found
Source File: https://testpilot.mozillalabs.com/testcases/index-tb.json
Line: 1

Timestamp: 12/25/2011 05:19:54 PM
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: chrome://messenger/content/messengercompose/messengercompose.xul
Line: 0

Timestamp: 12/25/2011 05:19:54 PM
Error: tooltipChildrenReminders is null
Source File: chrome://reminderfox/content/reminderFox.js
Line: 1080

Timestamp: 12/25/2011 05:20:11 PM
Error: redeclaration of const Ci
Source File: chrome://global/content/commonDialog.js
Line: 42

localfolder commonDialog localfolderInitDlg

Timestamp: 12/25/2011 05:20:50 PM
Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgMailNewsUrl.server]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource:///modules/activity/alertHook.js :: <TOP_LEVEL> :: line 80"  data: no]
Source File: resource:///modules/activity/alertHook.js
Line: 80

Timestamp: 12/25/2011 05:20:54 PM
Warning: XUL box for toolbarbutton element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://messenger/content/messenger.xul
Line: 0

2011-12-25 17:20:54	gloda.datastore	ERROR	got error in _asyncTrackerListener.handleError(): 19: PRIMARY KEY must be unique

Timestamp: 12/25/2011 05:21:37 PM
Error: redeclaration of const Ci
Source File: chrome://global/content/commonDialog.js
Line: 42

localfolder commonDialog localfolderInitDlg

Timestamp: 12/25/2011 05:21:54 PM
Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgMailNewsUrl.server]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource:///modules/activity/alertHook.js :: <TOP_LEVEL> :: line 80"  data: no]
Source File: resource:///modules/activity/alertHook.js
Line: 80

Timestamp: 12/25/2011 05:22:07 PM
Error: redeclaration of const Ci
Source File: chrome://global/content/commonDialog.js
Line: 42

localfolder commonDialog localfolderInitDlg

Timestamp: 12/25/2011 05:22:21 PM
Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgMailNewsUrl.server]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource:///modules/activity/alertHook.js :: <TOP_LEVEL> :: line 80"  data: no]
Source File: resource:///modules/activity/alertHook.js
Line: 80

Timestamp: 12/25/2011 05:22:53 PM
Error: redeclaration of const Ci
Source File: chrome://global/content/commonDialog.js
Line: 42

localfolder commonDialog localfolderInitDlg

Timestamp: 12/25/2011 05:23:00 PM
Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgMailNewsUrl.server]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource:///modules/activity/alertHook.js :: <TOP_LEVEL> :: line 80"  data: no]
Source File: resource:///modules/activity/alertHook.js
Line: 80

Timestamp: 12/25/2011 05:23:28 PM
Error: redeclaration of const Ci
Source File: chrome://global/content/commonDialog.js
Line: 42

localfolder commonDialog localfolderInitDlg

Timestamp: 12/25/2011 05:23:41 PM
Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgMailNewsUrl.server]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource:///modules/activity/alertHook.js :: <TOP_LEVEL> :: line 80"  data: no]
Source File: resource:///modules/activity/alertHook.js
Line: 80

localfolder commonDialog localfolderInitDlg




Expected results:


I should be able to send and receive email.

Thanks!

Windows 7 x64
Intell Core2 Duo E8400
Thunderbird Daily 12.0a1

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20111225 Thunderbird/12.0a1 ID:20111225030253
Hardware: x86 → x86_64
I can not send and receive email in safe mode either.

Timestamp: 12/25/2011 06:53:10 PM
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

This is the only entry in the Error Console.


I do have quite a few add-ons:

- About Add-ons 0.6.20110718
- Adblock Plus 2.0.1 (Disabled)
- Add-on Compatibility Reporter 1.0.2
- AddressBookTab 1.4.2
- Advanced Unread Folders 1.3
- Attachment Options 1.0
- BccInfo 1.01
- Birthday Reminder 1.0.6.5
- Calendar Tweaks 3.0
- Classicish Add-on Manager 0.8.1
- Contacts Sidebar 0.7.1 (Disabled, Incompatible)
- CookieFast 1.0
- CookieSafe 3.1a9
- Copy Link Name for Thunderbird 0.9 (Incompatible)
- CuteButtons - Crystal SVG 0.3.0
- CuteMenus - Crystal SVG 1.9.3 (Incompatible)
- DictionarySearch 7.0.0
- Element Hiding Helper for Adblock Plus 1.1.4 (Disabled)
- envelopes 0.1
- Exif Viewer 1.70 (Incompatible)
- Extension List Dumper 1.15.2
- Extension Options Menu 2.1
- Flat Folder Tree 1.1.2
- Folder Account 5.0
- Folder Categories 0.5.3
- FolderFlags 1.2.4
- Get All Mail Button Thunderbird 0.1 (Incompatible)
- Grammar Checker 0.5.1
- Identity Chooser 1.6.1
- Lightning 1.4a1
- LightningButton 1.5.2
- LocalFolder 0.8.8
- Mail Merge 2.5.0
- Mailbox Alert 0.16.1
- Manually sort folders 1.0.1
- More Snooze 1.1.1
- music_detector 0.6beta (Incompatible)
- New Mail Attention 1.2.1
- Nightly Tester Tools 3.2
- QuickFolders 2.9.4
- Quote Colors 0.3 (Incompatible)
- ReminderFox 1.9.9.4.3
- Restart Thunderbird 1.0 (Incompatible)
- TB Custom Toolbar 1.0 (Incompatible)
- Test Pilot for Thunderbird 1.3.4
- ThunderBrowse 3.8
- ThunderShot 0.1 (Incompatible)
- Toolbar Buttons 1.0 (Incompatible)
- Version in Add-on bar 1.0
Please try with thunderbird safe-mode (all extensions disabled).
Hi,

I tried again today in safe mode and I still can't send and receive email.
These are the errors I got today:



Sending of message failed.
The message could not be sent because connecting to SMTP server smtp.live.com failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP server settings are correct and try again, or contact the server administrator.

----------------------------------------------

Timestamp: 12/27/2011 09:44:42 AM
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Timestamp: 12/27/2011 09:46:45 AM
Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgMailNewsUrl.server]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource:///modules/activity/alertHook.js :: <TOP_LEVEL> :: line 80"  data: no]
Source File: resource:///modules/activity/alertHook.js
Line: 80

2011-12-27 09:46:45	gloda.datastore	ERROR	got error in _asyncTrackerListener.handleError(): 19: PRIMARY KEY must be unique



Thanks,
Norman
Norman sent me:
"I tried again today in safe mode and I still can't send and receive email.
These are the errors I got today:

Sending of message failed.
The message could not be sent because connecting to SMTP server smtp.live.com
failed. The server may be unavailable or is refusing SMTP connections. Please
verify that your SMTP server settings are correct and try again, or contact the
server administrator."

Did you check the firewall/antivirus isn't blocking connections? (They often do when the binary changes.)
What is your email provider? There is bug 713561 that Verizon changed some settings.

Otherwise there are many messages in your Error console, most of them probably unrelated. Could you start TB in safe mode (Help->restart with addons disabled) so that the messages caused by extentions are not shown.

The post the contents of Error console again.
I will check the firewall/antivirus this afternoon when I get time on the computer.

I made the changes for Verizon so that is not the problem. I have 5 different email providers:

GoDaddy: smtpout.secureserver.net
Verizon: outgoing.yahoo.verizon.net
GMX:     mail.gmx.com
HotMail: smtp.live.com
Yahoo!:  smtp.mail.yahoo.com

All POP/SMTP settings are correct.

I will post the Error Console results after I check the firewall/antivirus.
I will make sure I clear the Error Console messages before I restart in safe mode.

Norman
Hi,

Yesterday I spent a lot of time looking at my firewall, antivirus and antispyware. I could not find any settings blocking Daily.

This morning I cleared the error console and restarted in safe mode.
This is the only warning that was displayed after restart:

Timestamp: 12/30/2011 07:19:58 AM
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Norman
Tried turning off the firewall?
Yes I tried with the antivirus, antispyware and firewall turned off. Should I try creating a new profile and if it works just reinstall my addons and reconfigure my account settings? I'm not sure what else can be done.
Today the Error Console has 1 error and 1 warning.

Timestamp: 12/31/2011 09:42:26 AM
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Timestamp: 12/31/2011 09:43:11 AM
Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgMailNewsUrl.server]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource:///modules/activity/alertHook.js :: <TOP_LEVEL> :: line 80"  data: no]
Source File: resource:///modules/activity/alertHook.js
Line: 80
That warning is harmless.

To see if your computer can connect at all, open a command prompt and do "telnet smtp.live.com 587". If it sais it connected, you at least have connectivity.
(In reply to NRLacasse from comment #6)
> Yahoo!:  smtp.mail.yahoo.com
> All POP/SMTP settings are correct.

Let's check with Yahoo!'s SMTP only first, which any user can use.

Can you show us SMTP server setting for Yahoo!'s SMTP in your prefs.js?
Following is an SMTP definition for smtp.mail.yahoo.com in my prefs.js. 
> user_pref("mail.smtpserver.smtpN.authMethod", 3);
> user_pref("mail.smtpserver.smtpN.description", "boyacky@rocketmail.com");
> user_pref("mail.smtpserver.smtpN.hostname", "smtp.mail.yahoo.com");
> user_pref("mail.smtpserver.smtpN.port", 465);
> user_pref("mail.smtpserver.smtpN.try_ssl", 3);
> user_pref("mail.smtpserver.smtpN.username", "boyacky@rocketmail.com");

How about "ping smtp.mail.yahoo.com"?
How about "telnet smtp.mail.yahoo.com XYZ"?
(XYZ = value in mail.smtpserver.smtpN.port for Yahoo!'s SMTP in your prefs.js) 

Can you access news server of news.mozilla.org) from you Tb?
  Create news account via File/New/Other accounts, Newsgroup account,
  sepecify news.mozilla.rg as server name, and finish,
  then at news account, Subscribe.
Because mandatory setup is correct typing of "news.mozilla.org" by you only, "your setting is correct or incorrect" will never be problem if mozilla.org's news server.

When did your problem start to occur? Just after you tried to use Tb 12.0a1?
No problem with official release of Tb 8/Tb9, with same profile?
Happy New Year!!!!!!!


RE: Comment 11 Magnus Melin

I tried with both with and without quotes. I'm 99% sure it is supposed to be without quotes. It said it does not recognize telnet:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\NRL>telnet smtp.live.com 587
'telnet' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\NRL>"telnet smtp.live.com 587"
'"telnet smtp.live.com 587"' is not recognized as an internal or external comman
d,operable program or batch file.

C:\Users\NRL>
Happy New Year to you too!!!!!!!!


RE: Comment 12 WADA


user_pref("mail.smtpserver.smtp1.authMethod", 3);
user_pref("mail.smtpserver.smtp1.description", "Yahoo");
user_pref("mail.smtpserver.smtp1.hostname", "smtp.mail.yahoo.com");
user_pref("mail.smtpserver.smtp1.port", 465);
user_pref("mail.smtpserver.smtp1.try_ssl", 3);
user_pref("mail.smtpserver.smtp1.username", "nrlacasse");

-----

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\NRL>ping smtp.mail.yahoo.com

Pinging smtp.mail.us.am0.yahoodns.net [98.138.84.55] with 32 bytes of data:
Reply from 98.138.84.55: bytes=32 time=155ms TTL=53
Reply from 98.138.84.55: bytes=32 time=176ms TTL=50
Reply from 98.138.84.55: bytes=32 time=402ms TTL=52
Reply from 98.138.84.55: bytes=32 time=243ms TTL=50

Ping statistics for 98.138.84.55:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 155ms, Maximum = 402ms, Average = 244ms

C:\Users\NRL>telnet smtp.mail.yahoo.com 465
'telnet' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\NRL>

-----

I set up the news account. I tried to subscribe but it says that it can't connect to the server. The problem started after I updated from TB 11.0a1 to 12.0a1

I only use the Daily/Nightly versions of Thunderbird and SeaMonkey because it is hard for me to keep track of emails. SeaMonkey 2.9a1 works. When Thunderbird does not work I use SeaMonkey to get my email.

I will look at the telnet settings.

telnet smtp.live.com 587:

220 BLU0-SMTP114.phx.gbl Microsoft ESMTP MAIL Service, Version: 6.0.3790.4675 re
ady at  Sun, 1 Jan 2012 09:06:36 -0800


Connection to host lost.

C:\Users\NRL>

----------------------------

telnet smtp.mail.yahoo.com 465:

telnet Yahoo gives me a blank window then when I press enter I get the command prompt again. I let it go blank for several minutes before I pressed enter.


C:\Users\NRL>
I enabled tenet client not the server
(In reply to NRLacasse from comment #16)
> telnet smtp.mail.yahoo.com 465:
> telnet Yahoo gives me a blank window then when I press enter I get the
> command prompt again. I let it go blank for several minutes before I pressed
> enter.

Don't worry about it. Same result in my Win-XP.
As SSL is used, Yahoo! server requests handshaking, but standard telnet doesn't support SSL, so telnet is waiting for our data input for handshaking.
It indicates that connection with the Yahoo! server from "Command Prompt/telnet" was established, as non-SSL connecion with smtp.live.com was normally established.

(In reply to NRLacasse from comment #7)
> Yesterday I spent a lot of time looking at my firewall, antivirus and
> antispyware. I could not find any settings blocking Daily.

As you saw with news.mozilla.org too, connection from Tb 12.0a1 with any server couldn't be established in your environment, even though telnet could connect to them. 
Did you check firewall setting properly?
> http://kb.mozillazine.org/Firewalls
On Win, three kinds of firewall can exists.
(i) Firewall component of anti-virus software such as Norton, MaCafee, PC-cillin.
(ii) Personal Firewall Software such as ZoneAlarm.
(iii) Windows Firewall, which MS perhaps enables by default.
If you enable multiple firewalls, did you check all?
Tomorrow I will give details on the settings in the firewall, antivirus and antispyware. I am confident Thunderbird is not being blocked but I'm not 100% sure. I'm in the mid to high 90% range that the settings are okay. It might help if you know what I use and what the settings are for Thunderbird.
Hi,

In the firewall I originally looked at the Trusted Files and Thunderbird is in the trusted files. I did not think a trusted file could be blocked. It sounded like an oxymoron to me, but now I look like a moron. Today I looked at the firewall better. I looked at View Active Connections and it showed Thunderbird as Listening with 0 Bytes in/out. Then I looked at the View Firewall Events and it showed that it was blocking Thunderbird. Then I looked at the Network Security Policy. Both Firefox and Thunderbird had the same setting as a Web Browser. I changed Thunderbird to an Email Client and it started working. As soon as I changed the setting I got 3 emails that came in.

I must apologize for wasting your time! I do thank you and appreciate your help. I do not know how Thunderbird got classified as a web browser instead of an Email Client.

Thank you for all your help and working with me on this.

Norman


PS: I was able to join different Mozilla News Feeds too.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.