Fix calDateTime nsIXPCScriptable implementation (build error calDateTime::PreCreatePrototype)

RESOLVED FIXED in 1.4

Status

Calendar
Internal Components
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Fallen, Assigned: Fallen)

Tracking

unspecified

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 584408 [details] [diff] [review]
Fix - v1

Until now we have been implementing each new method that mozilla-central throws at us, but all we will ever need is get/setproperty and newresolve.

This patch will fix once and for all, since I just found out about xpc_map_end.h

This is needed for comm-central since bug 707717
Attachment #584408 - Flags: review?(mbanner)

Comment 1

6 years ago
Building SeaMonkey with ac_add_options --enable-calendar

make.py[3]: Entering directory 'c:\t1\hg\objdir-sm\calendar\lightning\../libical'
make.py[4]: Entering directory 'c:\t1\hg\objdir-sm\calendar\libical\src'
make.py[5]: Entering directory 'c:\t1\hg\objdir-sm\calendar\libical\src\libical'
c:\t1\hg\objdir-sm\calendar\libical\src\libical\Makefile:185:0$ /bin/sh /c/t1/hg/comm-central/mozilla/build/msys-perl-wrapper -I c:/t1/hg/comm-central/calendar/libical/src/libical/../../scripts c:/t1/
hg/comm-central/calendar/libical/src/libical/../../scripts/mkderivedparameters.pl -i c:/t1/hg/comm-central/calendar/libical/src/libical/icalderivedparameter.c.in -c c:/t1/hg/comm-central/calendar/libical/src/libical/../../design-data/parameters.csv > icalderivedparameter.c
Can't locate readvaluesfile.pl in @INC (@INC contains: c /t1/hg/comm-central/calendar/libical/src/libical/../../scripts /usr/lib/perl5/5.6.1/msys /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/msys /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl .) at c:/t1/hg/comm-central/calendar/libical/src/libical/../../scripts/mkderivedparameters.pl line 3.
c:\t1\hg\objdir-sm\calendar\libical\src\libical\Makefile:185:0: command '/bin/sh /c/t1/hg/comm-central/mozilla/build/msys-perl-wrapper -I c:/t1/hg/comm-central/calendar/libical/src/libical/../../scripts c:/t1/hg/comm-central/calendar/libical/src/libical/../../scripts/mkderivedparameters.pl -i c:/t1/hg/comm-central/calendar/libical/src/libical/icalderivedparameter.c.in -c c:/t1/hg/comm-central/calendar/libical/src/libical/../../design-data/parameters.csv > icalderivedparameter.c' failed, return code 2
c:\t1\hg\comm-central\config\rules.mk:880:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C libical libs' failed, return code 2
c:\t1\hg\comm-central\config\rules.mk:880:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C src libs' failed, return code 2
c:\t1\hg\comm-central\config\rules.mk:880:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C ../libical libs' failed, return code 2
c:\t1\hg\comm-central\config\rules.mk:725:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C calendar/lightning libs' failed, return code 2
c:\t1\hg\comm-central\config\rules.mk:736:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py libs_tier_app' failed, return code 2
(Assignee)

Comment 2

6 years ago
And this doesn't happen without the patch? readvaluesfile.pl is in comm-central/calendar/libical/scripts/ and looking at that @INC dir there seems to be a win32 vs unix path mismatch:

@INC contains: c /t1/hg/comm-central/calendar/libical/src/libical/../../scripts
  Missing ':' --^

maybe something with pymake vs non-pymake?

Comment 3

6 years ago
> And this doesn't happen without the patch?
Without this patch, I don't get far enough to say whether it happens.

> maybe something with pymake vs non-pymake?
Yeah using pymake, but was building Lightning successfully before this with pymake.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 714016
(Assignee)

Updated

6 years ago
Summary: Fix calDateTime nsIXPCScriptable implementation → Fix calDateTime nsIXPCScriptable implementation (build error calDateTime::PreCreatePrototype)
(Assignee)

Comment 5

6 years ago
I'm going to push this patch to get the builders green, I'd still appreciate a review on this though.
(Assignee)

Comment 6

6 years ago
Pushed to comm-central changeset e58436e512e5
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4
Comment on attachment 584408 [details] [diff] [review]
Fix - v1

Not tested, but looks fine to me by inspection.
Attachment #584408 - Flags: review?(mbanner) → review+
You need to log in before you can comment on or make changes to this bug.