Closed Bug 713796 Opened 8 years ago Closed 7 years ago

"Reset Assignee to default" and "Reset QA Contact to default" should only be checked when the assignee/qa-contact is the default

Categories

(bugzilla.mozilla.org :: General, defect, minor)

Production
defect
Not set
minor

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Assigned: glob)

References

Details

Attachments

(1 file)

1. Pick an open bug that's assigned to an actual person.
2. Select another component to move it to.
3. Look at the "Reset Assignee to default" checkbox that appears after step 2.

Result: it's checked

Expected: it should be unchecked
I don't understand the change needed here. When selecting a new product and/or a new component for the bug being viewed, the page does not know who the default assignee is
yet for the new component being selected. It just means that it will reset to the new assignee when the bug is changed. If you want the current assignee to stay the same (whoever it is currently) you would just uncheck the "Reset assignee to default" checkbox before submitting the change. Are you just asking for the default behavior to be unchecked instead of being checked?

dkl
I'm asking for the default behavior to be unchecked when the current owner is the default assignee for the old component, and checked otherwise.
+1, I hate having to always uncheck that box when moving bugs that are already assigned to someone.
Summary: "Reset Assignee to default" should only be checked when the assignee is the default → "Reset Assignee to default" and "Reset QA Contact to default" should only be checked when the assignee/qa-contact is the default
Duplicate of this bug: 792655
That seems backwards actually...  if the current assignee is NOT the default owner of the current (not new) component, then you would want the assignee to stay the same by default, correct?  If the current assignee is the default owner then we can assume they got it by default and it should go to the default assignee of the new component as well (and thus it would be checked if the current owner is the default owner).
fwiw, what I just suggested matches what Byron changed the summary to.  My response was to comment 2.
Attached patch patch v1Splinter Review
if this patch looks good, i'll try to push it upstream too.
Assignee: nobody → glob
Status: NEW → ASSIGNED
Attachment #663002 - Flags: review?(dkl)
Comment on attachment 663002 [details] [diff] [review]
patch v1

Review of attachment 663002 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me and works as expected. r=dkl
Attachment #663002 - Flags: review?(dkl) → review+
thanks dkl.

filed upstream bug 797680

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified js/field.js
modified template/en/default/bug/edit.html.tmpl
Committed revision 8344.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified js/field.js
modified template/en/default/bug/edit.html.tmpl
Committed revision 8366.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.