Last Comment Bug 714057 - Remove uintn users from XPConnect
: Remove uintn users from XPConnect
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: :Ms2ger
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-29 07:08 PST by :Ms2ger
Modified: 2012-01-03 03:54 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (68.51 KB, patch)
2011-12-29 07:08 PST, :Ms2ger
bobbyholley: review+
khuey: review+
Details | Diff | Review

Description :Ms2ger 2011-12-29 07:08:14 PST
Created attachment 584743 [details] [diff] [review]
Patch v1

js/src moved away from them in bug 708735, and as in bug 711611, we can avoid getting them provided by NSPR with a simple define.
Comment 1 Bobby Holley (PTO through June 13) 2011-12-29 19:19:46 PST
Comment on attachment 584743 [details] [diff] [review]
Patch v1

I didn't look at this very closely, but it looks like you configured your regexp right. r+ on that part.

I don't know anything about the NSPR stuff, so flagging khuey for review on that part.
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-12-29 19:27:04 PST
Comment on attachment 584743 [details] [diff] [review]
Patch v1

Can we get a bug on file on defining NO_NSPR_10_SUPPORT globally?
Comment 3 :Ms2ger 2011-12-30 02:55:38 PST
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #2)
> Comment on attachment 584743 [details] [diff] [review]
> Patch v1
> 
> Can we get a bug on file on defining NO_NSPR_10_SUPPORT globally?

Bug 714247.

Note You need to log in before you can comment on or make changes to this bug.