Last Comment Bug 714621 - HTML/Rich text (copied from IE, Firefox, MSWord, etc.) is always pasted as plain text
: HTML/Rich text (copied from IE, Firefox, MSWord, etc.) is always pasted as pl...
Status: RESOLVED DUPLICATE of bug 714115
[GS][workaround: see comment 11]
: regression
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: 9 Branch
: x86 Windows XP
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://getsatisfaction.com/mozilla_me...
: 718272 718398 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-02 06:36 PST by José Ángel Morente
Modified: 2012-01-18 00:55 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
+
fixed


Attachments
pasted html (6.88 KB, message/rfc822)
2012-01-03 17:33 PST, Joe Sabash [:JoeS1]
no flags Details

Description José Ángel Morente 2012-01-02 06:36:30 PST
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.63 Safari/535.7

Steps to reproduce:

I created a new e-mail in HTML format and pasted some HTML text from a WEB browser (Firefox and IE).


Actual results:

The text pasted as plain text ignoring all the formatting, images, etc.


Expected results:

The text should have been pasted as HTML formatted text.
Comment 1 José Ángel Morente 2012-01-02 06:56:27 PST
It works fine on Thunderbird 8, so it seems to be a TB9-specific problem.
I have been able to reproduce the issue on every computer available at the company I work for.
Comment 2 Hashem Masoud 2012-01-03 10:42:20 PST
(In reply to José Ángel Morente from comment #1)
Same issue here pasting from Firefox in Linux + XFCE. Only hyperlinks work, other formatting is not maintained.

User Agent: Mozilla/5.0 (X11; Linux i686; rv:9.0) Gecko/20111222 Thunderbird/9.0.1
Application Build ID: 20111222141531
Comment 3 Joe Sabash [:JoeS1] 2012-01-03 17:33:26 PST
Created attachment 585616 [details]
pasted html

pasted html
Comment 4 Joe Sabash [:JoeS1] 2012-01-03 17:36:15 PST
I am not able to reproduce this in:
Mozilla/5.0 (Windows NT 5.0; rv:12.0a1) Gecko/20120102 Thunderbird/12.0a1 ID:20120102030146

The html in the attached eml was pasted from http://status.mozilla.com/
Comment 5 José Ángel Morente 2012-01-04 00:42:30 PST
By the way, I forgot to note that I use the Spanish (es-es) version of Thunderbird 9.0.1.
Comment 6 Ludovic Hirlimann [:Usul] 2012-01-05 02:28:48 PST
José does it happens in safe-mode too (see http://support.mozillamessaging.com/en-US/kb/Safe-Mode#os=mac&browser=tb7) ?
Comment 7 José Ángel Morente 2012-01-05 02:38:36 PST
Yes it does :-(
Comment 8 Joe Sabash [:JoeS1] 2012-01-05 07:07:39 PST
This may be related, or a duplicate of core bug 714115
Comment 9 Ian Neal 2012-01-15 15:59:12 PST
*** Bug 718272 has been marked as a duplicate of this bug. ***
Comment 10 Vincent (caméléon) 2012-01-16 05:00:13 PST
Confirming the bug with 11.0a2.

I also find a thread on GSFN reporting this problem: http://getsatisfaction.com/mozilla_messaging/topics/problem_pasting_html_text and another one on Geckozone: http://www.geckozone.org/forum/viewtopic.php?f=4&t=101735
Comment 11 Joe Sabash [:JoeS1] 2012-01-16 06:24:54 PST
Please try the work-around here:
https://bugzilla.mozilla.org/show_bug.cgi?id=714115#c22
Comment 12 Joe Sabash [:JoeS1] 2012-01-16 06:26:48 PST
Didn't mean to change the status
Comment 13 Vincent (caméléon) 2012-01-16 06:30:55 PST
(In reply to Joe Sabash from comment #11)
> Please try the work-around here:
> https://bugzilla.mozilla.org/show_bug.cgi?id=714115#c22

Well, it fix the issue! Thanks.
Comment 14 Mark Banner (:standard8) 2012-01-16 06:37:23 PST
*** Bug 718398 has been marked as a duplicate of this bug. ***
Comment 15 rsx11m 2012-01-16 07:43:01 PST
(In reply to Joe Sabash from comment #8)
> This may be related, or a duplicate of core bug 714115

If switching the decimal representation from ',' to '.' resolves the issue for the reporter as well this is most likely a duplicate of that core bug. Those affected can also try a nightly 12.0a1 build, or wait until the core fix has checked into mozilla-beta for the next 10.0 beta.
Comment 16 Vincent (caméléon) 2012-01-16 07:45:44 PST
(In reply to rsx11m from comment #15)
> > If switching the decimal representation from ',' to '.' resolves the issue
> for the reporter as well this is most likely a duplicate of that core bug.

I agree, this is certainly a duplicate.
Comment 17 José Ángel Morente 2012-01-16 07:55:30 PST
I just tried changing the decimal character to '.' and YES it works fine now.

:-)
Comment 18 Brian R. Bondy [:bbondy] 2012-01-16 08:25:28 PST

*** This bug has been marked as a duplicate of bug 714115 ***
Comment 19 Mark Banner (:standard8) 2012-01-18 00:55:54 PST
For those cc'ed on this bug: the issue causing this has been backed out of TB 10 and therefore won't affect users. It will be incorporated into the next TB 10.0 beta which is out tomorrow (you can find beta builds here: http://www.mozilla.org/thunderbird/channel/)

For TB 11 a fix has been applied, and hence it won't regress when we get there either.

Note You need to log in before you can comment on or make changes to this bug.