Last Comment Bug 715397 - ability to build m-c on 10.7 (lion)
: ability to build m-c on 10.7 (lion)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: 12 Branch
: x86 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
Mentors:
Depends on: 715872 715930 721160
Blocks: 715337 720027 723632
  Show dependency treegraph
 
Reported: 2012-01-04 17:11 PST by Dustin J. Mitchell [:dustin]
Modified: 2012-05-15 07:08 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use the 10.6 sdk (1.77 KB, patch)
2012-01-17 18:22 PST, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
ted: review+
Details | Diff | Splinter Review

Description Dustin J. Mitchell [:dustin] 2012-01-04 17:11:32 PST
This is a follow-on to bug 674655, which gives us the ability to build 10.5-compatible (32-bit) firefox using the 10.6 SDK.

Once that's in place, to satisfy bug 715337, we need to be able to build with that SDK on a 10.7 system.

As I understand it, 10.7 requires XCode 4.x (and since we're using gcc, that means 4.1, which is not the latest), and XCode 4.x only has the 10.6 and 10.7 SDKs, so bug 674655 is definitely a prerequisite here.
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-05 06:53:09 PST
I did a try push to
https://tbpl.mozilla.org/?tree=Try&rev=35b3fc2ac72e

The 10.5 debug build already failed as expected since it is running on a 10.5 machine with no 10.6 sdk.

If the rest is green we should be able to switch to the 10.6 soon after the debug builds are moved out of 10.5 machines.
Comment 2 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-05 13:35:39 PST
A new push is at

https://tbpl.mozilla.org/?tree=Try&rev=84fad4f51ae3

It should fix the "Symbol not found: _SCDynamicStoreCreate" errors.
Comment 3 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-05 17:18:33 PST
And yet a new one for the libstdc++ issue:

https://tbpl.mozilla.org/?tree=Try&rev=c071c5aaa866

looks like we are also not correctly detecting how to handle page protection.  I will try to debug that tomorrow.
Comment 4 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-06 08:50:24 PST
A new try push with the non-hack version of the libstdc++ fix is at

https://tbpl.mozilla.org/?tree=Try&rev=0d5234270db4
Comment 5 John Ford [:jhford] 2012-01-10 11:51:34 PST
(In reply to Rafael Ávila de Espíndola (:espindola) from comment #4)
> A new try push with the non-hack version of the libstdc++ fix is at
> 
> https://tbpl.mozilla.org/?tree=Try&rev=0d5234270db4

Rafael, this looks really neat!  How far out do you think this bug is?
Comment 6 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-10 12:17:23 PST
There is a new try on top of m-i in:

https://tbpl.mozilla.org/?tree=Try&rev=c7fec001ba99

The expected result is for all to be green, except for a failure in the 10.5 debug build which is running on a 10.5 machine. If that is really the case, this bug would then be fully blocking on us moving the 10.5 debug builds to a 10.6 machine.
Comment 7 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-17 11:02:47 PST
A new push to try is in https://tbpl.mozilla.org/?tree=Try&rev=f3c8c19da938

We are being "conservative" back in bug 698827, so we can't actually check that in, but should be interesting to see if a debug build finds any other problems with the 10.6 sdk.
Comment 8 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-17 18:22:10 PST
Created attachment 589377 [details] [diff] [review]
Use the 10.6 sdk

We have to wait for bug 698827 to be fixed for this to land, but we should be able to do the code review in parallel.

https://tbpl.mozilla.org/?tree=Try&rev=c7fec001ba99
Comment 9 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-18 04:56:54 PST
note: the new try push is https://tbpl.mozilla.org/?tree=Try&rev=f3c8c19da938
sorry for the confusion.
Comment 10 Ted Mielczarek [:ted.mielczarek] 2012-01-18 11:41:21 PST
Comment on attachment 589377 [details] [diff] [review]
Use the 10.6 sdk

Review of attachment 589377 [details] [diff] [review]:
-----------------------------------------------------------------

::: build/macosx/universal/mozconfig.common
@@ +46,1 @@
>  ac_add_app_options x86_64 --with-macos-sdk=/Developer/SDKs/MacOSX10.6.sdk

You can combine these two lines into:
ac_add_options --with-macos-sdk=/Developer/SDKs/MacOSX10.6.sdk
Comment 11 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-18 12:36:56 PST
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=429503206f26
Comment 12 Marco Bonardo [::mak] 2012-01-19 02:49:07 PST
https://hg.mozilla.org/mozilla-central/rev/429503206f26
Comment 13 Mike Taylor [:bear] 2012-05-15 07:08:01 PDT
I believe we are done here - if not please reopen.

Note You need to log in before you can comment on or make changes to this bug.