Last Comment Bug 716373 - Lightning doesn't send event invitations when adding attendees to an existing event
: Lightning doesn't send event invitations when adding attendees to an existing...
Status: RESOLVED DUPLICATE of bug 938459
:
Product: Calendar
Classification: Client Software
Component: E-mail based Scheduling (iTIP/iMIP) (show other bugs)
: Lightning 1.1
: x86_64 Windows 7
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 702247 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-08 08:49 PST by nmmozilla
Modified: 2014-03-22 12:43 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description nmmozilla 2012-01-08 08:49:04 PST
When adding attendees to an existing event invitation/update is not sent out. Thunderbird 9.0 + Lightning 1.1.1 in Windows 7 OS.

Steps for reproducing:

1. Create a new event with or without attendees.
2. Once created open it again and add one or two attendees.
3. With the notify attendees box checked Save and Close the event.

Expected result:

1. Lightning will prompt if you would like to send notifications out.
2. If you click ok, email should be sent to attendees.

Actual result:

1. Event is saved with new attendees but no prompt for notifications no email to attendees is sent out.

Additional comments:

1. Event update to attendees is only sent if you modify event time.
2. If you add attendees since the begining during event creation it does prompt and send invitations out.
3. In Ubuntu 10+ OS bug is not reproduced.
Comment 1 Felix Möller 2012-01-09 13:25:41 PST
Thanks for reporting.

This might be similar to bug #709604.

Could you rephrase "3. In Ubuntu 10+ OS bug is not reproduced."
Comment 2 Felix Möller 2012-01-09 13:31:14 PST
*** Bug 702247 has been marked as a duplicate of this bug. ***
Comment 3 nmmozilla 2012-01-09 19:56:23 PST
Thank you Felix,

Yes, it seems same as bug #709604.

Rephrase of number 3 would be: "3. Lightning 1.1 version for Ubuntu OS does not exhibit the bug of this report."
Comment 4 Felix Möller 2012-01-10 06:32:23 PST
Seems to be the same as bug #703513 as well -- there it is said to work on Linux too,  while it fails on Windows.
Comment 5 nmmozilla 2012-01-10 08:13:03 PST
(In reply to Felix Möller from comment #4)
> Seems to be the same as bug #703513 as well -- there it is said to work on
> Linux too,  while it fails on Windows.

Maybe is somehow related but I think is not the same as bug #703513.

Failure of bug #703513 is: Not sending updates when modifying event time. 
Failure of this report is: Not sending invitations when adding attendees to an existing event.

Failure described on bug #703513 is not reproduced in my system.
Comment 6 nmmozilla 2012-01-10 08:14:30 PST
(In reply to Felix Möller from comment #4)
> Seems to be the same as bug #703513 as well -- there it is said to work on
> Linux too,  while it fails on Windows.

Maybe is somehow related but I think is not the same as bug #703513.

Failure of bug #703513 is: Not sending updates when modifying event time. 
Failure of this report is: Not sending invitations when adding attendees to an existing event.

Failure described on bug #703513 is not reproduced in my system.
Comment 7 fred_g_bdx 2012-02-16 11:21:23 PST
I confirm the bug here on win 7 / tb 10.0.1 / lghtng 1.2.1
another horrible workaround is to cut the event (the cancellation is sent) and then paste the event. finally the invitation is sent.
Comment 8 fred_g_bdx 2012-02-18 00:41:31 PST
Bug not present in fedora 16/TB 10.0/lghtng 1.2.1. 
Seems to be a platform (windows) related bug.
Really annoying!
Comment 9 Bob Atkins 2012-02-20 19:02:55 PST
I can confirm that this is still a problem with Lightning 1.2.1 with Thunderbird 10.0.2 on WInXP SP3.

I can also confirm that this is not an issue with Lightning v0.9 and Thunderbird 2.0.0.24.
Comment 10 fred_g_bdx 2012-03-22 04:29:14 PDT
Bug still alive on windows in TB 11.0 and litghning 1.3 ....
Comment 11 fred_g_bdx 2012-05-30 22:59:38 PDT
Bug still alive on windows in TB 12.0.1 and lightning 1.4 ...
Sorry guys but this bug is really annoying.
Comment 12 major.gyula 2012-06-25 02:38:06 PDT
I have the very same problem. I tested on 2 computers.
Thunderbird 13.0.1., Lightning 1.5.1, WinXp with all Microsoft updates installed.
Comment 13 fred_g_bdx 2012-07-18 04:34:31 PDT
Guess what ... Applicable to lightning 1.6 too. (TB 14.0)
Comment 14 fred_g_bdx 2012-08-29 09:20:55 PDT
Still applicable on lightning 1.7 too. (TB 15.0)... what is missing for confirming this bug?
Comment 15 Stefan Sitter 2012-09-20 10:22:49 PDT
Does the workaround mentioned in several other reports on this problem works for you, i.e. use the Save command instead of the Save and Close command and wait until invitations are send before closing the dialog?
Comment 16 fred_g_bdx 2012-09-20 13:36:52 PDT
Yes this workaround is working as the one in comment #7 but both are not really convenient.
Comment 17 Bob Atkins 2012-09-20 14:17:31 PDT
I'm just amazed that this bug hasn't been tackled in so long for what I would have thought was a popular addon. Personally my work around is just not to upgrade Thunderbird. I'm running Lightning 0.9 with Thunderbird 2 and it works just fine. With Lightning broken for later versions of Thunderbird there is no reason to upgrade, besides, the later versions of Thunderbird are processor hogs anyway.
Comment 18 fred_g_bdx 2012-09-23 01:10:25 PDT
Really amazed too. This small bug makes me reluctant to push my colleagues to swap from Outlook to TB.
Comment 19 jotbe 2012-10-12 03:19:38 PDT
Even the workaround doesn't work for me. (Sabayon Linux, Lightning 1.7.b1, Thunderbird 15.0.1)
Comment 20 Stephen Crowley 2013-05-08 09:49:16 PDT
This problem persists on IceOwl 1.2b1 on Linux
Comment 21 Bob Atkins 2013-05-08 10:21:40 PDT
I suspect that development of the Lightning extension is dead in the water. This problem has persisted for far too long without any constructive response.

Time to move on - nothing to see here.
Comment 22 Stephen Crowley 2013-05-08 11:47:47 PDT
Son of a... I'll pay someone to fix it.. any bidders?
Comment 23 fred_g_bdx 2013-05-27 04:39:05 PDT
Still applicable on lightning 1.9.1 too. (TB 17.0.6).
Again, what is missing for confirming/assigning this bug?
Comment 24 Lada 2013-08-26 23:10:51 PDT
Confirming this case with Ubuntu 13.04, Thunderbird 17.0.8, Lightning 1.9.1 setup. Invitations are stored into calendar but not sent out (also UI notification is missing). This worked couple weeks back (I will try to trace what updated caused this issue).
Comment 25 Stephen Crowley 2013-08-27 08:24:06 PDT
Bob, you really think Lightning development is dead in the water?
Comment 26 plasty.grove 2013-09-06 04:18:19 PDT
So close yet so far. I'm using Windows 7 x64 with Thunderbird 17.0.8 and Lightning 1.9.1, Invitations sometimes get sent if I fiddle with them long enough, otherwise they don't get sent.

Why can't I right-click on the event and say "Re-send Invitations", is this something that I shouldn't do? It's things like this that keep this product from getting adopted.

I also looked at the documentation, just overviews at https://wiki.mozilla.org/Calendar:Dev_Guide. Nothing concrete :(. Anyone know of a more up-to-date guide?
Comment 27 cle2treize 2014-01-29 08:15:46 PST
Confirmed on WinXp SP3 with TB 24.2.0 and Lghtning 2.6.4.
Comment 28 MakeMyDay 2014-03-22 12:43:15 PDT

*** This bug has been marked as a duplicate of bug 938459 ***

Note You need to log in before you can comment on or make changes to this bug.