"From" column of thread pane is always lost after restart by upgrade to Tb 10 beta

RESOLVED DUPLICATE of bug 710056

Status

RESOLVED DUPLICATE of bug 710056
7 years ago
7 years ago

People

(Reporter: kk5do, Unassigned)

Tracking

({regression})

10 Branch
x86_64
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 587545 [details]
troubleshoot.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a2) Gecko/20120107 Firefox/11.0a2
Build ID: 20120107042006

Steps to reproduce:

Upgraded to newest beta 10


Actual results:

On main window, you have email subject, date, size. I tag "From". When I do an upgrade, the "From" column is always gone and I have to click View and add "From". This has been going on for the last dozen or so upgrades to the beta. 


Expected results:

All selected columns for display prior to an upgrade should be preserved for after the upgrade. 

Copied the Troubleshooting Information to clipboard and placed in attached file.
Tb trunk(2012/01/03 build) behavior on column of thread pane.
  Non special folder(not Trash, Junk, Archive, Sent, Drafts, Templates) 
    create new folder : Same column set in same order as Inbox of the account
    after delete .msf : Same column set in same order as Inbox of the account
  Inbox, after delete Inbox.msf : (in next order)
    Thread, Starred, Attachments, Read, From, Junk Status, Date
  IIRC, Sent and Drafts has different internal default from Inbox.

Is "From" column selected at Inbox? Is column set shown after upgrade same as one for Inbox always?

FYI.
Current column set/order of a folder is saved in .msf, and it can be known by data like next in .msf file.
> <(80=1)(81=4)(82=AAA)(83=0)(84=4f0d0cd6)(85=)(86=1326255321)(87=12)
>   (88
>     ={"threadCol":{"visible":true,"ordinal":"1"},"flaggedCol":{"visible":true,\
> "ordinal":"3"},"attachmentCol":{"visible":true,"ordinal":"5"},"subjectCol":{"v\
> isible":true,"ordinal":"7"},"unreadButtonColHeader":{"visible":true,"ordinal":\
> "9"},"senderCol":{"visible":true,"ordinal":"11"},"recipientCol":{"visible":fal\
> se,"ordinal":"17"},"junkStatusCol":{"visible":true,"ordinal":"19"},"receivedCo\
> l":{"visible":false,"ordinal":"35"},"dateCol":{"visible":true,"ordinal":"21"},\
> "statusCol":{"visible":true,"ordinal":"13"},"sizeCol":{"visible":false,"ordina\
> l":"23"},"tagsCol":{"visible":false,"ordinal":"25"},"accountCol":{"visible":fa\
> lse,"ordinal":"27"},"priorityCol":{"visible":false,"ordinal":"29"},"unreadCol"\
> :{"visible":false,"ordinal":"31"},"totalCol":{"visible":false,"ordinal":"33"},\
> "locationCol":{"visible":false,"ordinal":"37"},"idCol":{"visible":true,"ordina\
> l":"15"}})>
> {1:^9F {(k^A0:c)(s=9u)} 
>   [1(^AC=1)(^AD=1)(^88=4)(^A7^82)(^A3=0)(^A5^84)(^B6=0)(^B5=)(^B8^86)
>     (^B1=12)(^B2=1)(^B3=0)(^B4=0)(^B9=)(^B7^88)(^C2=1)]}
(In reply to Bruce from comment #0)
> I tag "From". When I do an upgrade, the "From" column is always gone (snip)

If Sent, following was set by Tb 9.0.1. Recipient is shown instead of From if Sent.
  Sent, after delete Sent.msf : (in next order, Subject is always selected)
    Thread, Starred, Attachments, (Suject), Read, Recipient, Junk Status, Date

Which folder? Sent or Drafts folder or subfolder of Sent/Drafts?
What is saved in xxx.msf after column selection change(Add From) and termination of Tb?
When column set is changed back to "no From" after restart of Tb, is there any error in Error Console? (e.g. error relevant to folderTree.json, exception relevant to thread pane processing)
Summary: "From" in reading pane → "From" column of thread pane is always lost after restart by upgrade to Tb 10 beta

Updated

7 years ago
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
isn't the same of bug #710056 ?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 710056
You need to log in before you can comment on or make changes to this bug.