Last Comment Bug 717110 - [New Tab Page] Tooltips should be added to page thumbnails
: [New Tab Page] Tooltips should be added to page thumbnails
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
: 717109 (view as bug list)
Depends on:
Blocks: 716538
  Show dependency treegraph
 
Reported: 2012-01-10 17:12 PST by Jennifer Morrow [:Boriss] (UX)
Modified: 2012-02-21 06:37 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Mockup: Tooltip added. Not that you really needed one (126.61 KB, image/png)
2012-01-10 17:12 PST, Jennifer Morrow [:Boriss] (UX)
no flags Details
patch v1 (784 bytes, patch)
2012-01-11 05:24 PST, Tim Taubert [:ttaubert]
dao+bmo: review+
Details | Diff | Splinter Review

Description Jennifer Morrow [:Boriss] (UX) 2012-01-10 17:12:22 PST
Tooltips already exist on the interface elements of new tab page, including (on thumbnails) pin and remove, and (on the page itself) restore and hide New Tab page.

On the thumbnails themselves, the tooltip should give the full string title of the site.
Comment 1 Jennifer Morrow [:Boriss] (UX) 2012-01-10 17:12:47 PST
Created attachment 587548 [details]
Mockup: Tooltip added.  Not that you really needed one
Comment 2 Jennifer Morrow [:Boriss] (UX) 2012-01-10 17:18:24 PST
*** Bug 717109 has been marked as a duplicate of this bug. ***
Comment 3 Tim Taubert [:ttaubert] 2012-01-11 05:24:54 PST
Created attachment 587665 [details] [diff] [review]
patch v1

Simple patch, adding tooltips.
Comment 4 Tim Taubert [:ttaubert] 2012-01-25 14:54:45 PST
https://hg.mozilla.org/integration/fx-team/rev/7f44427086f7
Comment 5 Tim Taubert [:ttaubert] 2012-01-25 23:59:12 PST
https://hg.mozilla.org/mozilla-central/rev/7f44427086f7
Comment 6 Tim Taubert [:ttaubert] 2012-01-26 10:01:40 PST
Backed out:

https://hg.mozilla.org/mozilla-central/rev/f47e281a0509
Comment 7 Tim Taubert [:ttaubert] 2012-01-27 08:11:51 PST
https://hg.mozilla.org/integration/fx-team/rev/0ab12334bd7e
Comment 8 Tim Taubert [:ttaubert] 2012-01-28 06:20:29 PST
https://hg.mozilla.org/mozilla-central/rev/0ab12334bd7e
Comment 9 Tim Taubert [:ttaubert] 2012-02-14 00:38:10 PST
*** Bug 721442 has been marked as a duplicate of this bug. ***
Comment 10 Virgil Dicu [:virgil] [QA] 2012-02-21 06:37:54 PST
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a2) Gecko/20120220 Firefox/12.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a2) Gecko/20120221 Firefox/12.0a2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a2) Gecko/20120220 Firefox/12.0a2

Verified on Firefox 12. Tooltips are no available for page titles.

Note You need to log in before you can comment on or make changes to this bug.