The default bug view has changed. See this FAQ.

[AZURE] backgrounds of elements using -border-radius are drawn with an additional offset from browser chrome

RESOLVED FIXED in mozilla14

Status

()

Core
Graphics
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Steve Scott (pxbugz), Assigned: bas)

Tracking

Trunk
mozilla14
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120111 Firefox/12.0a1
Build ID: 20120111031049

Steps to reproduce:

-Install latest nightly, clean profile
-Make gfx.content.azure.enabled to true
-load about:config and/or about:memory and a bugzilla page with enough comments to scroll



Actual results:

-white hbox (about:config) and body (about:memory) background appear to be drawn too low - equivalent to the size of the browser toolbars - you can check by opening/closing bookmarks toolbar or switching tabs on top, the white background will shift up or down to be an equivalent size
- Opening and closing the sidebar will shift the white background to the right, equivalent to the width of the sidebar

On a bugzilla page the div#bugzilla-body will be affected by the sidebar being open when scrolling - it will paint it's background shifted to the right, equivalent to the width of the sidebar, but only for parts of the page that have been offscreen (i.e. not painted). This problem is not exhibited with a closed sidebar.




Expected results:

The page elements should not be effected by browser chrome.

I am not au fait with the thebes wrapper but I guess it would be easy to assume  that these elements are being drawn either doubly offset from the whole browser window or offset from the content window bounds when they should be offset from the whole browser window.

Also, I have not extensively tested so the specific page elements with problems may not be exhaustive.
(Reporter)

Updated

5 years ago
Blocks: 715768
Component: Untriaged → Graphics
Product: Firefox → Core
(Reporter)

Comment 1

5 years ago
Created attachment 587749 [details]
Buzilla page with sidebar after being scrolled down then up

Top left of grey Buzilla div background is shifted right/not drawn after scrolling
(Reporter)

Comment 2

5 years ago
Created attachment 587750 [details]
about:config page showing issue

about:config hbox background is shifted downwards equivalent to the height of the browser chrome.
Confirming - Setting to NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Some webpage and about: element backgrounds are affected by browser chrome → [AZURE] Some webpage and about: element backgrounds are affected by browser chrome
(Reporter)

Comment 4

5 years ago
Browsed the top 100 sites on alexa.com to find other cases of this bug, which hopefully should help.

www.youtube.com - div.feed-item.upload - on subscription page

www.reddit.com -  div.linkinfo - on a comments page

www.imgur.com - div.panel.Left

etsy.com - div.section

newegg.com - div.grpSearch

verizonwireless.com - DIV#oo_tab.oo_tab_right
Created attachment 588304 [details]
Border Radius Test

The problem seem to point to border-radius. (If it wasn't obvious to the devs before)

I made a quick testcase.
Created attachment 588305 [details]
Border Radius Test

Auto-detect fail.
Attachment #588304 - Attachment is obsolete: true
(Reporter)

Updated

5 years ago
Summary: [AZURE] Some webpage and about: element backgrounds are affected by browser chrome → [AZURE] -border-radius is drawn with an additional offset from browser chrome
(Reporter)

Updated

5 years ago
Summary: [AZURE] -border-radius is drawn with an additional offset from browser chrome → [AZURE] backgrounds of elements usings-border-radius are drawn with an additional offset from browser chrome
(Reporter)

Updated

5 years ago
Summary: [AZURE] backgrounds of elements usings-border-radius are drawn with an additional offset from browser chrome → [AZURE] backgrounds of elements using -border-radius are drawn with an additional offset from browser chrome
Duplicate of this bug: 717782
Duplicate of this bug: 718198

Updated

5 years ago
Duplicate of this bug: 725267
(Assignee)

Updated

5 years ago
Attachment #588305 - Attachment mime type: text/plain → text/html
(Assignee)

Updated

5 years ago
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
(Assignee)

Comment 10

5 years ago
Created attachment 606328 [details] [diff] [review]
Mark transform dirty properly
Attachment #606328 - Flags: review?(jmuizelaar)
Attachment #606328 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/54eeedd8faa1
https://hg.mozilla.org/mozilla-central/rev/54eeedd8faa1
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14

Updated

5 years ago
QA Contact: untriaged → thebes
(Assignee)

Updated

5 years ago
No longer blocks: 715768
(Assignee)

Updated

5 years ago
Blocks: 715768
You need to log in before you can comment on or make changes to this bug.