The default bug view has changed. See this FAQ.

Selection in Scratchpad behaves strangely if selecting into the gutter

VERIFIED FIXED

Status

()

Firefox
Developer Tools: Scratchpad
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: rc, Assigned: msucan)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox11 wontfix, firefox12 verified)

Details

(Whiteboard: [sourceeditor][orion][qa!])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
STR:

1. Open a Scratchpad
2. Select any line in the placeholder text, from right to left, extending into the gutter.

Expected results:

Line is selected.

Actual results:

Line is selected and then reselected repeatedly, flashing the selection area on screen.
(Reporter)

Updated

5 years ago
Whiteboard: [sourceeditor][orion]

Updated

5 years ago
Duplicate of this bug: 719015
(Assignee)

Comment 2

5 years ago
Bug triage. Filter on PEGASUS.
Priority: -- → P2
Version: unspecified → Trunk
(Reporter)

Comment 3

5 years ago
boosting this to P1. It's important.
Priority: P2 → P1
(Assignee)

Updated

5 years ago
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
(Assignee)

Comment 4

5 years ago
Bug reported upstream:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=370548

... and included a proposed fix. Waiting only for review.
(Assignee)

Comment 5

5 years ago
This is going to be fixed by bug 718816.
Depends on: 718816
(Assignee)

Updated

5 years ago
Duplicate of this bug: 729134
(Assignee)

Comment 7

5 years ago
This should be fixed now. Please reopen if the problem persists. Thank you!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

5 years ago
Created attachment 601978 [details] [diff] [review]
[in-aurora] minimal patch for aurora

Minimal patch for Aurora. This does not require an Orion update.

[Approval Request Comment]
Regression caused by (bug #): according to hg blame it's bug 709006. Orion does not support changing paddings on line elements. This is something we've only recently learned.

User impact if declined: users will continue to see broken behavior when selecting text and moving the mouse into the gutter. Jarring effect.

Testing completed (on m-c, etc.): this fix has landed approximately a week ago in m-c as part of bug 718816 - users report no issues now.

Risk to taking this patch (and alternatives if risky): no risk. This is a CSS change.

String changes made by this patch: none.

Thank you!
Attachment #601978 - Flags: review?(rcampbell)
Attachment #601978 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Keywords: regression
(Assignee)

Comment 9

5 years ago
Created attachment 601979 [details] [diff] [review]
minimal patch for beta

Minimal patch that applies cleanly in the mozilla-beta repo.

[Approval Request Comment]
Regression caused by (bug #): bug 709006
User impact if declined: users will see broken behavior when they select text and move the mouse into the gutter.
Testing completed (on m-c, etc.): patch landed in m-c about a week ago - no reported regressions.
Risk to taking this patch (and alternatives if risky): none. This is a style change.
String changes made by this patch: none.
Attachment #601979 - Flags: review?(rcampbell)
Attachment #601979 - Flags: approval-mozilla-beta?
(Reporter)

Updated

5 years ago
Attachment #601978 - Flags: review?(rcampbell) → review+
(Reporter)

Comment 10

5 years ago
Comment on attachment 601979 [details] [diff] [review]
minimal patch for beta

r+, basically the same patch.
Attachment #601979 - Flags: review?(rcampbell) → review+
Comment on attachment 601979 [details] [diff] [review]
minimal patch for beta

[Triage Comment]
Apologies, but this doesn't meet the requirements of landing for our sixth beta. We're only taking sg:crit bugs, chemspill-worthy issues, and backouts to known states for sake of risk mitigation.
Attachment #601979 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 601978 [details] [diff] [review]
[in-aurora] minimal patch for aurora

(approving for Aurora 12, however)
Attachment #601978 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 13

5 years ago
Thanks for the Aurora approval Alex!


(In reply to Alex Keybl [:akeybl] from comment #11)
> Comment on attachment 601979 [details] [diff] [review]
> minimal patch for beta
> 
> [Triage Comment]
> Apologies, but this doesn't meet the requirements of landing for our sixth
> beta. We're only taking sg:crit bugs, chemspill-worthy issues, and backouts
> to known states for sake of risk mitigation.

This comment states that the patch is not approved for beta, but the flag is +. What's the case?
(Assignee)

Comment 14

5 years ago
Comment on attachment 601978 [details] [diff] [review]
[in-aurora] minimal patch for aurora

Landed:
https://hg.mozilla.org/releases/mozilla-aurora/rev/cf771f621858
Attachment #601978 - Attachment description: minimal patch for aurora → [in-aurora] minimal patch for aurora
(Assignee)

Updated

5 years ago
status-firefox12: --- → fixed
(Reporter)

Comment 15

5 years ago
Comment on attachment 601979 [details] [diff] [review]
minimal patch for beta

clearing approval for beta. Alex stated that this does not meet the reqs for beta.
Attachment #601979 - Flags: approval-mozilla-beta+
(Reporter)

Updated

5 years ago
status-firefox11: --- → wontfix
(In reply to Rob Campbell [:rc] (robcee) from comment #15)
> Comment on attachment 601979 [details] [diff] [review]
> minimal patch for beta
> 
> clearing approval for beta. Alex stated that this does not meet the reqs for
> beta.

Sorry for the mis-flagging. This was the correct action.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 736494
Whiteboard: [sourceeditor][orion] → [sourceeditor][orion][qa+]

Comment 18

5 years ago
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0
20120328051619
Status: RESOLVED → VERIFIED
status-firefox12: fixed → verified
Whiteboard: [sourceeditor][orion][qa+] → [sourceeditor][orion][qa!]
You need to log in before you can comment on or make changes to this bug.