Column picker has empty context menu in Manage Bookmarks window

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
Bookmarks & History
P2
critical
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Chris Lyon, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({regression})

Trunk
mozilla0.9.1
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: waiting for bug 80663 to verify)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using build 2001031204.
Open the Manage Bookmarks window and click on the column picker button.

Result:
A tiny empty context menu appears to the right of the window.

Expected Result:
The column picker menu should appear like it does in the History window.

Comment 1

17 years ago
Confirmed on build 2001030904 win95. Marking NEW, blocking tracker bug 68550.
Blocks: 68550
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
*** Bug 74031 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
from the duplicate bug :
"Actual Results:  JavaScript error stating "BuildTreePopup not defined" occurs. 

Expected Results:  Display of a popup with the other available columns is
displayed.

Cause of Problem:
Missing <script> for chrome://global/content/treePopups.js in bookmarks.xul"
Sounds easy to fix.


Updated

17 years ago
Severity: normal → critical
Keywords: regression
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

17 years ago
changing platform to ALL/ALL. adding regression keyword. This used to work very recently - more
recently than the implementation of the new bookmarks manager.

Ben, I've upped the severity because -believe it or not- this bug is blocking my weekly performance
testing - I can't test the column sort without the column picker.
Keywords: nsbeta1
mozilla0.9.1, P2, nsbeta1+. 
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla0.9.1
Fix in hand. 
Status: NEW → ASSIGNED

Comment 7

17 years ago
Created attachment 33353 [details] [diff] [review]
Splitting Ben's patch in bug 76502. One-liner to fix this bug.

Comment 8

17 years ago
Attaching a patch that adds a missing javascript file. Taken from Ben's patch in
bug 76502 which has just rotten there. Please r=/sr= this quickly, need to get
the bookmarks done right asap!
Keywords: patch, review

Comment 9

17 years ago
r=hwaara

Comment 10

17 years ago
sr=alecf

Comment 11

17 years ago
Fix checked in, marking FIXED.
Thanks for the reviews.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
Now the column picker widget is completely missing. This may be a different bug because it's
missing in the Global History window as well, but I'm guessing it's intricately related
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
claudius - could you file a different bug for the column picker being absent 
globally? thanks, Vishy. 
(Reporter)

Comment 14

17 years ago
The global column picker bug is logged as bug 80663.

Comment 15

17 years ago
Remarking fixed. The column picker missing is another problem and not caused by
the patch in this bug.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
ok, if fabian says he didn't break it, fine. Note this isn't really 'global' b/c the mailnews column
picker is fine, just Navigator wide.
Depends on: 80663
Whiteboard: waiting for bug 80663 to verify

Comment 17

17 years ago
It's probably because mailnews uses the outliner while bookmarks and history use
trees
Right, we're not dependant upon treePopups.js anymore.

Comment 19

17 years ago
finally. VERIFIED Fixed with 2001061514 builds
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.