Last Comment Bug 718039 - Canvas element for Angrybirds webapp is displayed upside down
: Canvas element for Angrybirds webapp is displayed upside down
Status: VERIFIED FIXED
[qa!]
: regression
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: 10 Branch
: All Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: Jeff Gilbert [:jgilbert]
:
Mentors:
http://chrome.angrybirds.com/
Depends on: 702058
Blocks: 695912
  Show dependency treegraph
 
Reported: 2012-01-13 13:04 PST by Tony Chung [:tchung]
Modified: 2012-01-24 15:59 PST (History)
9 users (show)
anthony.s.hughes: in‑litmus+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
fixed
unaffected
unaffected


Attachments
screenshot (708.28 KB, image/png)
2012-01-13 13:04 PST, Tony Chung [:tchung]
no flags Details

Description Tony Chung [:tchung] 2012-01-13 13:04:20 PST
Created attachment 588503 [details]
screenshot

See screenshot.  Angry birds is displayed upside down.


Repro:
1) launch mac firefox 10:  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0) Gecko/20100101 Firefox/10.0
2) visit URL
3) verify page loads with content upside down

Expected:
- right side up!
Comment 1 Henrik Skupin (:whimboo) 2012-01-13 13:19:22 PST
This is a regression in Firefox 10. It doesn't happen in Firefox 9 nor Aurora. So probably it has been fixed already but has not been backported?
Comment 2 Leonard Camacho [:lcamacho] 2012-01-13 14:47:59 PST
I cant reproduce this on linux ubuntu 11.10 32bits beta or aurora

Mozilla/5.0 (X11; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (X11; Linux i686; rv:11.0a2) Gecko/20120113 Firefox/11.0a2
Comment 3 Marcia Knous [:marcia - use ni] 2012-01-13 14:52:24 PST
Not able to reproduce on 10.7.3 using the latest Firefox 10 beta.
Comment 4 Henrik Skupin (:whimboo) 2012-01-16 03:11:41 PST
Just to add, this happens for on my 13" aluminum MBP but not the white one with the same version of OS X installed. So it seems to have some external dependencies.
Comment 5 Henrik Skupin (:whimboo) 2012-01-16 04:11:18 PST
Regressed between the builds 2011-11-03-03 and 2011-11-04-03 on mozilla-central/

WORKS: http://hg.mozilla.org/mozilla-central/rev/b8dd6f6f4207
FAILS: http://hg.mozilla.org/mozilla-central/rev/3491b2f021bf

Pushlog:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b8dd6f6f4207&tochange=3491b2f021bf

There are way too many changesets. I would have to bisect all those.

Paul, anything you could imagine?
Comment 6 Henrik Skupin (:whimboo) 2012-01-16 04:29:50 PST
I think we should track this bug for Firefox 10.
Comment 7 Henrik Skupin (:whimboo) 2012-01-16 04:36:19 PST
Fixed on mozilla-central between the builds 2011-11-24-03 and 2011-11-25-03:

FAILS: http://hg.mozilla.org/mozilla-central/rev/de483d897af4
WORKS: http://hg.mozilla.org/mozilla-central/rev/84117219ded0

Pushlog:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=de483d897af4&tochange=84117219ded0

I can't really find anything useful. Will start to bisect now.
Comment 8 Henrik Skupin (:whimboo) 2012-01-16 06:40:34 PST
The first bad revision is:
changeset:   79683:b7a96e8bec7e
user:        Doug Sherk <dsherk@mozilla.com>
date:        Thu Nov 03 10:50:40 2011 -0400
summary:     Bug 695912: implemented antialiasing blocklisting r=jgilbert

Given that we have tested it on different machines, it would explain why we do not have seen this issue on some of them. Looks like that some of our hardware is getting blocklisted and somehow the canvas element displays the content upside down.
Comment 9 Henrik Skupin (:whimboo) 2012-01-16 06:44:05 PST
Here my graphics section from about:support

Vendor ID               0x8086
Device ID               0x 126
WebGL Renderer          Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine -- 2.1 APPLE-7.14.5
GPU Accelerated Windows 1/1 OpenGL
AzureBackendskia
Comment 10 Jeff Gilbert [:jgilbert] 2012-01-16 09:34:05 PST
Sounds like this may be bug 702058. Does 'cgl.prefer-fbo'='true' make it right-side-up again?
Comment 11 Henrik Skupin (:whimboo) 2012-01-16 09:44:32 PST
(In reply to Jeff Gilbert [:jgilbert] from comment #10)
> Sounds like this may be bug 702058. Does 'cgl.prefer-fbo'='true' make it
> right-side-up again?

You are right:

The first good revision is:
changeset:   80723:9c20e88fe6c1
user:        Jeff Gilbert <jgilbert@mozilla.com>
date:        Wed Nov 23 16:49:02 2011 -0800
summary:     Bug 702058 - Prefer CGL+FBOs by default on Mac - r=bjacob

Setting the preference in Firefox 10 to true fixes the problem too. So shall we dupe and request tracking-firefox 10 on bug 702058?
Comment 12 Jeff Gilbert [:jgilbert] 2012-01-16 10:07:24 PST
Indeed.
Comment 13 Henrik Skupin (:whimboo) 2012-01-16 12:56:29 PST
Fixed with the push to beta on bug 702058:
https://hg.mozilla.org/releases/mozilla-beta/rev/4c6bfe0434b0
Comment 14 Henrik Skupin (:whimboo) 2012-01-23 02:42:03 PST
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0) Gecko/20100101 Firefox/10.0

Not sure if we have or want manual WebGL tests on Litmus, but we should add Angry birds at least to a list of major apps we test across releases. Anthony or Marcia, can you please follow-up?
Comment 15 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-24 15:55:28 PST
I think it's worth having a smoketest for this. I'll go ahead and add one.
Comment 16 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-24 15:59:46 PST
Added to the Aurora Smoketests:
https://litmus.mozilla.org/show_test.cgi?id=45465

Note You need to log in before you can comment on or make changes to this bug.