Last Comment Bug 702058 - WebGL google maps is upside down
: WebGL google maps is upside down
Status: VERIFIED FIXED
[qa+][qa!:10]
: verified-beta
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: 10 Branch
: All Mac OS X
: -- normal (vote)
: mozilla11
Assigned To: Jeff Gilbert [:jgilbert]
:
Mentors:
: 703368 703832 704615 (view as bug list)
Depends on:
Blocks: 704615 718039
  Show dependency treegraph
 
Reported: 2011-11-12 16:49 PST by Jeff Muizelaar [:jrmuizel]
Modified: 2012-03-16 15:33 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
verified


Attachments
Switch Mac to default to using FBOs instead of PBuffers (1.88 KB, patch)
2011-11-23 03:13 PST, Jeff Gilbert [:jgilbert]
jacob.benoit.1: review+
Details | Diff | Review
Switch Mac to default to using FBOs instead of PBuffers (fx10) (1.89 KB, patch)
2012-01-16 11:56 PST, Jeff Gilbert [:jgilbert]
jacob.benoit.1: review+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review
screenshot (303.36 KB, image/jpeg)
2012-01-27 02:23 PST, Vlad [QA]
no flags Details

Description Jeff Muizelaar [:jrmuizel] 2011-11-12 16:49:01 PST
Search for LAX with WebGL Maps and see that everything is flipped upside down.
Comment 1 Jeff Gilbert [:jgilbert] 2011-11-14 14:03:24 PST
Does this not happen on other WebGL pages or demos?
Comment 2 Jeff Muizelaar [:jrmuizel] 2011-11-14 14:12:03 PST
Not that I've seen.
Comment 3 Jeff Gilbert [:jgilbert] 2011-11-14 14:20:10 PST
Does it replicate in Chrome?
Comment 4 Jeff Muizelaar [:jrmuizel] 2011-11-17 19:32:58 PST
(In reply to Jeff Gilbert [:jgilbert] from comment #3)
> Does it replicate in Chrome?

No.
Comment 5 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-11-17 20:24:55 PST
I can't reproduce this with a local build. Graphics card is forced to integrated - Intel HD Graphics 3000.
Comment 6 Emanuele Alimonda 2011-11-22 17:55:42 PST
Everything based on WebGL seems to be flipped upside down for me, not just google maps. (i.e. all the examples available at [1])

Reproduced with the 2011-11-22 Nightly on an OS X 10.7.2 MacBook Pro with an Intel HD 3000 graphics card (no discrete graphics card available on the machine, only the integrated one).  I'll be trying older builds as soon as I have some time.

[1]: http://forums.mozillazine.org/viewtopic.php?f=23&t=2090351

Screenshots:
http://img21.imageshack.us/img21/139/screenshot20111123at224.png
http://img207.imageshack.us/img207/4794/screenshot20111123at225.png
Comment 7 Jeff Gilbert [:jgilbert] 2011-11-22 22:11:33 PST
Does this replicate with the pref cgl.prefer-fbo=true?
Comment 8 Emanuele Alimonda 2011-11-22 23:04:25 PST
(In reply to Jeff Gilbert [:jgilbert] from comment #7)
> Does this replicate with the pref cgl.prefer-fbo=true?

No, it doesn't.  Setting that preference seems to fix it.
Comment 9 Jeff Gilbert [:jgilbert] 2011-11-23 03:13:30 PST
Created attachment 576436 [details] [diff] [review]
Switch Mac to default to using FBOs instead of PBuffers

https://tbpl.mozilla.org/?tree=Try&rev=cf667016f3b2

I am going to need to confirm the absence of perf regressions between FBOs and PBuffers, but they should be very similar.
Comment 10 Jeff Gilbert [:jgilbert] 2011-11-23 03:15:47 PST
From the earlier try run at https://tbpl.mozilla.org/?tree=Try&rev=48ffe4835f65 , it looks like we actually pass two new conformance tests by using FBOs.
Comment 11 Benoit Jacob [:bjacob] (mostly away) 2011-11-23 05:03:42 PST
Comment on attachment 576436 [details] [diff] [review]
Switch Mac to default to using FBOs instead of PBuffers

Review of attachment 576436 [details] [diff] [review]:
-----------------------------------------------------------------

Hurrah!
Comment 12 Benoit Jacob [:bjacob] (mostly away) 2011-11-23 05:05:18 PST
¿uʍop ǝpısdn sıɥʇ sı :ɯɹıɟuoɔ oʇ ʇsnɾ ʞɔǝɥɔ ʞɔınb
Comment 13 Emanuele Alimonda 2011-11-23 10:21:34 PST
d: (pǝddılɟ uɐɥʇ ɹǝɥʇɐɹ pǝʇɐʇoɹ sı sıɥʇ) ǝɹǝɥ uʍoɥs ǝnssı ǝɥʇ ǝʇınb ʇou s,ʇı ʇnq 'uʍop ǝpısdn sı sıɥʇ 'sǝʎ
Comment 15 Ed Morley [:emorley] 2011-11-24 08:16:17 PST
https://hg.mozilla.org/mozilla-central/rev/9c20e88fe6c1
Comment 16 Jo Hermans 2011-11-28 17:19:38 PST
*** Bug 703368 has been marked as a duplicate of this bug. ***
Comment 17 Jeff Gilbert [:jgilbert] 2011-12-06 15:27:29 PST
*** Bug 704615 has been marked as a duplicate of this bug. ***
Comment 18 Julian Adams 2011-12-07 09:40:57 PST
(In reply to Emanuele Alimonda from comment #8)
> (In reply to Jeff Gilbert [:jgilbert] from comment #7)
> > Does this replicate with the pref cgl.prefer-fbo=true?
> 
> No, it doesn't.  Setting that preference seems to fix it.

I'm running the current Aurora (FF10) on OSX. I can't find this setting in about:config. Is it not in FF10, or is there another way to set it. I definitely have the bug :(
Comment 19 Jeff Gilbert [:jgilbert] 2011-12-11 19:49:13 PST
It's a hidden pref, so you have to add it manually. (It won't show up by default) Just add a boolean pref called "cgl.prefer-fbo" and set it to true.
Comment 20 Julian Adams 2011-12-12 01:11:45 PST
(In reply to Jeff Gilbert [:jgilbert] from comment #19)
> It's a hidden pref, so you have to add it manually. (It won't show up by
> default) Just add a boolean pref called "cgl.prefer-fbo" and set it to true.

Thanks, got it!
Comment 21 Henrik Skupin (:whimboo) 2012-01-16 10:19:27 PST
As bug 718039 states this is still broken in Firefox 10. Asking for tracking Firefox 10.

Marking as verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0a2) Gecko/20120113 Firefox/11.0a2 ID:20120113042010
Comment 22 Alex Keybl [:akeybl] 2012-01-16 11:27:00 PST
(In reply to Henrik Skupin (:whimboo) from comment #21)
> As bug 718039 states this is still broken in Firefox 10. Asking for tracking
> Firefox 10.
> 
> Marking as verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7;
> rv:11.0a2) Gecko/20120113 Firefox/11.0a2 ID:20120113042010

Jeff - let's get this nominated for beta ASAP. This is a major regression that needs to be addressed on beta if deemed low risk.
Comment 23 Jeff Gilbert [:jgilbert] 2012-01-16 11:56:18 PST
Created attachment 588952 [details] [diff] [review]
Switch Mac to default to using FBOs instead of PBuffers (fx10)

Patch for Beta (10).
Comment 24 Jeff Gilbert [:jgilbert] 2012-01-16 12:02:40 PST
Comment on attachment 588952 [details] [diff] [review]
Switch Mac to default to using FBOs instead of PBuffers (fx10)

[Approval Request Comment]
Regression caused by (bug #): Unknown, fixed here in 11+.
User impact if declined: WebGL on Mac may display upside-down.
Testing completed (on m-c, etc.): Nearly identical (simple) patch already in 11+.
Risk to taking this patch (and alternatives if risky): Switching the default for a hidden (afaik undocumented) pref should carry little risk.
Comment 25 Henrik Skupin (:whimboo) 2012-01-16 12:22:24 PST
(In reply to Jeff Gilbert [:jgilbert] from comment #24)
> Regression caused by (bug #): Unknown, fixed here in 11+.

Bi-secting for bug 718039 showed that at least for Angrybirds it has been regressed with bug 695912.
Comment 26 Alex Keybl [:akeybl] 2012-01-16 12:34:05 PST
Comment on attachment 588952 [details] [diff] [review]
Switch Mac to default to using FBOs instead of PBuffers (fx10)

[Triage Comment]
Approving for beta since this is a recent regression, WebGL is strategically important, and this fix has been deemed low risk. FWIW I was also able to reproduce on my MB Air.
Comment 27 Jeff Gilbert [:jgilbert] 2012-01-16 12:46:37 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/4c6bfe0434b0
Comment 28 Henrik Skupin (:whimboo) 2012-01-16 12:53:17 PST
QA will verify this with the next beta candidate builds.
Comment 29 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-18 16:38:21 PST
*** Bug 703368 has been marked as a duplicate of this bug. ***
Comment 30 Danial Horton 2012-01-20 17:51:22 PST
(In reply to Jeff Gilbert [:jgilbert] from comment #9)
> Created attachment 576436 [details] [diff] [review]
> Switch Mac to default to using FBOs instead of PBuffers
> 
> https://tbpl.mozilla.org/?tree=Try&rev=cf667016f3b2
> 
> I am going to need to confirm the absence of perf regressions between FBOs
> and PBuffers, but they should be very similar.

if anything FBO should be faster. I've seen how slow pbuffering is on a project of mine
Comment 31 Jeff Gilbert [:jgilbert] 2012-01-22 01:49:29 PST
In one of my tests, it appeared we were getting faster readback from PBuffers. I should think that PBuffers should be as fast as FBOs, since the driver could just use FBOs as the backing for PBuffers.
Comment 32 Danial Horton 2012-01-22 02:03:19 PST
Reads may be faster under Pbuffer, but writes are where the benefits of FBO's is seen the most.
Comment 33 Vlad [QA] 2012-01-27 02:23:39 PST
Created attachment 592087 [details]
screenshot

Hi guys.

I have verified this on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0 beta 6
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0) Gecko/20100101 Firefox/10.0 beta 6

The google maps in WebGl mode aren't flipped upside down anymore but I've noticed another behavior:
- On MacOS X 10.7 - Google Maps - WebGl - with side menu enabled you can see some random straight lines (see the atachament).These are disappearing when scrolling. If I hide the side menu, the lines are gone. 
- On MacOS X 10.6.8 - the lines are present with and without the side menu.

I'll set this as verified on beta since the image is displayed properly but should I file a new bug with this behavior? On Google Chrome the lines are not present.

Thanks
Comment 34 Benoit Jacob [:bjacob] (mostly away) 2012-01-27 05:03:34 PST
This visual bug is almost certainly a driver issue that we can't do much about. We could try to see what Chrome is doing differently to steer clear of it, but at this point it doesn't seem to be worth the effort.
Comment 35 Jeff Gilbert [:jgilbert] 2012-03-16 15:33:26 PDT
*** Bug 703832 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.