Setup Development environment for ReMo

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: pierros, Assigned: jd)

Tracking

Details

(Reporter)

Description

6 years ago
Hello superIT :)

We would like to have a development environment setup for Mozilla Reps portal.
The repo is living here: https://github.com/mozilla/remo 
and the url should be: reps-dev.allizom.org

Thanks!
(Reporter)

Updated

6 years ago
Blocks: 718489
Is this for dev and stage both?  stage was requested in 647446 but that bug was put on ice.

Also, please take a moment to fill in any gaps you can in https://mana.mozilla.org/wiki/display/websites/reps.mozilla.org

Jason, I think we originally talked about this going on the engagement cluster..
Assignee: server-ops → jcrowe
(Reporter)

Comment 2

6 years ago
For stage I shall open a new bug as the project referenced in 647446 is outdated.

Will update mana asap.

Consider this bug only for dev.

Also can I open stage and prod in one bug?

Thanks!
(Assignee)

Comment 3

6 years ago
Pierros,

This is basically set up.  Since there is no code in the repository I cant really do much.  I created the relevant dns and Apache configurations.  I generated a test index file to ensure it is all working.  If you visit the url you will get a not found error right now (even if you put a place-holder index file in place) as I have the WSGIScriptAlias definition in place already.  Once you get the app in place let me know and I can run whatever commands you need to get the site deployed correctly (to include creating the settings-local file).

There is a cron job in place which updates this site every 5 minutes or so.  You might be able to get things going without my help with just this.  FYI I will be out for the next two days so if you need help ping cshields on IRC and he can get someone to assist you.

Please let me know if there is anything more I can do for you.

Oh and I have no issue with the stage and prod requests being on the same bug, plus you can just assign that bug to me when you create it.

Cheers
Thanks for setting up our instance Jason!

I just pushed some code in our repo, basically a off-the-shelf playdoh codebase. I get a 500 error which I guess is due to the missing database. Can you please verify / create a database for us?

Is there a way to see apache's (error) logs?

Cheers
(Assignee)

Comment 5

6 years ago
Giorgos,

I did not create a database as the mana docs specifically says none was needed :).  I created one now but I do not see where the settings file is (so I have no idea what is included AKA what to name my local config file).  I usually find this somewhere like settings/local.py-dist which I crib off of. Can you please let me know where this is / should be so I can get it set up?

Thanks
(Assignee)

Comment 6

6 years ago
Also,

Once I have that file I can set debug=True and you can see the error output in the browser.

Cheers
You did the right thing! We obviously missed the database part, sorry ;)

You can find "local.py-dist" under remo/settings/ directory

Thanks
(Assignee)

Comment 8

6 years ago
Giorgos,

Oh I see now.  This must be the new layout, where there is a directory called remo inside the root directory called remo.  Anyhow, I have things set up now (submodules and vendor). I got all the usual manage.py stuff to run correctly (syncdb etc).  There seems to be an issue on the server now, it is complaining about the settings module.  Not sure what the issue is.

[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240] mod_wsgi (pid=24358): Exception occurred processing WSGI script '/data/www/reps-dev.allizom.org/remo/wsgi/playdoh.wsgi'.
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240] Traceback (most recent call last):
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240]   File "/data/www/reps-dev.allizom.org/remo/vendor/src/django/django/core/handlers/wsgi.py", line 250, in __call__
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240]     self.load_middleware()
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240]   File "/data/www/reps-dev.allizom.org/remo/vendor/src/django/django/core/handlers/base.py", line 39, in load_middleware
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240]     for middleware_path in settings.MIDDLEWARE_CLASSES:
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240]   File "/data/www/reps-dev.allizom.org/remo/vendor/src/django/django/utils/functional.py", line 276, in __getattr__
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240]     self._setup()
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240]   File "/data/www/reps-dev.allizom.org/remo/vendor/src/django/django/conf/__init__.py", line 42, in _setup
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240]     self._wrapped = Settings(settings_module)
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240]   File "/data/www/reps-dev.allizom.org/remo/vendor/src/django/django/conf/__init__.py", line 89, in __init__
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240]     raise ImportError("Could not import settings '%s' (Is it on sys.path?): %s" % (self.SETTINGS_MODULE, e))
[Tue Jan 17 17:46:16 2012] [error] [client 10.8.33.240] ImportError: Could not import settings 'settings' (Is it on sys.path?): No module named settings
Jason,

I just created a symlink to remo/settings into the toplevel link the everything worked fine! ;)

There seems to be a need to fine-tune funfactory to produce the correct schema. As you said manage.py works with the nested settings directory but apparently wsgi script doesn't.

Thank you for your time ;)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Please provide Celery as well.

I updated the mana page to represent that.

Thanks!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

6 years ago
Giorgos,

I believe that I have Celery set up and working.  I am not sure how to test the connection through the app.  Can you either test and let me know if it is working or provide me with instructions to test the app?

Thanks
Status: REOPENED → ASSIGNED
Tested working!

Thanks! ;)
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Please add a cronjob to update product details once per week.

./manage.py update_product_details

I changed our mana page to reflect that.

Thanks!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 14

6 years ago
Dev already has this included in the normal update script which runs off of cron every 5 minutes.

Regards
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.