Closed Bug 718848 Opened 8 years ago Closed 8 years ago

Include Sync Setup UI changes

Categories

(Firefox for Android :: Android Sync, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla12
Tracking Status
firefox11 --- verified
fennec + ---

People

(Reporter: liuche, Assigned: liuche)

References

Details

Attachments

(4 files)

Bug to keep track of UI changes after design meeting:

Design:
http://www.flickr.com/photos/madhava_work/6360153407/sizes/o/in/photostream/


- Theming
- new Sync strings
- (try to) redirect user to Firefox Sync account settings
Assignee: nobody → liuche
Blocks: 718643
Blocks: 718242
This is the proposed JPAKE screen text, from the meeting last week:
http://cl.ly/0Q18120J18273W2i0X0I

Subheader: "Enter this code on your desktop"
Body:  "Select "Pair a Device" in the Sync section of your desktop Firefox options. Show me how"  -- with the "show me how" being a link to the SUMO article.

One revision to this is to say "computer" rather than "desktop" in the subheader
If this is already landed, then great; otherwise, we are likely to be late for string freeze, because it won't happen today or tomorrow. No idea what happens then...
Initial round of string changes:
https://github.com/mozilla-services/android-sync/commit/6de0b27fb71c006100600488ea64b81859cfb9b4

String revision from comment 1:
https://github.com/mozilla-services/android-sync/commit/ca061767377bddabef53710d1999b428826fd727

I don't think the first one has landed in MC yet, was just merged into github yesterday (pull request #30: string-changes).
target firefox 11?
tracking-fennec: --- → ?
tracking-fennec: ? → +
Regressions in J-PAKE screen:

* Clickable links are unstyled. If I didn't already know, I'd be really confused by how to get to the advanced screen.
* I might be crazy, but it looks like the J-PAKE code itself is more tightly spaced. It was quite hard to read. I would tend to prefer fixed-width display, given that these aren't words.
* Sync icon is blurred. You need to make sure you pick the right one and set it to the correct size.


Comments that aren't strictly regressions:

* "Advanced setup" ought to be further from the J-PAKE code. I was scared of accidentally tapping something I shouldn't.
* Wow, all that black and white looks intimidating. I found the old screen altogether more inviting.
* Inadequate margins — text appears to be only 1em from the edge of the screen.
* Two headings. Confusing, particularly because one of them is the same size as body text but missing punctuation.
Comments on credentials screen:

* I have a real personal dislike of the 100%-width text entry boxes. It looks unstyled. Madhava's mockups don't address this case.
Observation: Madhava's mocks align with our original design goals for the J-PAKE UI, which used a black-on-white scheme for each code fragment to evoke the appearance of the destination text boxes on the other device.

(See Fennec 10 and desktop Firefox.)

The UI as implemented has a white code on a black background instead. Was this intentional, or an accidental omission?
Blocks: 720933
In develop and landed on inbound with Bug 720933.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
looks good with m-c build from 20120126 on 2.2

(In reply to Richard Newman [:rnewman] from comment #7)
> Regressions in J-PAKE screen:
> 
> * Clickable links are unstyled. If I didn't already know, I'd be really
> confused by how to get to the advanced screen.
both links are underlined

> * I might be crazy, but it looks like the J-PAKE code itself is more tightly
> spaced. It was quite hard to read. I would tend to prefer fixed-width
> display, given that these aren't words.
codes don't appear squeezed together

> * Sync icon is blurred. You need to make sure you pick the right one and set
> it to the correct size.
no longer blurry

> 
> 
> Comments that aren't strictly regressions:
> 
> * "Advanced setup" ought to be further from the J-PAKE code. I was scared of
> accidentally tapping something I shouldn't.
nice separation now

> * Wow, all that black and white looks intimidating. I found the old screen
> altogether more inviting.
stayed with all that black and white per mocks

> * Inadequate margins — text appears to be only 1em from the edge of the
> screen.
margins appear sufficient

> * Two headings. Confusing, particularly because one of them is the same size
> as body text but missing punctuation.
Bold heading regular text instructions.
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla12
Verified on Fx11
Product: Mozilla Services → Android Background Services
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.