Closed Bug 720933 Opened 8 years ago Closed 8 years ago

[meta] Android Sync 0.3 code drop

Categories

(Firefox for Android :: Android Sync, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox11 --- verified

People

(Reporter: rnewman, Assigned: rnewman)

References

Details

Tracking what's going in to the next one.

Thus far (with my not-yet-merged stuff from liuche's pull request #40):

7993ba4 Bug 718848 - Part 7: More link styling, pin display styling, alignment per UI feedback.
c726107 Bug 718848 - Part 6: Fixed regression of progressbar layout.
ec71a73 Bug 718848 - Part 5: Indentation alignment.
ad6f8a8 Bug 718848 - Part 4: Fixes for links, icon blurriness, PIN display.
4093d2d Bug 718848 - Part 3: Whitespace changes.
20276aa Bug 718848 - Part 2: Setting theme on start of Sync setup.
9d27381 Bug 718848 - Part 1: Theme and layout changes, per UI meeting.
42cc4f3 Bug 717075 - make classic setup hint text visible. Added basic SyncTheme.
25e8b0b Eliminate deps.sh, reorganize build and deploy scripts.
962fa59 Merge pull request #38 from mozilla-services/marina/merge-script-changes
47956ef Bug 709660 - Split drawable manifest into 4
3ecff39 Merge branch 'bug-717691' into develop
249419b Bug 717691 - Part 1: fall back to supported cipher suites for older Android releases.
d0b5ed4 Bug 797691 - Part 0: Specify HTTP 1.1 in HTTP requests.
ff52525 Merge pull request #35 from mozilla-services/bug-719669-throw
54da18e Bug 718848 - Part 2: fixed string revision: "computer" not "desktop".  r=rnewman
55bbbe4 Bug 719669 - Part 1: throw IncorrectZkpException when g^x^q % p = 1 in J-PAKE.
2e8fcb5 Bug 719669 - Part 0: code reformatting and string tidying.
6b95322 Merge pull request #32 from mozilla-services/launch-settings
6de0b27 Merge pull request #30 from mozilla-services/string-changes
98cecd7 Bug 718149 - go somewhere useful after Firefox Sync set up, on launch.
125c280 Working on 0.3.
da399b1 New strings per design review.

Plus Makefile changes:

 Bug 718928 - AndroidManifest.xml does not depend on Sync manifest include fragments. r=khuey
 Bug 709660 - correctly process resolution-specific Sync resources. f=rnewman
Play spot the typo: Bug 797691 should of course be Bug 717691. I shan't rewrite history to fix that.
Blocks: 720934
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Try run for 5337493d509d is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=5337493d509d
Results (out of 55 total builds):
    exception: 1
    success: 49
    warnings: 4
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/rnewman@mozilla.com-5337493d509d
Adding Bug 721129, a small crypto fix.
Depends on: 721129
Depends on: 720471
Blocks: 721271
Is there a specific reason for using "..." instead of "…" on Android?
(In reply to Francesco Lodolo [:flod] from comment #7)
> Is there a specific reason for using "..." instead of "…" on Android?

We do use the proper ellipsis character in most places:

<!ENTITY sync.jpake.subtitle.waiting.label 'Waiting for other device…'>
<!ENTITY sync.link.nodevice.label 'I don\&apos;t have the device with me…'>

There's only one string that doesn't (except for the J-PAKE placeholders, and those don't count):

<!ENTITY sync.link.advancedsetup.label 'Advanced setup...'>

I will fix this, because I am a typography nerd.
(In reply to Richard Newman [:rnewman] from comment #8)

> I will fix this, because I am a typography nerd.

Filed 721305. Thanks for the report!
Verified per depends bugs
Status: RESOLVED → VERIFIED
Product: Mozilla Services → Android Background Services
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.