java.lang.IndexOutOfBoundsException: getChars (0 ... 88168) ends beyond length 0

RESOLVED FIXED in Firefox 11

Status

()

Firefox for Android
General
P1
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mfinkle, Assigned: dougt)

Tracking

({crash})

unspecified
Firefox 12
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox11 fixed, firefox12 fixed, fennec11+)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

This is one of the types of TouchMemory errors.

java.lang.IndexOutOfBoundsException: getChars (0 ... 88168) ends beyond length 0
	at android.text.SpannableStringBuilder.checkRange(SpannableStringBuilder.java:943)
	at android.text.SpannableStringBuilder.getChars(SpannableStringBuilder.java:847)
	at android.text.SpannableStringBuilder.toString(SpannableStringBuilder.java:869)
	at org.mozilla.gecko.GeckoInputConnection.getExtractedText(GeckoInputConnection.java:201)
	at com.android.internal.view.IInputConnectionWrapper.executeMessage(IInputConnectionWrapper.java:318)
	at com.android.internal.view.IInputConnectionWrapper$MyHandler.handleMessage(IInputConnectionWrapper.java:86)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:150)
	at org.mozilla.gecko.GeckoApp$31.run(GeckoApp.java:1547)

Updated

5 years ago
Blocks: 719373
Severity: normal → critical
Crash Signature: [@ TouchBadMemory]
Keywords: crash
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Whiteboard: [native-crash]
alex, dupe as appropriate
Assignee: nobody → alexp
tracking-fennec: --- → 11+
Priority: -- → P1
dup of bug 717932?

Updated

5 years ago
Duplicate of this bug: 717932

Updated

5 years ago
Duplicate of this bug: 720085
Made this bug the main one, as it is about the actual exception in Java code, causing the crashes:
https://crash-stats.mozilla.com/report/index/ecc2e65d-fc9e-40eb-afb9-14a3b2120121
https://crash-stats.mozilla.com/report/index/829fd557-b272-480f-b1f5-fbcc52120121
https://crash-stats.mozilla.com/report/index/ecc2e65d-fc9e-40eb-afb9-14a3b2120121
https://crash-stats.mozilla.com/report/list?query_search=signature&query_type=contains&reason_type=contains&range_value=4&range_unit=weeks&hang_type=any&process_type=any&signature=mozalloc_abort%20|%20__swrite%20|%20dlfree%20|%20dlfree%20|%20loadLibs
As mentioned in the bug 720085, the following issue might be related
http://code.google.com/p/android/issues/detail?id=5164

Updated

5 years ago
Crash Signature: [@ TouchBadMemory] → [@ TouchBadMemory] [@ mozalloc_abort | dexDataMapAlloc]

Updated

5 years ago
Depends on: 722044
(Assignee)

Comment 7

5 years ago
Created attachment 593128 [details] [diff] [review]
patch v.1
Assignee: alexp → doug.turner
Attachment #593128 - Flags: review?(alexp)

Updated

5 years ago
Attachment #593128 - Flags: review?(alexp) → review+
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/mozilla-central/rev/bbc7014db2de
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 593128 [details] [diff] [review]
patch v.1

[Triage Comment]
simple try-catch to catch the condition and not crash
Attachment #593128 - Flags: approval-mozilla-beta+
Attachment #593128 - Flags: approval-mozilla-aurora+

Comment 10

5 years ago
It landed just before 12.0 becomes Aurora: http://hg.mozilla.org/mozilla-central/rev/801015738a12.
An Aurora approval means it will land twice in 12.0.
status-firefox11: --- → affected
status-firefox12: --- → fixed
Target Milestone: --- → Firefox 12
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/09e15a877c86
https://hg.mozilla.org/releases/mozilla-beta/rev/7be7d0bdedcd
status-firefox11: affected → fixed
(Assignee)

Updated

5 years ago
Duplicate of this bug: 724425

Updated

5 years ago
No longer depends on: 722044

Updated

5 years ago
No longer blocks: 719373
Crash Signature: [@ TouchBadMemory] [@ mozalloc_abort | dexDataMapAlloc] → [@ java.lang.IndexOutOfBoundsException: getChars (0 ... 88168) ends beyond length 0 at android.text.SpannableStringBuilder.checkRange(SpannableStringBuilder.java)]
Blocks: 772225
You need to log in before you can comment on or make changes to this bug.