Closed Bug 719373 Opened 8 years ago Closed 8 years ago

[meta] crash @ TouchBadMemory

Categories

(Firefox for Android :: General, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking-fennec1.0 --- -

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, meta, topcrash, Whiteboard: [native-crash])

Crash Data

OOM crashes are now tracked under the TouchBadMemory crash signature from 12.0a1/20120115.
So it's #2 top crasher in 12.0a1 over the last 3 days and will be #1 once bug 718765 will be fixed.

I gathered every Java exceptions in App Notes that I broke down by type:
* java.lang.RuntimeException:
+ Unable to start activity ComponentInfo{org.mozilla.fennec/org.mozilla.fennec.App}: java.lang.IllegalThreadStateException: Thread already started. at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1955)
+ Unable to start activity ComponentInfo{org.mozilla.fennec/org.mozilla.gecko.TabsTray}: java.util.ConcurrentModificationException at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1768)
+ Unable to destroy activity {org.mozilla.fennec/org.mozilla.fennec.App}: java.lang.IllegalArgumentException: Receiver not registered: org.mozilla.gecko.GeckoNetworkManager@41918618 at at android.app.ActivityThread.performDestroyActivity(ActivityThread.java:3108)
+ Unable to resume activity {org.mozilla.fennec/org.mozilla.gecko.sync.setup.activities.SetupSyncActivity}: android.view.InflateException: Binary XML file line #21: Error inflating class <unknown> at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2241)

* java.lang.IndexOutOfBoundsException:
+ getChars (0 ... 34784) ends beyond length 34772 at android.text.SpannableStringBuilder.checkRange(SpannableStringBuilder.java:978)
+ src.length=32762 srcPos=6313 dst.length=26450 dstPos=0 length=26450 at java.lang.System.arraycopy(Native Method)

* java.lang.IllegalArgumentException:
+ View not attached to window manager at android.view.WindowManagerImpl.findViewLocked(WindowManagerImpl.java:542)
+ pointerIndex out of range at android.view.MotionEvent.nativeGetPointerId(Native Method)

* java.lang.IllegalStateException:
+ The content of the adapter has changed but ListView did not receive a notification. Make sure the content of your adapter is not modified from a background thread, but only from the UI thread. [in ListView(2131492881, class android.widget.ListView) with Adapter(class org.mozilla.gecko.AwesomeBarTabs$AwesomeBarCursorAdapter)] at android.widget.ListView.layoutChildren(ListView.java:1538)

* java.lang.ClassCastException:
+ java.lang.String at org.mozilla.gecko.AwesomeBar.onCreateContextMenu(AwesomeBar.java:422)

* android.view.InflateException: Binary XML file line #19: Error inflating class <unknown> at android.view.LayoutInflater.createView(LayoutInflater.java:518)
Thanks, Scoobi.  FYI : bug 718907 have all the java crashes from the App notes.
Duplicate of this bug: 719795
If this is supposed to be a meta bug it needs the meta keyword.
Keywords: meta
Filed bug 720092 for:

* java.lang.IndexOutOfBoundsException:
+ getChars (0 ... 34784) ends beyond length 34772 at android.text.SpannableStringBuilder.checkRange(SpannableStringBuilder.java:978)
+ src.length=32762 srcPos=6313 dst.length=26450 dstPos=0 length=26450 at java.lang.System.arraycopy(Native Method)
Depends on: 720092
(In reply to Mark Finkle (:mfinkle) from comment #4)
> + getChars (0 ... 34784) ends beyond length 34772 at
> android.text.SpannableStringBuilder.checkRange(SpannableStringBuilder.java:
> 978)
> + src.length=32762 srcPos=6313 dst.length=26450 dstPos=0 length=26450 at
> java.lang.System.arraycopy(Native Method)
In comment 0, each + represents an error that is broken down in several kinds of errors (*).
So there are 11 errors broken down in 6 kinds.

It should have 11 dependent bugs, more or less, as some errors are now fixed, others appeared and some are in low volume.
For instance, the "Binary XML file line #19" error is already tracked with bug 705874, so it can be marked as a dependency of this bug.
Dependencies are hard to determine as the error is not always in the bug summary.
Depends on: 718904, 705874
Depends on: 719795
Depends on: 720734
Depends on: 721342
Depends on: 722044
Depends on: 723495
So everything was getting put in this bucket but now that we have broken things down into various Java signatures, the crashes getting dumped into this signature are much lower. It's no longer a top crash itself. Removing the keyword.
Keywords: topcrash
No longer depends on: 721342
No longer depends on: 720092
Depends on: 736526, 736522, 720353, 705641
This is now our #1 topcrash on mozilla-central. I think perhaps we need to add TouchBadMemory to the skip list?
blocking-fennec1.0: --- → ?
Keywords: topcrash
(In reply to Joe Drew (:JOEDREW!) from comment #7)
> This is now our #1 topcrash on mozilla-central. I think perhaps we need to
> add TouchBadMemory to the skip list?
It is in the skiplist (see bug 722044). I don't think we track meta bugs.
If you want to reprocess previous crashes, file a bug.
(In reply to Joe Drew (:JOEDREW!) from comment #7)
> This is now our #1 topcrash on mozilla-central. I think perhaps we need to
> add TouchBadMemory to the skip list?

As Scoobidiver said, that has already been done, and should impact data from today forward (it was applied on production yesterday).
I think we should reprocess the data at least up to the last train : Bug 738506 filed.
Waiting to reprocess crash data
Waiting also that bug 738225 is fixed.
Depends on: 738935
Depends on: 738940
Depends on: 738942
Depends on: 738943
Depends on: 736714
Depends on: 736220
crash stats has been fixed to add TouchbadMemory to the skip list
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
blocking-fennec1.0: ? → -
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.