Awesome bar shouldn't start search on Enter key pressed if there is composition string

VERIFIED FIXED in Firefox 13

Status

()

Firefox for Android
Keyboards and IME
P3
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: m_kato, Assigned: cpeterson)

Tracking

unspecified
Firefox 14
All
Android
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox13 fixed, firefox14 verified, firefox15 verified, blocking-fennec1.0 +, fennec11+)

Details

(Whiteboard: [HKB])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
When there is composition string on awesome bar, if you press "enter key", Fennec native will start search or URL navigation.

On stock browser or Fennec XUL, if there is composition string, "enter key" means commiting string.

When there is composition string, we should commit text if entry key is pressed.
(Reporter)

Updated

6 years ago
Whiteboard: [HKB]
Assignee: nobody → alexp
tracking-fennec: --- → 11+
Priority: -- → P3

Updated

6 years ago
Summary: Awesome bar doesn't start search when Enter key press if there is composition string → Awesome bar shouldn't start search on Enter key pressed if there is composition string
This bug is a side-effect of the fix for bug 705939.
The keyboard handling in the Awesomebar is a bit hacky. Due to some internal specifics of the UI controls used for that screen the edit box sometimes loses its focus, and we cannot handle the input properly in some cases. The bug 702995 was filed to investigate this, but there is still no solution. The issues appearing are being patched, but those workarounds may cause other problems, and here's one of such examples.
We may try to add another check into onKeyPreIme listener to handle this specific situation here: http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/AwesomeBar.java#168
Though I'm not sure yet if it's possible to check the current composition state.
(Assignee)

Updated

6 years ago
Assignee: alex.mozilla → cpeterson
(Assignee)

Updated

6 years ago
blocking-fennec1.0: --- → ?
(Assignee)

Comment 2

6 years ago
I think this bug should be a fennec-1.0 blocker because it prevents the user from entering a URL.
blocking-fennec1.0: ? → +
(Assignee)

Updated

6 years ago
Component: General → IME
(Assignee)

Comment 3

6 years ago
This bug may depend on bug 737653.
Depends on: 737653
(Assignee)

Comment 4

6 years ago
Makoto, can you still reproduce this bug? I tested Google Japanese Input method on my Galaxy Nexus and Samsung S2, but I can't reproduce the problem.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

6 years ago
(In reply to Chris Peterson (:cpeterson) from comment #4)
> Makoto, can you still reproduce this bug? I tested Google Japanese Input
> method on my Galaxy Nexus and Samsung S2, but I can't reproduce the problem.

Google Japanese Input doesn't support Hardware keyboard.  Try Shimeji or OpenWnn on HTC Desire Z.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Simeji reproduces the issue on any device.  cpeterson, if you're in SF Office, I can show you in person.
(Assignee)

Comment 7

6 years ago
Created attachment 608548 [details] [diff] [review]
bug-720300-awesomebar-composition-string.patch

Don't submit AwesomeBar text when there is an active composition string.

This patch generalizes Makato-san's fix for bug 715207 so we can check for a composition string when processing ENTER keydown events. This bug only affects HKB.
Attachment #608548 - Flags: review?(m_kato)
Attachment #608548 - Flags: review?(blassey.bugs)
(Assignee)

Comment 8

6 years ago
oops: Makoto, not "Makato"! <:)
Attachment #608548 - Flags: review?(blassey.bugs) → review+
(Reporter)

Updated

6 years ago
Attachment #608548 - Flags: review?(m_kato) → review+
(Assignee)

Comment 9

6 years ago
checkin-needed for mozilla-central
Keywords: checkin-needed
(Assignee)

Comment 10

6 years ago
Comment on attachment 608548 [details] [diff] [review]
bug-720300-awesomebar-composition-string.patch

[Approval Request Comment]
Regression caused by (bug #): bug 705939
User impact if declined: Multibyte text input will not work in AwesomeBar.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): AwesomeBar text input.
String changes made by this patch: None
Attachment #608548 - Flags: approval-mozilla-aurora?
Comment on attachment 608548 [details] [diff] [review]
bug-720300-awesomebar-composition-string.patch

[Triage Comment]
Mobile only - approved for Aurora 13.
Attachment #608548 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/integration/mozilla-inbound/rev/6ad4454a4c83
Flags: in-testsuite?
Keywords: checkin-needed
Target Milestone: --- → Firefox 14
https://hg.mozilla.org/mozilla-central/rev/6ad4454a4c83
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

6 years ago
checkin-needed for mozilla-aurora
Keywords: checkin-needed
(Reporter)

Comment 15

6 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/8f8963784772
status-firefox13: --- → fixed
Keywords: checkin-needed
Verified fixed on:

Firefox 15.0a1 (2012-05-21)
Firefox 14.0a2 (2012-05-21)

Device: Galaxy Nexus
OS: Android 4.0.2
Status: RESOLVED → VERIFIED
status-firefox14: --- → verified
status-firefox15: --- → verified
You need to log in before you can comment on or make changes to this bug.