Closed Bug 720673 Opened 8 years ago Closed 7 years ago

Close button shifts places while Closing a tab

Categories

(Firefox :: Theme, defect)

12 Branch
All
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Optimizer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120123 Firefox/12.0a1
Build ID: 20120123095741

Steps to reproduce:

Close a tab either by clicking on the cross/close button on the right corner, or pressing middle mouse button on tab bar.


Actual results:

1. The title text disappears.
2. The close button moves to the left end of the tab being closed
3. Tab's width starts decreasing until it reaches the width of the close button.
4. Close buttons disappears.
5. Tab's width reduces to 0 and then tab disappears



Expected results:

Step 4 should just happen along with step 1. or even before it.
In the current situation, the closing animation gets jittery while removing the close button. If the button is not present, the animation would be smooth throughout.
Blocks: 59368
Keywords: perf
Hardware: x86_64 → All
Blocks: 593680
No longer blocks: 59368
Component: Untriaged → Theme
Can you reproduce this in safe mode? In a new profile?
QA Contact: untriaged → theme
Not in new profile, but in safe mode, with add-ons disabled, even though the close button does not shift to left, and just disappears, there is a jerk at the same point, as if the close button existed and now was being removed.
Well, may be it is on my own system only.
Just wanted to discuss about this issue with people concerned so filed a bug
We need to narrow down why this is happening in safe mode. Can you attach your about:support output?

  Application Basics

        Name
        Firefox

        Version
        12.0a1

        User Agent
        Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120123 Firefox/12.0a1

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Auto Complete
        1.2
        true
        AutoComplete@girishsharma

        FireGestures
        1.6.7
        true
        firegestures@xuldev.org

        Greasemonkey
        0.9.14
        true
        {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

        Open Bookmarks in New Tab
        0.1.2011120101
        true
        openbookmarkintab@piro.sakura.ne.jp

        Proxy Selector
        0.80.6
        true
        proxyselector@mozilla.org

        Stylish
        1.2.5
        true
        {46551EC9-40F0-4e47-8E18-8E5CF550CFB8}

        UI Enhancer
        3.1
        true
        UIEnhancer@girishsharma

        WordWeb one-click lookup
        5.0.1701
        true
        wcapturex@deskperience.com

        Firefox Synchronisation Extension
        1.7.56.205
        false
        fe_7.0@nokia.com

        RealPlayer Browser Record Plugin
        14.0.5
        false
        {ABDE892B-13A8-4d1b-88E6-365A6E755758}

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage
        http://www.facebook.com/|www.igoogle.com

        browser.startup.homepage_override.buildID
        20120123095741

        browser.startup.homepage_override.mstone
        rv:12.0a1

        browser.tabs.homeTab
        true

        browser.tabs.loadBookmarksInBackground
        true

        browser.tabs.loadDivertedInBackground
        true

        browser.tabs.warnOnClose
        false

        browser.tabs.warnOnOpen
        false

        dom.min_background_timeout_value
        4

        extensions.checkCompatibility
        false

        extensions.checkCompatibility.10.0
        false

        extensions.checkCompatibility.10.0a
        false

        extensions.checkCompatibility.11.0
        false

        extensions.checkCompatibility.11.0a
        false

        extensions.checkCompatibility.3.6
        false

        extensions.checkCompatibility.3.6b
        false

        extensions.checkCompatibility.3.6p
        false

        extensions.checkCompatibility.3.6pre
        false

        extensions.checkCompatibility.3.7a
        false

        extensions.checkCompatibility.4.0
        false

        extensions.checkCompatibility.4.0b
        false

        extensions.checkCompatibility.4.0p
        false

        extensions.checkCompatibility.4.0pre
        false

        extensions.checkCompatibility.4.2
        false

        extensions.checkCompatibility.4.2a
        false

        extensions.checkCompatibility.4.2b
        false

        extensions.checkCompatibility.4.2p
        false

        extensions.checkCompatibility.4.2pre
        false

        extensions.checkCompatibility.5.0
        false

        extensions.checkCompatibility.5.0a
        false

        extensions.checkCompatibility.5.0b
        false

        extensions.checkCompatibility.5.0p
        false

        extensions.checkCompatibility.5.0pre
        false

        extensions.checkCompatibility.6.0
        false

        extensions.checkCompatibility.6.0a
        false

        extensions.checkCompatibility.7.0
        false

        extensions.checkCompatibility.7.0a
        false

        extensions.checkCompatibility.8.0
        false

        extensions.checkCompatibility.8.0a
        false

        extensions.checkCompatibility.9.0
        false

        extensions.checkCompatibility.9.0a
        false

        extensions.lastAppVersion
        12.0a1

        gfx.content.azure.enabled
        false

        network.cookie.prefsMigrated
        true

        network.http.spdy.enabled
        true

        places.database.lastMaintenance
        1327345269

        places.history.expiration.transient_current_max_pages
        20723

        places.history.expiration.transient_optimal_database_size
        39556136

        privacy.cpd.cookies
        false

        privacy.cpd.downloads
        false

        privacy.cpd.formdata
        false

        privacy.cpd.history
        false

        privacy.cpd.sessions
        false

        privacy.donottrackheader.enabled
        true

        privacy.popups.showBrowserMessage
        false

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.timeSpan
        0

        security.dialog_enable_delay
        10

        security.warn_viewing_mixed
        false

        webgl.msaa-level
        4

  Graphics

        Adapter Description
        NVIDIA GeForce GTX 260

        Vendor ID
        0x10de

        Device ID
        0x05e2

        Adapter RAM
        896

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.17.12.9053

        Driver Date
        12-17-2011

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17563)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE (NVIDIA GeForce GTX 260) -- OpenGL ES 2.0 (ANGLE 1.0.0.930)

        GPU Accelerated Windows
        1/1 Direct3D 10

        AzureBackend
        direct2d
(In reply to Marco Castelluccio [:marco] from comment #5)
> Is this what you see? http://dl.dropbox.com/u/34104919/20120501_001230.mp4

Not really, currently I am unable to reproduce it, so closing
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.