Support 'mailbloat' test target in SeaMonkey

RESOLVED FIXED in seamonkey2.9

Status

SeaMonkey
Build Config
P2
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

(Blocks: 2 bugs)

Trunk
seamonkey2.9
Dependency tree / graph
Bug Flags:
in-testsuite -

SeaMonkey Tracking Flags

(seamonkey2.6 wontfix, seamonkey2.7 wontfix, seamonkey2.8 wontfix)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Assignee)

Description

6 years ago
http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry&rev=79c7730a8bb6
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTry/1327572648.1327582892.14286.gz&fulltext=1
Linux x86-64 try-comm-central leak test build on 2012/01/26 02:10:48
s: momo-vm-linux64-01
{
make: *** No rule to make target `mailbloat'.  Stop.
}

***

http://mxr.mozilla.org/comm-central/search?string=mailbloat&case=1&find=%2Fmailnews%2Ftest

This is a SeaMonkey build, but it looks like to be explicitly supported:
http://mxr.mozilla.org/comm-central/source/mailnews/testsuite-targets.mk#50
{
46 ifdef MOZ_SUITE
47 EXTRA_BLOAT_ARGS := -mail
48 endif
49 
50 mailbloat:
}

I'm not sure what went wrong.
This is more likely build config than try server, especially given that it works for Thunderbird. My immediate suspicion is that SM isn't including the targets.
Component: Release Engineering → Build Config
Product: Mozilla Messaging → SeaMonkey
QA Contact: release → build-config
Version: other → unspecified
(Assignee)

Comment 2

6 years ago
Created attachment 591778 [details] [diff] [review]
(Av1) Add support for MailNews Core test suites to SeaMonkey

(I will test it on TB Try after review.)
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #591778 - Flags: review?(bugspam.Callek)
(Assignee)

Updated

6 years ago
status-seamonkey2.6: --- → wontfix
status-seamonkey2.7: --- → affected
status-seamonkey2.8: --- → affected
Depends on: 506202
Flags: in-testsuite-
OS: Linux → All
Priority: -- → P2
Hardware: x86_64 → All
Summary: TB Try: "make: *** No rule to make target `mailbloat'. Stop." → Port mailnews part of bug 506202 to SeaMonkey, to support 'mailbloat' test target
Target Milestone: --- → seamonkey2.9
Version: unspecified → Trunk
(Assignee)

Updated

6 years ago
Blocks: 721391
I intend to test this sometime next week, likely after this train leaves the station. Since it only affects us when compiled on TB-based try, its not urgent.
(Assignee)

Updated

6 years ago
Blocks: 524125
(Assignee)

Comment 4

6 years ago
Comment on attachment 591778 [details] [diff] [review]
(Av1) Add support for MailNews Core test suites to SeaMonkey

(In reply to Serge Gautherie (:sgautherie) from comment #2)
> (I will test it on TB Try after review.)

http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry&rev=223dbe5a1fee
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTry/1327614432.1327627615.26961.gz&fulltext=1
WINNT 5.2 try-comm-central leak test build on 2012/01/26 13:47:12
{
d:/mozilla-build/python25/python2.5.exe -u /e/buildbot/try-comm-cen-w32-dbg/build/mozilla/config/pythonpath.py \
        -I./mozilla/dist/../build -I/e/buildbot/try-comm-cen-w32-dbg/build/mozilla/build \
        /e/buildbot/try-comm-cen-w32-dbg/build/mailnews/test/performance/bloat/runtest.py \
	--distdir=./mozilla/dist --bin=seamonkey --brand=SeaMonkeyDebug \
	--symbols-path=./mozilla/dist/crashreporter-symbols -mail
Usage: Usage instructions for runtest.py.
All arguments must be specified.


runtest.py: error: no such option: -m
make: *** [mailbloat] Error 2
}

suite/ part seems fine.
But there seems to have an issue in mailnews/ file. (Patch coming up...)
(Assignee)

Comment 5

6 years ago
Created attachment 592090 [details] [diff] [review]
(Bv1) Fix support for SeaMonkey in MailNews Core 'mailbloat' target

http://mxr.mozilla.org/comm-central/source/mailnews/test/performance/bloat/runtest.py

I assume this patch is what was meant to be:
there is no '-mail' arg, but there is
{
79         self.add_option("--extra-startup-arg",
80                         action = "store", type = "string", dest = "extraArg",
81                         help = "Extra startup argument if required, at the moment this will only support one extra argument with no parameters")
}
Attachment #592090 - Flags: review?(mbanner)
(Assignee)

Comment 6

6 years ago
Comment on attachment 592090 [details] [diff] [review]
(Bv1) Fix support for SeaMonkey in MailNews Core 'mailbloat' target

This patch works fine too.
(Though there is a 3rd issue to investigate...)

http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry&rev=1c940d34c9fa
+
http://build.mozillamessaging.com/buildbot/try/builders/WINNT%205.2%20try-comm-central%20leak%20test%20build/builds/120/steps/make_mailbloat/logs/stdio
{
make mailbloat
 in dir e:\buildbot\try-comm-cen-w32-dbg\build/obj-firefox (timeout 1200 secs)
...
INFO | runtest.py | Running bloatTests in e:\buildbot\try-comm-cen-w32-dbg\build\obj-firefox : 
INFO | runtest.py |  e:\buildbot\try-comm-cen-w32-dbg\build\obj-firefox\mozilla\dist\bin\seamonkey ['-no-remote', '-profile', 'e:\\buildbot\\try-comm-cen-w32-dbg\\build\\obj-firefox\\mozilla\\dist\\..\\_tests\\mailbloat\\leakprofile', '-mail']
...
Chrome file doesn't exist: e:\buildbot\try-comm-cen-w32-dbg\build\obj-firefox\mozilla\dist\bin\chrome\toolkit\skin\classic\global\checkbox\cbox-dis.gif
...
JavaScript strict warning: chrome://global/content/bindings/tree.xml, line 0: reference to undefined property this.treeBoxObject.view
...
###!!! ASSERTION: URI is empty: '!aURI.IsEmpty()', file e:/buildbot/try-comm-cen-w32-dbg/build/mozilla/rdf/base/src/nsRDFService.cpp, line 924
...
(And the build seems to be stalled in that state:
 20 mn timeout has not fired or has silently failed :-/)
}
(Assignee)

Comment 7

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #6)
> Chrome file doesn't exist:
> e:\buildbot\try-comm-cen-w32-dbg\build\obj-
> firefox\mozilla\dist\bin\chrome\toolkit\skin\classic\global\checkbox\cbox-
> dis.gif

I filed bug 722019.
That issue should be unrelated.
Comment on attachment 592090 [details] [diff] [review]
(Bv1) Fix support for SeaMonkey in MailNews Core 'mailbloat' target

r=me, although I'm a bit surprised you don't need quotes round the -mail.
Attachment #592090 - Flags: review?(mbanner) → review+
Comment on attachment 591778 [details] [diff] [review]
(Av1) Add support for MailNews Core test suites to SeaMonkey

I just had a look at the try build that you did with this. It had been running for 20 hours so I looked at the builder. It had hung at the default client dialog.

Therefore this is r- until that is fixed as I don't want people hanging try server by mistake.

I suspect the fix is easy, I suspect you just need to set the appropriate pref somewhere. The test code is pretty simple and easy to test.
Attachment #591778 - Flags: review?(bugspam.Callek) → review-
(Assignee)

Updated

6 years ago
Depends on: 722026
(Assignee)

Comment 10

6 years ago
Created attachment 592393 [details] [diff] [review]
(Cv1) Add support for SeaMonkey in MailNews Core 'mailbloat' preferences
[Checked in: Comment 18]

(In reply to Mark Banner (:standard8) from comment #9)

> I just had a look at the try build that you did with this. It had been
> running for 20 hours so I looked at the builder. It had hung at the default
> client dialog.

Should I file a bug on TB Try wrt the timeout not working in that case?

> Therefore this is r- until that is fixed as I don't want people hanging try
> server by mistake.

Agreed.

> I suspect the fix is easy, I suspect you just need to set the appropriate
> pref somewhere. The test code is pretty simple and easy to test.

Sadly, with my (windows 2000) environment, it's very impractical to run non-packaged tests :-(

***

Nonetheless, I manage to +/- reproduce this behavior and here is an (untested) attempt to fix this hang.
Attachment #592393 - Flags: review?(mbanner)
(Assignee)

Comment 11

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTry/1327664061.1327754218.7992.gz&fulltext=1
WINNT 5.2 try-comm-central leak test build on 2012/01/27 03:34:21


(In reply to Serge Gautherie (:sgautherie) from comment #6)
> JavaScript strict warning: chrome://global/content/bindings/tree.xml, line
> 0: reference to undefined property this.treeBoxObject.view
> ...
> ###!!! ASSERTION: URI is empty: '!aURI.IsEmpty()', file
> e:/buildbot/try-comm-cen-w32-dbg/build/mozilla/rdf/base/src/nsRDFService.cpp,
> line 924

(Though I don't like these, they don't seem to be more than noise atm :-|)


(In reply to Mark Banner (:standard8) from comment #9)
> It had hung at the default client dialog.

Good news is that, after you un-hang the application, these tests/build completed successfully :-)
(Assignee)

Comment 12

6 years ago
Comment on attachment 592393 [details] [diff] [review]
(Cv1) Add support for SeaMonkey in MailNews Core 'mailbloat' preferences
[Checked in: Comment 18]

(In reply to Serge Gautherie (:sgautherie) from comment #10)
> Nonetheless, I manage to +/- reproduce this behavior and here is an
> (untested) attempt to fix this hang.

Succeeded as
http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry&rev=683d2a0a4a51
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTry/1327780272.1327798628.6382.gz&fulltext=1
WINNT 5.2 try-comm-central leak test build on 2012/01/28 11:51:12
(Assignee)

Updated

6 years ago
Depends on: 460456
(Assignee)

Updated

6 years ago
No longer depends on: 722026
(Assignee)

Comment 13

6 years ago
Created attachment 592506 [details] [diff] [review]
(Bv2) Fix support for SeaMonkey in MailNews Core 'mailbloat' target
[Checked in: Comment 19]

Bv1, with comment 8 suggestion(s),
and rewriting a little this code.

Succeeded as
http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry&rev=8a36bc669d1f
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTry/1327838052.1327851095.322.gz&fulltext=1
Linux x86-64 try-comm-central leak test build on 2012/01/29 03:54:12


(In reply to Mark Banner (:standard8) from comment #8)
> r=me, although I'm a bit surprised you don't need quotes round the -mail.

I tried with (superfluous, but more explicit) '"' and it succeeded too.
Yet, using '=' seems both more usual and simpler ;-)
Attachment #592090 - Attachment is obsolete: true
Attachment #592506 - Flags: review?(mbanner)
(Assignee)

Comment 14

6 years ago
Created attachment 592507 [details] [diff] [review]
(Av2) Add support for MailNews Core test suites to SeaMonkey
[Checked in: Comment 20]

Av1, with 'BLOAT_EXTRA_ARG' setting moved here.
Attachment #591778 - Attachment is obsolete: true
Attachment #592507 - Flags: review?(mbanner)
(Assignee)

Comment 15

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTry/1327851604.1327856906.17103.gz&fulltext=1
OS X 10.6.2 try-comm-central leak test build on 2012/01/29 07:40:04
{
'make mailbloat' failed
...
INFO | runtest.py | Running register in /builds/slave/try-comm-cen-osx64-dbg/build/obj-firefox : 
...
Traceback (most recent call last):
...
OSError: [Errno 2] No such file or directory
make: *** [mailbloat] Error 1
}

I'm not sure what happened, (maybe related to bug 722026?), but I'll leave that for later (if it is reproducible (on SeaMonkey)).
(In reply to Serge Gautherie (:sgautherie) from comment #15)
> http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTry/1327851604.
> 1327856906.17103.gz&fulltext=1
> OS X 10.6.2 try-comm-central leak test build on 2012/01/29 07:40:04
...
> I'm not sure what happened, (maybe related to bug 722026?), but I'll leave
> that for later (if it is reproducible (on SeaMonkey)).

You want the SeaMonkey mac part of bug 668869.
(Assignee)

Updated

6 years ago
Depends on: 722262
(Assignee)

Comment 17

6 years ago
(In reply to Mark Banner (:standard8) from comment #16)
> > I'm not sure what happened, (maybe related to bug 722026?)
> 
> You want the SeaMonkey mac part of bug 668869.

I thought it could be related to the executable name. Thanks for the pointer to that bug.
Wrt this bug, I'll Try a workaround...
Attachment #592393 - Flags: review?(mbanner) → review+
Attachment #592507 - Flags: review?(mbanner) → review+
Attachment #592506 - Flags: review?(mbanner) → review+
(Assignee)

Comment 18

6 years ago
Comment on attachment 592393 [details] [diff] [review]
(Cv1) Add support for SeaMonkey in MailNews Core 'mailbloat' preferences
[Checked in: Comment 18]

http://hg.mozilla.org/comm-central/rev/9b1782c766aa
Attachment #592393 - Attachment description: (Cv1) Add support for SeaMonkey in MailNews Core 'mailbloat' preferences → (Cv1) Add support for SeaMonkey in MailNews Core 'mailbloat' preferences [Checked in: Comment 18]
(Assignee)

Comment 19

6 years ago
Comment on attachment 592506 [details] [diff] [review]
(Bv2) Fix support for SeaMonkey in MailNews Core 'mailbloat' target
[Checked in: Comment 19]

http://hg.mozilla.org/comm-central/rev/73d713767f75
Attachment #592506 - Attachment description: (Bv2) Fix support for SeaMonkey in MailNews Core 'mailbloat' target → (Bv2) Fix support for SeaMonkey in MailNews Core 'mailbloat' target [Checked in: Comment 19]
(Assignee)

Comment 20

6 years ago
Comment on attachment 592507 [details] [diff] [review]
(Av2) Add support for MailNews Core test suites to SeaMonkey
[Checked in: Comment 20]

http://hg.mozilla.org/comm-central/rev/bec2e72ce8ed
Attachment #592507 - Attachment description: (Av2) Add support for MailNews Core test suites to SeaMonkey → (Av2) Add support for MailNews Core test suites to SeaMonkey [Checked in: Comment 20]
(Assignee)

Updated

6 years ago
Blocks: 523773
No longer blocks: 721391
(Assignee)

Updated

6 years ago
Depends on: 465968
(Assignee)

Updated

6 years ago
No longer depends on: 722262
(Assignee)

Comment 21

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #17)
> (In reply to Mark Banner (:standard8) from comment #16)
> > You want the SeaMonkey mac part of bug 668869.
> 
> Wrt this bug, I'll Try a workaround...

I'm moving this MacOSX issue to bug 523773.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
status-seamonkey2.7: affected → wontfix
status-seamonkey2.8: affected → wontfix
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Summary: Port mailnews part of bug 506202 to SeaMonkey, to support 'mailbloat' test target → Support 'mailbloat' test target in SeaMonkey
(Assignee)

Updated

6 years ago
Blocks: 753810
You need to log in before you can comment on or make changes to this bug.