Mailnews shutdown causes freeze

VERIFIED DUPLICATE of bug 72588

Status

MailNews Core
Backend
--
critical
VERIFIED DUPLICATE of bug 72588
17 years ago
10 years ago

People

(Reporter: BenB, Assigned: Scott MacGregor)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Browser often freezes when closing Mailnews, roughly every 2. time. It seems
like the first close in a Mozilla-session works, but the second one causes the
freeze. So, the reproduction would look like:

Reproduction:
1. Open browser
2. Open Mailnews (via Tasks menu)
3. Use Mailnews
4. Close Mailnews (3pane)
5. Try to use browser (it should work)
6. Open Mailnews again
7. Use Mailnews
8. Close Mailnews (3pane) again
9. Try to use the browser

Actual result:
You can't. Freeze. Mozilla stops redrawing or doing anything just before the
Mailnews 3panes window closes.

Expected result:
Browser functionality not influenced at all by opening/closing Mailnews hundreds
of times.

Additional Comments:
- I'm using Linux, UW-IMAP, with Trash, Sent and Drafts folder on the server.
Lots of accounts, which the Sent etc. folder of all of them pointing to the same
folders on the IMAP server (I need most of the account only for the identities).
I'll have to test with a fresh profile.
- Tested with Mozilla 0.8.
- It's a real freeze, not just slow (bug 39810) - Mozilla is still in the same
state ofter ~45 mins.
(Reporter)

Comment 1

17 years ago
Created attachment 27883 [details]
Example prefs.js
(Reporter)

Comment 2

17 years ago
OK, I took the time to cut down the prefs.js to the Mailnews accounts only,
since I don't see the bug with a fresh profile. The attached prefs.js only for
reading, not direct using, of course - your environment will differ. Also, I
changed names etc.. Note that some accounts have the same host - I tried to
preserve that.

Comment 3

17 years ago
From prefs.js I see you have "Empty Trash on Exit" set to true. Emptying 
trash on exit increases the shutdown time. 

Try turning off this pref and see if it helps. 
(Reporter)

Comment 4

17 years ago
Navin, it's not just slow, it's a freeze. Sitting there, doing nothing, for much
more than half an hour doesn't really count as slow anymore...

Empty Trash is enabled for the main account only. I might try to disable it anyway.

Note that this bug doesn't exist in Mozilla 0.6, IIRC.
Keywords: regression
(Reporter)

Comment 5

17 years ago
"Clean up INBOX on Exit" seems to be the offender.
(Reporter)

Comment 6

17 years ago
NO, it seems liek you have to enable *both* "Clean up INBOX on Exit" and "Empty
Trash on Exit" to see the bug.

Comment 7

17 years ago
this seems related to 75288. Marking as dup of 75288, which has already been 
fixed for 0.9.1. 

*** This bug has been marked as a duplicate of 75288 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
sorry,  wrong bug number.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 9

17 years ago

*** This bug has been marked as a duplicate of 72588 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
verified duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.