Closed Bug 723390 Opened 8 years ago Closed 8 years ago

Selective rendering proposal

Categories

(Firefox :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 683284

People

(Reporter: u430111, Unassigned)

Details

Thinking a method to reduce memory usage, why not use a selective rendering? In short terms, Gecko should render only the visible page based on the screen height, or better, 2-3 times the screen height (when the page isn't at one side but scrolled, Gecko could render a piece of page before and after the page position).

This should render less memory dependent contents, like images, because unrendered images could stay compressed in cache and decompressed when rendered, but after a scroll they could be unrendered to reduce memory usage, if they're offscreen.

This should be the behavior of WebKit as seen on iPhones and similas, where the GPU acceleration helps (Firefox uses it too, shouldn't be a problem to implement something similar at this).

Maybe this can be implemented as an option toggled by a checkbox, so powerful and high size ram pcs can leave it unchecked, where netbooks/tablets could benefit from this improvement, at the cost of a bit of cpu usage (but i saw an iPhone 3G time ago having no problem to scroll a page, but leaving a bit of a squared pattern)
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: image-suck
More specifically, see bug 542158 and bug 661304.
You need to log in before you can comment on or make changes to this bug.