Last Comment Bug 723563 - Use findScripts to retrieve the list of scripts known to the debugger
: Use findScripts to retrieve the list of scripts known to the debugger
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 14
Assigned To: Panos Astithas [:past]
:
Mentors:
Depends on: 676281 739995
Blocks: minotaur 728244 736000
  Show dependency treegraph
 
Reported: 2012-02-02 09:06 PST by Panos Astithas [:past]
Modified: 2012-03-30 09:36 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Backout patch (10.02 KB, patch)
2012-02-23 01:09 PST, Panos Astithas [:past]
no flags Details | Diff | Review
WIP (14.76 KB, patch)
2012-03-14 10:57 PDT, Panos Astithas [:past]
no flags Details | Diff | Review
Working patch (25.72 KB, patch)
2012-03-15 09:57 PDT, Panos Astithas [:past]
rcampbell: review+
Details | Diff | Review

Description Panos Astithas [:past] 2012-02-02 09:06:40 PST
When bug 676281 lands, the debugger server should use Debugger.prototype.getAllScripts to retrieve the list of all scripts known to the debugger. Currently we rely on onNewScript notifications to generate the list, which doesn't work when the client takes a while to attach to the server, thus missing the initial notifications.
Comment 1 Panos Astithas [:past] 2012-02-02 09:07:56 PST
See bug 697040 for a manifestation of the problem with the current solution.
Comment 2 Panos Astithas [:past] 2012-02-15 03:09:12 PST
We are implementing a workaround in bug 697040, so the first thing to do in this bug is revert that. I'll upload the necessary patch once 697040 lands.
Comment 3 Panos Astithas [:past] 2012-02-23 01:09:00 PST
Created attachment 599914 [details] [diff] [review]
Backout patch

This is the backout patch for the workaround in bug 697040.
Comment 4 Panos Astithas [:past] 2012-03-14 10:57:19 PDT
Created attachment 605843 [details] [diff] [review]
WIP

This is almost there, but I'm having issues with getting the client to send the request. Might be related to bug 731537.
Comment 5 Panos Astithas [:past] 2012-03-15 09:57:26 PDT
Created attachment 606271 [details] [diff] [review]
Working patch

Fixed the tests by adding an extra event. This may come in handy with some oranges as well. Also contains the typo fix from bug 736000.
Comment 6 Rob Campbell [:rc] (:robcee) 2012-03-27 07:16:47 PDT
Comment on attachment 606271 [details] [diff] [review]
Working patch

very nice. I wish I had comments for you.
Comment 7 Rob Campbell [:rc] (:robcee) 2012-03-27 07:17:22 PDT
if it fixes orange, I'll be super happy. :)
Comment 8 Panos Astithas [:past] 2012-03-28 04:16:13 PDT
I sneaked in another one-liner to fix the gcli breakpoint test in the same way as the others:

https://hg.mozilla.org/integration/fx-team/rev/794ff67c7a9a
Comment 9 Panos Astithas [:past] 2012-03-28 08:29:27 PDT
Backed out due to new randomorange:

https://hg.mozilla.org/integration/fx-team/rev/4b87cffba4d5
Comment 10 Panos Astithas [:past] 2012-03-30 02:14:32 PDT
Relanded:

https://hg.mozilla.org/integration/fx-team/rev/401804642db1
Comment 11 Tim Taubert [:ttaubert] 2012-03-30 09:36:00 PDT
https://hg.mozilla.org/mozilla-central/rev/401804642db1

Note You need to log in before you can comment on or make changes to this bug.