Last Comment Bug 724418 - Enable Archives Options support for Gmail Accounts
: Enable Archives Options support for Gmail Accounts
Status: RESOLVED DUPLICATE of bug 532159
:
Product: Thunderbird
Classification: Client Software
Component: Account Manager (show other bugs)
: 10 Branch
: x86_64 Linux
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: tb-gmailWIP
  Show dependency treegraph
 
Reported: 2012-02-05 13:20 PST by Jake
Modified: 2012-02-06 00:29 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Jake 2012-02-05 13:20:57 PST
Hi,

In the past Gmail did not have support for "sub-folders", or "sub-labels" or however you may call them, due to this reason Gmail account options had their archive options disabled, for the simple reason it would not work correctly.

However since that time Google have introduced "sub labels"[1] so now it is entirely possible to use archive options on a Gmail account, however due to a hard-coded limit in Thunderbird it is still not allowed.

Of course, you would not want to go creating for example yearly folders in your "All Mail" folder. However if a user sets to a custom folder, "Archives" for example, he/she should be allowed to set it for yearly mode or other options. As this would no longer cause problems on a Gmail account.

Currently I have many sub folders, and I can confirm Thunderbird works just fine with them, I even have a custom Archives folder, and manually created yearly folders under this folder. It would be very handy if this process could be made automated like it can be for many other accounts.

[1] News article stating Google introduce nested labels: http://gmailblog.blogspot.com/2010/04/new-in-labs-nested-labels-and-message.html
Comment 1 WADA 2012-02-05 21:46:32 PST
(In reply to Jake from comment #0)
> [1] News article stating Google introduce nested labels:
> http://gmailblog.blogspot.com/2010/04/new-in-labs-nested-labels-and-message.
> html

It's merely UI improvement in Gmail Web interface, simply hierarchical display of Gmail Label, isn't it?
Has Gmail actually started to support "Archive to sublabel of All Mail"? 

> As this would no longer cause problems on a Gmail account.

Disabling of "archive options ..." was done for next two reasons.
(1) Gmail had 40 bytes limitation in Gmail Label=folder name via Gmail IMAP.
(2) Different behavior of Archive in Tb from Gmail's Archive behavior surely produces user's confusions.
After user archives a mail to Gmail IMAP folder named Archives/2012/02 or [Gmail]/All Mail/2012/02, if user copies or moves same mail in other Gmail IMAP folder(call XXX, the mail has both Gmail Label of XXX and .../2012/02) to [Gmail]/Trash, all Gmail Labels assigned to the mail is removed, and the mail is deleted from [Gmail]/All Mail too. This will surely causes bug open of "my archived mail was deleted by Tb!" by general users.
If folder for archived mail in Tb is limited to "[Gmail]/All Mail" only, such confusions are reduced very much.

Actual *problem" other than (1) didn't exist. And, because [Gmail]/All Mail/yyyy/mm is 24 bytes, there was practically no actual problem in subfolders under any archive folder in Gmail account too, unless user selects other deeper folder as archive folder and/or user wants to use "keep folder structure" option. 

Do you mean that "40 bytes limitation in Gmail Label length" has been removed by the new "sublabel" support, by your "this would no longer cause problems"?

Even before the Gmail's "sublabel" support, subfolder(nested-label) of a folder(a Gmail Label) can be generated by creating Gmail Label of <Gmail-Label>/<nested-label>, and is shown as <nested-label> subfolder under <Gmail-Label> folder via Gmail IMAP.
After the new "sublabel" support, "[Gmail]/All Mail/A/B/C" via Gmail IMAP is shown like next at Gmail Web interface.
  All Mail  : Gmail's system label ("[Gmail]/All Mail" via Gmail IMAP)
              User can't select system label as "parent" of "nested label".
  [Gmail]/All Mail/A : User defined Gmail Label named [Gmail]/All Mail/A
              ("[Gmail]/All Mail/A" via Gmail IMAP)
     B      : User defined Gmail sublabel B under [Gmail]/All Mail/A
              ("[Gmail]/All Mail/A/B" via Gmail IMAP)
       C    : User defined Gmail sublabel C under B under [Gmail]/All Mail/A
              ("[Gmail]/All Mail/A/B/C" via Gmail IMAP)

Above is far better than previous display like next.
 Gmail Label at Gmail Web interface                  IMAP folder via Gmail IMAP 
  All Mail               : Gmail's system label       [Gmail]/All Mail
  Trash                  : Gmail's system label       [Gmail]/Trash
  [Gmail]                : User defined Gmail Label   [Gmail]
  [Gmail]/All Mail       : User defined Gmail Label   Not shown
  [Gmail]/All Mail/A     : User defined Gmail Label   [Gmail]/All Mail/A
  [Gmail]/All Mail/A/B   : User defined Gmail Label   [Gmail]/All Mail/A/B
  [Gmail]/All Mail/A/B/C : User defined Gmail Label   [Gmail]/All Mail/A/B/C
  [Imap]/Trash           : User defined Gmail Label   Trash
  Note: You can create user defined Gmail Label of [Gmail], [Gmail]/All Mail.
However, nothing is changed in particularity of All Mail, Trash, Spam([Gmail]/All Mail, Trash, Spam via Gmail IMAP) and in Gmail Label, by the new "sublabel" support in UI of Gmail Web interface.
  Any mail, except mails in Trash and Spam, always has system label of All Mail.
  So, any mail, except mails in [Gmail]/Trash and [Gmail]/Spam via Gmail IMAP,
  is always shown as "mail in [Gmail]/All Mail" too.
  If a mail is copied to Gmail/Trash or Spam, all assigned Gmail Labels are
  removed("hidden" is accurate, because Gmail Labels are recovered by move back.)

Even if above particularity still exists, "adding Gmail Label of ARC/Inbox/yyyy/mm by Archive operation in Tb" is convenient for users, unless Gmail still has limitations around Gmail Label length(40 bytes limitation is already removed). And, after the UI improvement by Gmail, deep IMAP subfolders may be less confusing for user than before.
Is disabling/ignoring "archive options ..." better limited to special "[Gmail]/All Mail" only?
  - Archives folder = [Gmail]/All Mail
      user wants same behaviour as Gmail's Archive in Archive of Tb
  - Archives folder = System label of Gmail (folders in XLIST response)
      better to disable/ignore "archive options...", to avoid user's confusion
  - Archives folder = User defined Gmail Label
      user wants to add Gmail Label by Archive operation of Tb
  - Archives folder = folder of other account
      same as current, no limitation is needed
Is "user won't open bug like 'my archived mail was deleted by Tb!' at B.M.O after it" guaranteed?
Comment 2 Jim Porter (:squib) 2012-02-05 23:36:58 PST

*** This bug has been marked as a duplicate of bug 532159 ***

Note You need to log in before you can comment on or make changes to this bug.