With more tabs than fit into tab bar, switching tabs with keyboard shortcuts does not scroll "hidden" tab top of active tab into view (Ctrl+Tab, Ctrl+Page down, Ctrl+Page up, Ctrl+1-8, Ctrl+9)

REOPENED
Unassigned

Status

Thunderbird
Toolbars and Tabs
REOPENED
7 years ago
3 years ago

People

(Reporter: Thomas D. (currently busy elsewhere), Unassigned)

Tracking

(Blocks: 1 bug)

10 Branch
x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [screenshot -> see URL], URL)

Str

1) Select multiple messages with Shift, than will fit into your tab bar (say 20)
2) press Ctrl+1 go back to 1st tab Mail & Newsgroup main tab
3) press Ctrl+tab or Ctrl+page down several times to move forward to the next tabs

Actual

after 1) last tab gets focus and is correctly scrolled into view
after 2) 1st tab gets focus and is shown, but the tab-top in the tab bar is not scrolled into view (wrong and confusing: this bug)
after 3) subsequent tabs get focus and are shown, but the tab-top in the tab bar is not scrolled into view; after several times of ctrl+click, on the tab bar, you'll see the focus coming from the left and going to the right, but only on the visible tab-tops

Expected

after 2) 1st tab gets focus and its *tab-top is scrolled into view*
after 3) subseqent tabs get focus and *tab-tops are scrolled into view*

I tested this in safe-mode, but I'd appreciate confirmation from somebody that they also see this bug.
(Reporter)

Comment 1

7 years ago
(In reply to Thomas D. from comment #0)
> Str
> 
> 1) Select multiple messages with Shift, than will fit into your tab bar (say
> 20)

you need *more* tabs than will fit into your tab bar (exceeding window width).
(Reporter)

Updated

7 years ago
Summary: With more tabs than fit into tab bar, switching tabs with keyboard shortcuts does not scroll "hidden" tabs into view (Ctrl+Tab, Ctrl+Page down, Ctrl+Page up, Ctrl+1-8, Ctrl+9) → With more tabs than fit into tab bar, switching tabs with keyboard shortcuts does not scroll "hidden" tab tops into view (Ctrl+Tab, Ctrl+Page down, Ctrl+Page up, Ctrl+1-8, Ctrl+9)
(Reporter)

Comment 2

7 years ago
(In reply to Thomas D. from comment #0)
> after 3) subsequent tabs get focus and are shown, but the tab-top in the tab
> bar is not scrolled into view; after several times of ctrl+click, on the tab
> bar, you'll see the focus coming from the left and going to the right, but
> only on the visible tab-tops

Typo: Obviously, as in STR 3, it's not Ctrl+click, but *Ctrl+Tab*

So focus can be seen going from left to right of tabbar, and then it disappears at the right: messages are still shown as expected, but the currently active message is disconnected from its tab top, which is hidden somewhere and not scrolled into view with the message reader.

> I tested this in safe-mode

Interestingly, in normal mode, with some extensions including lightning, the *first* Ctrl+1 will behave correctly, otherwise same symptoms for switching between first and last tab (ctrl+1 and ctrl+9), or moving into any "hidden" tab with ctrl+[shift]+tab
(Reporter)

Updated

7 years ago
Summary: With more tabs than fit into tab bar, switching tabs with keyboard shortcuts does not scroll "hidden" tab tops into view (Ctrl+Tab, Ctrl+Page down, Ctrl+Page up, Ctrl+1-8, Ctrl+9) → With more tabs than fit into tab bar, switching tabs with keyboard shortcuts does not scroll "hidden" tab top of active tab into view (Ctrl+Tab, Ctrl+Page down, Ctrl+Page up, Ctrl+1-8, Ctrl+9)
(Reporter)

Updated

7 years ago
Duplicate of this bug: 577655
(Reporter)

Comment 4

7 years ago
I forward-duplicated bug 577655 to this one because I think the description here is simpler and more concise. (But I won't die if you think it should be the other way round).

Bug 577655 has some screenshots illustrating the problem, best seen here:
https://bugzilla.mozilla.org/attachment.cgi?id=459782
Whiteboard: [screenshot -> see URL]

Comment 5

6 years ago
The same is for TB ver 13.0.1

Comment 6

5 years ago
works for me?

Comment 7

5 years ago
Seems so.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

5 years ago
(In reply to Magnus Melin from comment #7)
> Seems so.

No, this doesn't work yet on Daily 23.0a1 (2013-05-04).
Sorry, my bad. STR are incomplete. 

(In reply to Thomas D. from comment #0)
> STR
> 
> 1) Select multiple messages with Shift, than will fit into your tab bar (say
> 20)

After selecting lots of messages from your message list, do Message > Open (Ctrl+O) to open them in lots of tabs (more than fit into your tab bar).

> 2) press Ctrl+1 go back to 1st tab Mail & Newsgroup main tab

Actual result: 1st tab is scrolled back into view (you'll correctly see 3pane), BUT if you check out the tab bar, you'll find that the *tab top* of that 1st tab is missing, hidden on the left, while you still see the tab tops of last messages tabs. Let me know if you see that or if you need a screenshot.

> 3) press Ctrl+tab or Ctrl+page down several times to move forward to the
> next tabs
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Adding mconley, tab-master extrordinaire! ;)
You need to log in before you can comment on or make changes to this bug.