Telemetry.cpp:113:18: error: use of undeclared identifier 'EnumerateEntries' using clang

VERIFIED FIXED in mozilla13

Status

()

Toolkit
Telemetry
--
blocker
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

({regression})

Trunk
mozilla13
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 597009 [details] [diff] [review]
The fix

Using clang to build Telementry.cpp after bug 725699 landed I get:

/Users/moztest/comm/main/src/mozilla/toolkit/components/telemetry/Telemetry.cpp:113:18: error: use of undeclared identifier
      'EnumerateEntries'
  PRUint32 num = EnumerateEntries(ReflectEntryStub, static_cast<void*>(&args));
                 ^
                 this->

Looks like it just wants a 'this->' added.
Attachment #597009 - Flags: review?(taras.mozilla)
Severity: major → blocker
(Assignee)

Comment 1

6 years ago
Note: when this gets r+ I'm unlikely to be around for a few hours, so anyone with checkin privs, please feel free to land on my behalf.
Comment on attachment 597009 [details] [diff] [review]
The fix

Review of attachment 597009 [details] [diff] [review]:
-----------------------------------------------------------------

Hooray for compilers not implementing lookup correctly.  (GCC 4.7 correctly complains as well.)
Attachment #597009 - Flags: review?(taras.mozilla) → review+
Comment on attachment 597009 [details] [diff] [review]
The fix

https://hg.mozilla.org/integration/mozilla-inbound/rev/06725c1fd56f
Attachment #597009 - Flags: checkin+
OS: Mac OS X → All
Target Milestone: --- → mozilla13

Updated

6 years ago
Duplicate of this bug: 727208

Comment 5

6 years ago
Would be great if you could push build fixes like this straight to mozilla-central in the future. That gets developers up and running faster.
Blocks: 574346

Comment 6

6 years ago
Should we file a bug at http://llvm.org/bugs/?
(In reply to Gregory Szorc [:gps] from comment #6)
> Should we file a bug at http://llvm.org/bugs/?

No, gcc is the one incorrectly handling dependent base classes.
https://hg.mozilla.org/mozilla-central/rev/06725c1fd56f
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
This is fixed now. Thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.