Last Comment Bug 727140 - MAPLE: crash [@ TouchBadMemory]
: MAPLE: crash [@ TouchBadMemory]
Status: VERIFIED FIXED
MAPLE mwc-demo
: crash
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- critical (vote)
: ---
Assigned To: Doug Turner (:dougt)
:
Mentors:
: 726838 728452 (view as bug list)
Depends on:
Blocks: 728249
  Show dependency treegraph
 
Reported: 2012-02-14 10:23 PST by Cristian Nicolae (:xti)
Modified: 2012-03-24 09:19 PDT (History)
18 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch v.1 (1.04 KB, patch)
2012-02-17 23:09 PST, Doug Turner (:dougt)
pwalton: review+
Details | Diff | Review

Description Cristian Nicolae (:xti) 2012-02-14 10:23:14 PST
This bug was filed from the Socorro interface and is 
report bp-c81cbccb-2b34-4664-905d-b16dd2120214 .
============================================================= 
Frame 	Module 	Signature [Expand] 	Source
0 	libmozalloc.so 	TouchBadMemory 	memory/mozalloc/mozalloc_abort.cpp:68
1 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:89
2 	dalvik-heap (deleted) 	dalvik-heap @0x7c711f 	
3 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x3164f40 	
4 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x2e4676c 	
5 	org.mozilla.fennec-1.apk 	org.mozilla.fennec-1.apk@0x75621e 	
6 	dalvik-heap (deleted) 	dalvik-heap @0xbbfb971 	
7 	app_process 	app_process@0x240e
Comment 1 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-02-14 10:32:04 PST
GL Context? GL Context+
GL Layers? GL Layers+

xpcom_runtime_abort(###!!! ABORT: creating ThebesLayer 'back buffer' failed! width=2147483647
 height=2147483647
 type=1000: file /builds/slave/map-andrd-ntly/build/gfx/layers/basic/BasicLayers.cpp
 line 2417)

 "BuildID": "20120213040241"
 "Android_Model": "Galaxy Nexus"
 "ProductName": "Fennec"
 "URL": "about:blank"
 "ReleaseChannel": "nightly-maple"
Comment 2 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-02-14 13:46:59 PST
Nicolae, do you have reproducible steps?
Comment 3 Tony Chung [:tchung] 2012-02-14 22:01:53 PST
I also reproduced this.

HTC Desire HD, 02-14-2012 maple build
URL: http://paulrouget.com/mwc-demos/

Repro:
1) goto URL, and click the CSS3 hologram demo
2) rotate phone to landscape view
3) just tap around various points, swipe around, on the screen with your finger.   Eventually it crashes.

https://crash-stats.mozilla.com/report/index/bp-0ed01db1-ad9f-4379-ba89-b0a642120215
Comment 4 Jeff Muizelaar [:jrmuizel] 2012-02-16 10:38:14 PST
(In reply to Tony Chung [:tchung] from comment #3)
> I also reproduced this.
> 
> HTC Desire HD, 02-14-2012 maple build
> URL: http://paulrouget.com/mwc-demos/
> 
> Repro:
> 1) goto URL, and click the CSS3 hologram demo
> 2) rotate phone to landscape view
> 3) just tap around various points, swipe around, on the screen with your
> finger.   Eventually it crashes.
> 
> https://crash-stats.mozilla.com/report/index/bp-0ed01db1-ad9f-4379-ba89-
> b0a642120215

Tony, can you reproduce this on a Nexus S?
Comment 5 Tony Chung [:tchung] 2012-02-16 11:14:35 PST
(In reply to Jeff Muizelaar [:jrmuizel] from comment #4)
> (In reply to Tony Chung [:tchung] from comment #3)
> > I also reproduced this.
> > 
> > HTC Desire HD, 02-14-2012 maple build
> > URL: http://paulrouget.com/mwc-demos/
> > 
> > Repro:
> > 1) goto URL, and click the CSS3 hologram demo
> > 2) rotate phone to landscape view
> > 3) just tap around various points, swipe around, on the screen with your
> > finger.   Eventually it crashes.
> > 
> > https://crash-stats.mozilla.com/report/index/bp-0ed01db1-ad9f-4379-ba89-
> > b0a642120215
> 
> Tony, can you reproduce this on a Nexus S?

i dont have a nexus S on me at the moment.  but i'll see if i can dig one up.

But I do have a SGS2, Galaxy Nexus and access to some LG and sony phones.  Did you want testing on those?
Comment 6 Doug Turner (:dougt) 2012-02-16 11:32:24 PST
width=2147483647, height=2147483647 sounds very wrong.
Comment 7 Tony Chung [:tchung] 2012-02-16 12:01:13 PST
(In reply to Tony Chung [:tchung] from comment #3)
> I also reproduced this.
> 
> HTC Desire HD, 02-14-2012 maple build
> URL: http://paulrouget.com/mwc-demos/
> 
> Repro:
> 1) goto URL, and click the CSS3 hologram demo
> 2) rotate phone to landscape view
> 3) just tap around various points, swipe around, on the screen with your
> finger.   Eventually it crashes.
> 
> https://crash-stats.mozilla.com/report/index/bp-0ed01db1-ad9f-4379-ba89-
> b0a642120215

For reference, the hologram demo URL is: http://paulrouget.com/mwc-demos/hologram/.
Comment 8 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-02-16 12:12:09 PST
Could not reproduce in the latest maple build 02/16/2012 on Nexus S:
http://paulrouget.com/mwc-demos/hologram/
Comment 9 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-02-17 16:05:48 PST
https://crash-stats.mozilla.com/report/index/34d96724-49c6-4282-95c4-53f252120217
https://crash-stats.mozilla.com/report/index/5b9fb967-da56-473e-b6e1-a1dcc2120218
was able to reproduce this on Maple 2/17/2012 on Samsung Galaxy S II

1. opened a tab to about:home
2. opened a tab to Paulroget.com/mwc-demo
3. opened a tab to Hahlo.com
4. opened a tab to mozilla.org
5. kept switching tabs

Expected: no crash
Actual: crash due to touchbadmemory
Comment 10 Erin Lancaster [:elan] 2012-02-17 18:59:41 PST
This is the hologram field; we don't need to block mwc demos on this.
Comment 11 Doug Turner (:dougt) 2012-02-17 23:09:04 PST
Created attachment 598500 [details] [diff] [review]
patch v.1
Comment 12 Patrick Walton (:pcwalton) 2012-02-17 23:14:19 PST
Comment on attachment 598500 [details] [diff] [review]
patch v.1

Review of attachment 598500 [details] [diff] [review]:
-----------------------------------------------------------------

Ok, but we should make sure that the viewport actually does get adjusted for background tabs when switching to them after a resize.
Comment 13 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-02-17 23:19:21 PST
Test case for patch : 
1. opened a tab to Paulroget.com/mwc-demo
2. opened a tab to mozilla.org
3. rotate phone
4. switch to tab 1 after current tab is loaded.
Comment 14 Doug Turner (:dougt) 2012-02-17 23:23:44 PST
so, if I rotate the screen then switch to a tab that was in the background, the view is what I would expect.  Not sure what else there is to do.

http://hg.mozilla.org/projects/maple/rev/70c7baef22df
Comment 15 Doug Turner (:dougt) 2012-02-20 09:10:47 PST
*** Bug 728452 has been marked as a duplicate of this bug. ***
Comment 16 Ali Juma [:ajuma] 2012-02-20 14:43:59 PST
*** Bug 726838 has been marked as a duplicate of this bug. ***
Comment 17 :Ehsan Akhgari (out sick) 2012-02-20 15:24:22 PST
|Tabs.getInstance().getSelectedTab()| is Java code, not Javascript!
Comment 18 :Ehsan Akhgari (out sick) 2012-02-20 15:38:15 PST
https://hg.mozilla.org/projects/maple/rev/eff263ee7c82
Comment 19 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-24 09:19:34 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/e8b308c39205

Note You need to log in before you can comment on or make changes to this bug.