messages in threaded view get out of order

VERIFIED FIXED

Status

VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: kcha-ns-yka, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
win32 build 2001031904 win98SE

Messages in long, deep threads get completely out of order. There doesn't seem
to be a combination of Sort By and View|Threaded that puts them in logical
thread order.

1. Go to secnews.netscape.com/netscape.netscape6.windows
2. View|Threaded
3. Go to thread: "Why do we put up with this ****?"
   Started 03/12/2001 by "T / S"
4. Expand the thread
5. Scroll down through the thread pane. At first messages appear to be in
logical order, but get all mixed up after a point.

Changing the Sort By order does not have any positive effect, nor does removing
all Sorts. This same thread viewed in build 0316 looks just fine. Will attach
screen shot.

Updated

18 years ago
QA Contact: esther → fenella
(Reporter)

Comment 2

18 years ago
Since I have not been able to upload a screen shot (keeps timing out), here is
my lame attempt at ASCII art to show what this thread ends up looking like:

 T |Subject                                 |Sndr|o|Date      |
---------------------------------------------------------------
      | |             | |- Re:[OFFTOPIC]...  Jay. ' 2001-03-14
      | |             |   |- RE:[OFFTOPIC].  Wa.. ' 2001-03-14
  | |             |- Re:Why do we put up...  Jay. ' 2001-03-14
          | |             | |- Re:[OFFTOPIC] Ch.. ' 2001-03-14
          | |             |   |- Re:[OFFTOP. Wa.. ' 2001-03-14
          | |             |   |- Re:[OFFTOP. Ch.. ' 2001-03-15
  | |             |- Re:[OFFTOPIC]Re:Why do. Mar. ' 2001-03-15
                | |             |- Re:[OFF.. Mic. ' 2001-03-15
  | |               |- Re:[OFFTOPIC]Re:Why.. Ch.. ' 2001-03-15


And it gets worse. The thread is impossible to follow. There aren't any Sort By
options that get into logical order, at least none that I've stumbled across.
         

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 72493 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
mark it verified/dup.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

18 years ago
I don't agree with the duplicate marking. Bug 72493 seems to be about sort
feature requests. All I want is for thread integrity to be maintained. Look at
the recent thread "Mozilla's Icons" in netscape.public.mozilla.general, started
2001-03-22 by NeTDeMoN for a smaller example of what I'm talking about. I still
can't upload graphics (gif or png) to provide a screen shot, so here's the
description:

post from Garth W on 2001-03-24 17:25 is listed under a post from jesus X on
2001-03-24 16:16 when it is actually the last reply to a post from Mark A on
2001-03-24 09:58.
post from Aaron A on 2001-03-26 19:37 is listed under a post from Asa D on
2001-03-26 18:11 when it is actually the last reply to a post from Giovanni on
2001-03-25 03:55.
post from michael on 2001-03-27 10:12 is listed under a post from jesus X on
2001-03-27 09:24 when it is actually the last (only) reply to a post from Aaron
A on 2001-03-26 19:37.

No combination of Sort By with Threaded view gets the thread back in its logical
thread order. Looks like the entire thread is in straight date order without
regard to what reply goes with what post. In a very long thread, like the one in
the netscape6.windows ng noted above, this makes it impossible to follow the
thread. These threads look just hunky-dory in a build prior to the performance
improvements. I'm currently on build 2001032604.

Comment 6

18 years ago
reporter: this is unfair, this bug has _ZERO_ indications that a pciture is 
available. reopening now that we have a picture.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

18 years ago
reassigning to hyatt because this looks like an <outliner> bug.

fwiw, the jagged lines (ie the lines that form angles that aren't exactly 90 
degrees) is a fixed bug (or at least is tracked elsewhere).

this bug is still probably a dupe, but who knows.
Assignee: sspitzer → hyatt
Keywords: qawanted
Whiteboard: DUPEME

Comment 8

18 years ago
I'd rather hear that diagnosis from sspitzer, since mailnews implements the 
threading logic.
Assignee: hyatt → sspitzer
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 9

18 years ago
If this is really a dupe bug report, can somebody *please* point me to a bug
that I can track? I can't find one, and I want to cast my votes for fixing this.
It really is pretty nasty with big long threads. :(

Comment 10

18 years ago
It looks to me like articles in the thread are still being sorted by date which 
is causing the problem.

For example if msg A starts a thread and B, C, D, E & F arrive in that order, 
they will be sorted by date:

A
  B
  C
    D
  E
      F

Even though D was replying to B, and F was replying to D i.e.

A
  B
    D
      F
  C
  E

This appears to be why indentation looks so screwed up. Sorting should happen 
relative to an article's parent first and then by date.
(Reporter)

Comment 11

18 years ago
Fixed? I checked out several ngs, and thread order seems to be maintained nicely
in win32 build 2001050904. Even that monster with 188 messages. Very cool! :-)
marking fixed.

general outliner / nsMsgDBView work and specific fixes by bienvenu
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 13

18 years ago
Fixed as described by Adam Lock
A
  B
    D
      F
  C
  E

using these builds.
Linux (2001-05-11-05 trunk)
Win32 (2001-05-11-06 trunk)
Mac (2001-05-11-08 trunk)

Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: qawanted

Comment 14

15 years ago
clearing status whiteboard.
Whiteboard: DUPEME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.