Last Comment Bug 728309 - Re-enable mail toolbar in message tab and Gloda search result list
: Re-enable mail toolbar in message tab and Gloda search result list
Status: VERIFIED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: Trunk
: x86 All
: -- normal with 1 vote (vote)
: Thunderbird 13.0
Assigned To: Mike Conley (:mconley) - (needinfo me!)
:
Mentors:
Depends on: 729197
Blocks: 725507 tb-tabsontop
  Show dependency treegraph
 
Reported: 2012-02-17 10:42 PST by Mike Conley (:mconley) - (needinfo me!)
Modified: 2012-04-20 03:49 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
fixed


Attachments
Patch v1 (1.02 KB, patch)
2012-02-17 10:47 PST, Mike Conley (:mconley) - (needinfo me!)
mozilla: review+
bwinton: ui‑review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Review
Linux - mail toolbar in message tab (68.81 KB, image/png)
2012-02-17 10:49 PST, Mike Conley (:mconley) - (needinfo me!)
no flags Details
Linux - mail toolbar in search result tab (135.07 KB, image/png)
2012-02-17 10:49 PST, Mike Conley (:mconley) - (needinfo me!)
no flags Details
Windows 7 - toolbar in message tab (113.06 KB, image/png)
2012-02-17 10:56 PST, Mike Conley (:mconley) - (needinfo me!)
no flags Details
Windows 7 - toolbar in search tab (118.32 KB, image/png)
2012-02-17 10:56 PST, Mike Conley (:mconley) - (needinfo me!)
no flags Details
Windows XP - toolbar in message tab (48.68 KB, image/png)
2012-02-17 11:04 PST, Mike Conley (:mconley) - (needinfo me!)
no flags Details
Windows XP - toolbar in search result tab (47.52 KB, image/png)
2012-02-17 11:04 PST, Mike Conley (:mconley) - (needinfo me!)
no flags Details
OSX- toolbar in search result tab (133.45 KB, image/png)
2012-02-17 11:37 PST, Mike Conley (:mconley) - (needinfo me!)
no flags Details
OSX- toolbar in message tab (154.18 KB, image/png)
2012-02-17 11:38 PST, Mike Conley (:mconley) - (needinfo me!)
no flags Details

Description Mike Conley (:mconley) - (needinfo me!) 2012-02-17 10:42:16 PST
We'd like to re-enable the below-tabs mail toolbar for the message pane and for the Gloda search result list.
Comment 1 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 10:47:38 PST
Created attachment 598292 [details] [diff] [review]
Patch v1

This seems pretty simple - but did I forget any cases?

Screenshots of how this looks with our current styling forthcoming...
Comment 2 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 10:49:10 PST
Created attachment 598293 [details]
Linux - mail toolbar in message tab
Comment 3 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 10:49:36 PST
Created attachment 598294 [details]
Linux - mail toolbar in search result tab
Comment 4 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 10:56:10 PST
Created attachment 598295 [details]
Windows 7 - toolbar in message tab
Comment 5 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 10:56:30 PST
Created attachment 598296 [details]
Windows 7 - toolbar in search tab
Comment 6 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 11:04:22 PST
Created attachment 598300 [details]
Windows XP - toolbar in message tab
Comment 7 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 11:04:47 PST
Created attachment 598302 [details]
Windows XP - toolbar in search result tab
Comment 8 rsx11m 2012-02-17 11:30:11 PST
Hi Mike, looks good but how does this relate to bug 725507?
This looks like my proposal (3) over there...

Is this a short-term/interim solution for 11.0 only?
Comment 9 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 11:31:41 PST
*** Bug 725507 has been marked as a duplicate of this bug. ***
Comment 10 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 11:33:51 PST
Hey rsx11m,

Thanks for pointing that one out! Resolving as duplicate.  I'll do development on this bug #.

> Is this a short-term/interim solution for 11.0 only?

Unsure - bwinton might know?

-Mike
Comment 11 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 11:37:53 PST
Created attachment 598310 [details]
OSX- toolbar in search result tab
Comment 12 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 11:38:14 PST
Created attachment 598311 [details]
OSX- toolbar in message tab
Comment 13 Jim Porter (:squib) 2012-02-17 11:40:41 PST
(In reply to Mike Conley (:mconley) from comment #10)
> > Is this a short-term/interim solution for 11.0 only?
> 
> Unsure - bwinton might know?

I sure hope so.
Comment 14 rsx11m 2012-02-17 11:42:30 PST
(In reply to Mike Conley (:mconley) from comment #10)
> Resolving as duplicate.  I'll do development on this bug #.

Usually it's a good idea to look for existing bugs before filing a new one, and I thought that this specific one was high-profile enough not to be missed... ;-)

> > Is this a short-term/interim solution for 11.0 only?
> Unsure - bwinton might know?

If not, we can keep bug 725507 to further investigate into how to improve the message-tab and search-tabs toolbars from here.
Comment 15 Mike Conley (:mconley) - (needinfo me!) 2012-02-17 11:45:01 PST
(In reply to rsx11m from comment #14)
> Usually it's a good idea to look for existing bugs before filing a new one,
> and I thought that this specific one was high-profile enough not to be
> missed... ;-)
> 

Whoops - I had looked around, but I guess I didn't notice 725507.  If you'd like to re-open and use that for investigating UI improvements in those areas, be my guest! :)
Comment 16 rsx11m 2012-02-17 11:48:21 PST
So done and marked as a dependent bug to this one.
Comment 17 David :Bienvenu 2012-02-17 13:12:20 PST
Comment on attachment 598292 [details] [diff] [review]
Patch v1

toolbars are present and functional, r=me
Comment 18 Thomas D. (currently busy elsewhere; needinfo?me) 2012-02-17 16:28:59 PST
Things to consider:

1) Bug 725507 Comment 6 by rsx11m:
> FWIW, the stand-alone message viewer (Open Message in New Window) has a full
> main-like toolbar as well, which can be customized separately from the
> 3-pane window toolbar. So, this toolbar could be "recycled" for the message
> tab as a variant of option (3).

So currently, there are at least two independently customizable "mail" toolbars, one in the main 3pane, and another one for message windows. Now we have tabs on top, so in a message tab, the "mail" toolbar there is no longer an application-wide toolbar, but a message-specific toolbar (ux-natural-mapping). So I'm pretty sure it should *not* be the same as the main mail toolbar. At least, we should use the same separately customizable toolbar that we have in the stand-alone msg win, so that we have a msg-related toolbar (vs. a general purpose toolbar for the main 3pane). Which of the two toolbars did you use in your patch?

2) Consider giving the "open as list"-style global search results tab it's own (3rd) toolbar again. User might want to see things there that are not needed for a single message. And we could share that 3rd multiple-messages-related toolbar with "open in conversation" which is pretty much the same as "open as list".

3) Ensure that the "Quick filter" button is disabled or even hidden where it cannot be applied, e.g. in msg tab. Again, a good argument for giving the single msg tab it's own toolbar (shared with single msg windows), and having a separate toolbar for search tab & open in conversation, both with multiple messages where filtering makes sense.

With tabs on top, it doesn't make sense to put the very same main mail toolbar everywhere. Tabs on top is a paradigm shift and whatever toolbar is inside the tab should relate to that type of tab.

Another question: Having a set of independently configurable toolbars is useful, but having separate sets of selected buttons which I can only put on one toolbar but not on another seems very restrictive. Is it technically possible to arrange the customization dialogue in such a way that the user can put *any* button on *any* toolbar? That's how applications like Word handle toolbar customization, and it's a lot more flexible than we are (and would solve a lot of problems where certain buttons are missing in the palettes for that very toolbar).
Comment 19 rsx11m 2012-02-18 07:37:49 PST
Thomas: AFAICT, this patch reintroduces the main toolbar ("mail-bar3") for the message and search tabs, thus the same toolbar as before. Apparently that box is just hidden in the current implementation, and the patch simply removes hiding it. This should be the simplest version for a mitigating fix with target 11.0, and not much more may be possible considering that it's in the beta phase already and any changes are restricted. Also, there is still bug 725507 for more comprehensive modifications on current trunk following damage control for 11.0 here.
Comment 20 Jim Porter (:squib) 2012-02-18 12:41:50 PST
(In reply to Thomas D. from comment #18)
> Things to consider:
> 
> 1) Bug 725507 Comment 6 by rsx11m:
> > FWIW, the stand-alone message viewer (Open Message in New Window) has a full
> > main-like toolbar as well, which can be customized separately from the
> > 3-pane window toolbar. So, this toolbar could be "recycled" for the message
> > tab as a variant of option (3).
> 
> So currently, there are at least two independently customizable "mail"
> toolbars, one in the main 3pane, and another one for message windows.

Not really. It's the same toolbar, but in a different window, so it's persisted in a different spot. If you put that toolbar in the main window for a message tab, it would automatically become the same toolbar as in the 3pane.
Comment 21 Blake Winton (:bwinton) (:☕️) 2012-02-21 07:58:15 PST
Comment on attachment 598292 [details] [diff] [review]
Patch v1

Seems like a reasonable thing to do until we get a different toolbar for those screens…  ;)

ui-r=me!
Comment 22 Blake Winton (:bwinton) (:☕️) 2012-02-21 08:09:29 PST
Comment on attachment 598292 [details] [diff] [review]
Patch v1

D'oh!  I actually take this ui-r+ back, because I just noticed that the QFB button doesn't work in the View-As-List mode, and I really think it should…
Comment 23 Mike Conley (:mconley) - (needinfo me!) 2012-02-21 08:12:58 PST
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #22)
> Comment on attachment 598292 [details] [diff] [review]
> Patch v1
> 
> D'oh!  I actually take this ui-r+ back, because I just noticed that the QFB
> button doesn't work in the View-As-List mode, and I really think it should…

Hm - this bug appears to exist regardless of my change.  I think it's a separate issue.  Would you mind greatly if I opened up a separate bug for it?

-Mike
Comment 24 Blake Winton (:bwinton) (:☕️) 2012-02-21 08:20:39 PST
Comment on attachment 598292 [details] [diff] [review]
Patch v1

(In reply to Mike Conley (:mconley) from comment #23)
> (In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #22)
> > Comment on attachment 598292 [details] [diff] [review]
> > Patch v1
> > 
> > D'oh!  I actually take this ui-r+ back, because I just noticed that the QFB
> > button doesn't work in the View-As-List mode, and I really think it should…
> 
> Hm - this bug appears to exist regardless of my change.  I think it's a
> separate issue.  Would you mind greatly if I opened up a separate bug for it?

Okay, but I really do think we should fix it before we land.

Thanks,
Blake.
Comment 25 Mike Conley (:mconley) - (needinfo me!) 2012-02-21 11:29:19 PST
Comment on attachment 598292 [details] [diff] [review]
Patch v1

We want this for TB 11.
Comment 26 Mike Conley (:mconley) - (needinfo me!) 2012-02-21 12:12:22 PST
Committed to comm-central as http://hg.mozilla.org/comm-central/rev/5c3f99ded9d7
Comment 27 Mike Conley (:mconley) - (needinfo me!) 2012-02-21 14:40:53 PST
Committed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/a97e6cafdc03
Comment 28 Mike Conley (:mconley) - (needinfo me!) 2012-02-21 18:57:53 PST
Committed to comm-beta as http://hg.mozilla.org/releases/comm-beta/rev/5b08357336fb
Comment 29 rsx11m 2012-02-22 08:15:27 PST
Verified fixed in 11.0 beta 3 Linux x86_64 build1, thanks Mike!
Comment 30 Mike Conley (:mconley) - (needinfo me!) 2012-02-22 08:33:59 PST
rsx11m:

No problem - thanks for verifying!

-Mike

Note You need to log in before you can comment on or make changes to this bug.