"InBox" does not show all emails in separate accounts

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
7 years ago
5 years ago

People

(Reporter: rcblumen, Unassigned)

Tracking

10 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

546.98 KB, application/pdf
Details
(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

Sit with the cursor on the overall "Inbox" .


Actual results:

It shows some, but not all, emails sitting in the in boxes of all accounts.


Expected results:

In the past (with Thunderbird on my XP machine), if I highlighted the overall "inbox" it would show all the messages that were sitting in all the account in-boxes (i have 7 email accounts).  Now, under Windows 7, I have missed timely incoming messages, because messages came in and I was not sitting on that specific inbox, only the general overall in-box.

Comment 1

7 years ago
(In reply to Dick from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101
> Firefox/10.0.2
> Build ID: 20120215223356
> 
> Steps to reproduce:
> 
> Sit with the cursor on the overall "Inbox" .
By overall "Inbox" you mean unified/global inbox?
(Reporter)

Comment 2

7 years ago
Yes, the unified/global inbox that sits over all my inboxes in the top left panel.

Comment 3

7 years ago
(In reply to Dick from comment #2)
> Yes, the unified/global inbox that sits over all my inboxes in the top left
> panel.

Can you take & attach a screenshot of the problem? You can remove any sensitive info from the screenshot.
(Reporter)

Comment 4

7 years ago
Created attachment 598658 [details]
2 pix showing unified in-box and missing messages

Comment 5

7 years ago
Can you please attach a PNG image, not a DOCX?
(Reporter)

Comment 6

7 years ago
Created attachment 599260 [details]
pdf of 2 screen shots and comments
Attachment #598658 - Attachment is obsolete: true

Comment 7

7 years ago
(In reply to Dick from comment #6)
There is a work-around for this in bug 566342.
Dick did comment #7 help ?
(Reporter)

Comment 9

7 years ago
No it didn't.  I have no idea what work around is being suggested.  I don't have IMAP email accounts, only POP3.  The only true "work around" I know is to ignore my global inbox and move the cursor down each inbox and read all the email account in-boxes separately.  That really is not a decent workaround; may as well not even have a global inbox.  This is a relatively new problem. In the past, I always updated my Thunderbird software, so it was only when I moved to Windows 7 on a new computer did this problem occur. Coincidence?
And do you have extensions installed ? do you have the same issue if you disable your extensions ?
(Reporter)

Comment 11

7 years ago
I am not really active in adding any add-ons or extensions.  I did look under tools>addons and only saw "Do Not Track Plus 2.0.9" was there. That is the only extension I see.  If you want, I can disable it and then look to see if the issue still exists.
(Reporter)

Comment 12

6 years ago
Just an update.  I've got version 12.0.1 now and this bug still exists.  I had clicked on the global inbox and noticed a whole bunch of messages I was expecting to be there but were not.  Then I clicked on the account inbox in which they were supposed to come in to, and the messages WERE there.  Then, I clicked back onto the global in-box and the messages were there.  PLEASE FIX THIS as I cannot depend on my global inbox to be accurate.  Thanks.
(In reply to Dick from comment #11)
> I am not really active in adding any add-ons or extensions.  I did look
> under tools>addons and only saw "Do Not Track Plus 2.0.9" was there. That is
> the only extension I see.  If you want, I can disable it and then look to
> see if the issue still exists.

Yes try that.

Any error in Tools -> Error console ?

Comment 14

5 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #13)
> (In reply to Dick from comment #11)
> > I am not really active in adding any add-ons or extensions.  I did look
> > under tools>addons and only saw "Do Not Track Plus 2.0.9" was there. That is
> > the only extension I see.  If you want, I can disable it and then look to
> > see if the issue still exists.
> 
> Yes try that.
> 
> Any error in Tools -> Error console ?
Flags: needinfo?(rcblumen)
Whiteboard: [closeme 2013-06-11]
(Reporter)

Comment 15

5 years ago
I'm a little confused here what you are asking me for.  It has been so long (almost a year) that this has been addressed, I basically don't trust the top "inbox".  I looked in my present extensions and all are disabled except a new one (Lightning 1.9.1). This was just added recently.  The Inbox (when highlighted) still hasn't changed in that sometimes not all emails show up in the preview pane to the right. This, along with the darn view changing of the preview pane when I am looking at it due to some internal indexing or something, makes this product more and more non-productive to use.  Dick
Flags: needinfo?(rcblumen)

Comment 16

5 years ago
If you really mean the message indexing for global search you can disable that in the Preferences (Options). Then, you can still use the search that is per folder.
(In reply to Dick from comment #6)
> pdf of 2 screen shots and comments

Show "Account" column(account name), "Location" column if needed(Mbox name. always "Inbox" in your case), "Order Received" column(messageKey value. if local mail folder, messageKey=Offset in file. if IMAP, messageKey=UID of mail).
If account name is hard to distinguish, change account name(label), at Account Settings(for example, add sequence number at left of account name(label).

> The Inbox (when highlighted) still hasn't changed in that sometimes not all emails show up in the preview pane to the right.

Which?
a) New mail is not listed at Thread Pane of Unified Inbox folder.
b) New mail is listed at Thread Pane of Unified Inbox folder,
   but mail content of it is not automatically shown in Message Pane.
(Note: Because "area where message content is displayed" is frequently called "preview pane" by MS mailer users, "Message Pane in Tb" is called "preview pane" by many users even though mailer==Thunderbird.)

If a), which mail(mesasgeKey) of which account's Mbox(folder listed under Unified Inbox folder, with account name) is not listed at Thread Pane of Unified Inbox folder? 

If b), is the non-auto-matically-displayed mail selected(highlighted) at Thread Pane? If selected(highlighted), how many mails are selected at Thread Pane? Multiple mails are selected? Only one mail is selected?


To bug opener:
Phenomenon you see is following?
- When new mails arrive at each account's Inbox,
  new mail count is updated at Unified Inbox folder in Folder Pane,
  but new mail is not listed in Thread Pane of the Unified Inbox folder.
- When you click each account's Inbox, mails are listed and viewable.
- When you go back to Unified Inbox folder(click again),
  new mails are listed at Thread Pane of the Unified Inbox folder.
(Reporter)

Comment 18

5 years ago
Koneechi-Wah Wada-san.  Your English is much better than my Japanese, but I am having some problems understanding exactly what you are asking.  I will comment on the above sections of last last email above.  In "Show "Account"..." section above, I have no idea what you are requesting.  Are you asking me to modify the snapshot pictures I posted and ad columns?

In the middle section, is the definition of "Thread Pane", the count of messages that I have highlighted or what I am calling the Preview pane?  If it is, the email count section, when I log in and put in a password (or "Get Mail") and I have highlighted the Unified Inbox, I can see the number of messages increase as the messages are downloaded from my many POP3 accounts.  I think it is (b) above, but I am not sure.  Basically, many messages come in and I can't tell you if the count in the Thread Pane is correct or not as I have thousands of messages, so if the count number is off by a few, I would have no idea if the count is accurate.  

In your last section above, I believe it is working how you state..sometimes when a message is missing from the Unified inbox preview pane, and I then click instead on the individual inbox and then come back and select the unified inbox again, the missing message(s) in the preview pane will then show up when it didn't before.
(Reporter)

Comment 19

5 years ago
PS In response to "global search" comment made at 2013-05-29 23:38:03 PDT above, no, that is not what I meant. I am not doing a search.  Of course, this was another bug I put into the system a long, long time ago which has never been fixed.  Basically, what occurs is that I have highlighted either an individual inbox or the unified inbox and am looking down at the what I call the "preview pane" of each message on the right side.  I usually decide if I want to read that email by double clicking on it, or hit "R" to indicate it is read (to make it non-bold) or just hit DELETE to get rid of it.  So... I am working my way down the list either from the bottom up or top down when all of a sudden the whole view changes and TB appears to be doing some kind of reindexing or shifting around... whatever.  When it is done, I now have lost my place and I back at some other point in the inbox list and have to move the window up or down and try to get back to where in the list I was previously inspecting all the messages that have come in.  A real PITA!
(In reply to Dick from comment #18)
Sorry for my broken English and ambiguous question/request.

> Are you asking me to modify the snapshot pictures I posted and ad columns?

No. My asking is: Show such columns in your testing/checking or daily use, for better report about "what occurs in your environment".

> In the middle section, is the definition of "Thread Pane", (snip)

See following.
> http://mxr.mozilla.org/comm-central/search?string=folderpane
> http://mxr.mozilla.org/comm-central/search?string=threadpane
> http://mxr.mozilla.org/comm-central/search?string=messagepane
FolderPane/ThreadPane/MessagePane is defined name in 3pane window layout by messenger.xul.
> http://mxr.mozilla.org/comm-central/source/mail/base/content/messenger.xul#395
PreviewPane is used only here in Thunderbird.
> http://mxr.mozilla.org/comm-central/search?string=previewpane

  3pane window by View/Layout/Classic View 
  +-----------------------------------------+
  |       MenuBar, ToolBar etc.             |
  +------------+----------------------------+
  |            |                            |
  |            |         ThreadPane         | <= Mails are listed
  |            |                            | <= Never "Preview Pane"
  | FolderPane +----------------------------+
  |            |                            |
  |            |         MessagePane        | <= Mail content is shown
  |            |                            | <= Never "Preview Pane"
  +------------+----------------------------+

Please use accurate term, because here is bugzilla.mozilla.org to report Tb's flaw in code to developer, and here is not support forum.

Updated

5 years ago
Whiteboard: [closeme 2013-06-11] → [closeme 2013-07-11]

Comment 21

5 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2013-07-11]
You need to log in before you can comment on or make changes to this bug.