Last Comment Bug 728385 - [10.8] Include support for Mountain Lions "Notification Center" into Thunderbird
: [10.8] Include support for Mountain Lions "Notification Center" into Thunderbird
Status: RESOLVED FIXED
[gs][fixed by bug 728106]
:
Product: Thunderbird
Classification: Client Software
Component: OS Integration (show other bugs)
: unspecified
: x86 Mac OS X
: -- enhancement with 15 votes (vote)
: Thunderbird 19.0
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.apple.com/macosx/mountain-...
Depends on: 728106
Blocks: tb-mac TB-mountain-lion-com
  Show dependency treegraph
 
Reported: 2012-02-17 13:12 PST by Nomis101
Modified: 2014-07-10 23:44 PDT (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Thunderbird in the notification center preferences (103.38 KB, image/jpeg)
2012-06-17 09:20 PDT, Nomis101
no flags Details

Description Nomis101 2012-02-17 13:12:45 PST
OS X 10.8 has a new service "Notification center", which is a bit similar to Growl. Would be nice if we include support for this into Thunderbird for new mails, for the instant messaging feature, for news (and what else).
Comment 1 Philipp Kewisch [:Fallen] 2012-06-04 06:37:25 PDT
Is there already toolkit support for this?
Comment 2 Nomis101 2012-06-04 09:42:20 PDT
Not yet, toolkit support is Bug 728106.
Comment 3 Nomis101 2012-06-17 09:20:24 PDT
Created attachment 633904 [details]
Thunderbird in the notification center preferences

Cool, after building TB with the WIP patch from Bug 728106 I see TB in my notification center preferences. I also get a Growl-like notification for new mails, which than dissapears. But I don't see the notification in the notification center bar (or whatever this is named) if I toggle it.
Comment 4 markusd112 2012-07-25 23:00:03 PDT
I have just upgraded to OS X 10.8 and it would be great, if I could use TB with the new notification center. When will it be available in the stable release of TB on Mac?
Comment 5 Nomis101 2012-07-26 09:17:40 PDT
(In reply to markusd112 from comment #4)
> I have just upgraded to OS X 10.8 and it would be great, if I could use TB
> with the new notification center. When will it be available in the stable
> release of TB on Mac?

Bug 728106 needs to be fixed for this first. So I expect it (in the stable release) when TB 17 (or 18?) will be released.
Comment 6 Nomis101 2012-08-10 10:02:49 PDT
Note: Growl support will be removed completely in Bug 777409.
Comment 7 Nomis101 2012-08-23 10:58:45 PDT
(In reply to Philipp Kewisch [:Fallen] from comment #1)
> Is there already toolkit support for this?
Now there is toolkit support for this, but only if the application is in the background.
Comment 8 Wayne Mery (:wsmwk, NI for questions) 2012-09-24 10:27:38 PDT
https://getsatisfaction.com/mozilla_messaging/tags/bug_728106
Comment 9 mad.engineer 2012-10-12 09:46:12 PDT
Firefox 17.0 is adding support for 10.8 Notification Center. Since both Firefox and TB share the some common core code, why can't that piece of code be included into TB 17 to add support for Notification Center?
Comment 10 Nomis101 2012-10-12 09:57:59 PDT
Oh, thanks for reminding me to that. Because it is Core code it is in TB 17 and above and works if TB is in the background. There is nothing we need to do for this specific for TB, so I will close this Bug. So, fixed by Bug 728106.
Comment 11 estephan 2012-10-31 22:31:39 PDT
Hi all -- Apologies for this note.  I noticed that, though I am currently running Thunderbird 17 beta 2 on my mac, this support for the Notification Center is not appearing to be in there yet.  I saw this ticket was marked "resolved and fixed," so I wondered if someone could flag when it would appear in the product.  THANKS --eric
Comment 12 mad.engineer 2012-11-20 19:25:02 PST
This bug is not fixed in TB 17 and the Status need to be Changed from the existing Resolved Fixed. FF 17 Beta at one time added the support and based on that this bug was marked as Resolved for TB 17 as well. But looks the support for Notification Center has been pulled from the final FF 17 according to https://bugzilla.mozilla.org/show_bug.cgi?id=806351 "Bug 806351 - disable Notification Center support on beta (Firefox 17), it isn't ready". Hence this bug also need to be re-opened. Thanks
Comment 13 Mark Banner (:standard8) 2012-11-21 01:18:34 PST
It was only disabled in 17/18. The notification support hasn't been backed out of trunk.
Comment 14 BvdG 2013-02-20 02:37:47 PST
When will this finally be incorporated in the release channel? Apparently there will not be a Thunderbird 19.0 because the release schedule has been upended (see https://etherpad.mozilla.org/tb-releases ). So can we expect it in 17.1? 17.2? Version 24 in September?
Comment 15 BvdG 2013-07-26 06:48:04 PDT
Sorry to keep asking, but this is becoming a bit weird. The code that solves this bug (or 'obvious lacking feature') was apparently added in October, and it is still not in Thunderbird... because they changed the _numbering_ of their release cycle!

How do we get the TB managers to put this in a version number that is coming up before Christmas 2015?
Comment 16 Nomis101 2013-07-26 09:22:38 PDT
Yes, thats a bit confusing. It was in Thunderbird, but is now replaced with this new XUL notifications. So there will be no Thunderbird with native Notification center support. But it is planed to link the new XUL notifications with Notification center. (Therefore I've build my own TB with native Notification center support with the old NC code)
Comment 17 BvdG 2013-07-27 05:26:11 PDT
As a longtime Thunderbird user/fan, I'm saddened by the extent to which Thunderbird is out of touch with users, who simply want seamless integration with their operating system. It looks like they've really given up.

Please change the status of this bug to RESOLVED FIXED BUT ABANDONED THE SOLUTION, or whatever this situation is called.

Is there any ETA on the link between the XUL notifications and Notification center?
Comment 18 lau.hub 2013-10-31 05:01:00 PDT
Disclaimer: this is an end-user message

Why does this bug is marked as "RESOLVED" ?

I don't see anything now (TB 24.0.1) that allow to use Notification Center except Growl (which must be purchased to be used).

Bug 728106 is in the same state but nothing appears in TB24.
Comment 19 Nomis101 2013-10-31 11:09:13 PDT
(In reply to lau.hub from comment #18)
> Disclaimer: this is an end-user message
> 
> Why does this bug is marked as "RESOLVED" ?
> 
> I don't see anything now (TB 24.0.1) that allow to use Notification Center
> except Growl (which must be purchased to be used).
> 
> Bug 728106 is in the same state but nothing appears in TB24.

See #16. 
It was added here: http://hg.mozilla.org/mozilla-central/rev/67c5213dfe2b
And removed here: http://hg.mozilla.org/mozilla-central/rev/c9732200552d
Maybe Bug 852648 will fix the current Mac unpleasantness.
Comment 20 DotTheI 2014-07-10 21:41:09 PDT
This is not resolved. The issue is still there in TB 24.6. Shoul another bug be created or this one can be reopened?
Comment 21 Nomis101 2014-07-10 23:44:03 PDT
Is is resolved since TB 28. So, it will be resolved if TB 31 will be released around July 22. I don't think it will ever be fixed in TB 24.

Note You need to log in before you can comment on or make changes to this bug.