homepage link in lightning extension is broken (404)

RESOLVED FIXED in 3.1

Status

RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: stefan-bmo, Assigned: Fallen)

Tracking

Lightning 1.2

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2 Iceweasel/10.0.2
Build ID: 20120217180242

Steps to reproduce:

Thunderbird 10; Lightning 1.2.1; View Addon Details. Homepage link is http://www.mozilla.org/en-US/projects/calendar/releases/lightning1.2.1.html which is currently 404.
Component: General → Website
QA Contact: general → website

Updated

7 years ago
Assignee: nobody → jan.bambach
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
Status: NEW → ASSIGNED

Comment 1

6 years ago
Bump for Lightning 1.8
Homepage link on the Addons-Manager entry and also on Addons-Manager Entry => Right Click -> About

http://www.mozilla.org/de/projects/calendar/releases/lightning1.8.html

Comment 2

6 years ago
I'll gladly try to implement the fix if anyone can point me to the proper page :)
Duplicate of this bug: 751380
Duplicate of this bug: 798296
Duplicate of this bug: 814196

Comment 6

6 years ago
IMO I think http://www.mozilla.org/projects/calendar/ would be fine, better than 404.

Comment 7

6 years ago
Hmm... homepage says
Download Now
Version 1.5
Is the page maintained?

Comment 8

6 years ago
Better have a working link to somewhere quite accure than to a page that do not exist. That is the situration with Calendar 1.9 (at least with Seamonkey).

http://www.mozilla.org/projects/calendar/lightning/

seems to be the official project page, so missing updates to it is an another thing.

Note that I am using finnish version and maybe this is reason why link is broken.

Comment 9

5 years ago
Problem still exists in Lightning 2.6.2.  The add-on directs users to http://www.mozilla.org/projects/calendar/releases/lightning2.6.2.html which retuns a 404.
(Assignee)

Comment 10

5 years ago
I've heard that there will be a pull request for the new website this or next week. When its in place I will change the homepage location in the xpi.
(Reporter)

Comment 11

5 years ago
The new website is now live at ¹, but the link is still broken in 2.6.4. Just a reminder so this doesn’t get lost. 

¹ https://www.mozilla.org/en-US/projects/calendar/

Comment 12

5 years ago
WFM in SeaMonkey.
(Assignee)

Comment 13

5 years ago
Created attachment 8347370 [details] [diff] [review]
Fix - v1

Martin, Stefan, I'll take a review from any of you. Does it sound sane to you to use the new landing page?
Assignee: jan → philipp
Attachment #8347370 - Flags: review?(mschroeder)
Attachment #8347370 - Flags: feedback?(ssitter)
Comment on attachment 8347370 [details] [diff] [review]
Fix - v1

r=mschroeder
Attachment #8347370 - Flags: review?(mschroeder) → review+
(Assignee)

Comment 15

5 years ago
Pushed to comm-central changeset a89e4b3be6e9
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.1
Attachment #8347370 - Flags: feedback?(ssitter)
You need to log in before you can comment on or make changes to this bug.