Implement the web app installation UI

RESOLVED DUPLICATE of bug 697006

Status

Firefox Graveyard
Web Apps
RESOLVED DUPLICATE of bug 697006
6 years ago
2 years ago

People

(Reporter: Felipe, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Implement the notification (bar/doorhanger) and related UI that will be presented when a web app requests to be installed through navigator.mozApps
(Reporter)

Updated

6 years ago
Summary: Implementation web app installation UI → Implement the web app installation UI
(Reporter)

Comment 1

6 years ago
Tim, so the way that things are hooked together between the webpage and the install process is:

 a) webpage calls navigator.mozApps.install(..) to install itself
 b) the install function will then send a notification called webapps-ask-install
 c) front-end observes this notification and presents a doorhanger confirming installation
 d) If user confirms the installation than the front-end will call DOMApplicationRegistry.confirmInstall(..) and the app will get installed.

Fabrice, please correct me if I'm wrong here


So this bug is primarily about (c), and possible follow-ups for handling exception and error cases, if any (I'll be looking at this soon).

A bunch of this was previously implemented in the patch at bug 697006, in the webappsUI.jsm file, and parts of it are reviewed!  I'm not convinced though at the approach of using a .jsm for UI code like this, but it was used to handle the global (not per-window) nature of the observer system
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
(Reporter)

Comment 2

6 years ago
Created attachment 602270 [details]
Screenshot

Here's a screenshot of the doorhanger as currently implemented by the add-on. The add-on can be installed here: http://people.mozilla.com/~dclarke/openwebapps/Extension/ and the code is here: https://github.com/mozilla/openwebapps/tree/develop/addons/jetpack

I'm using this URL to test: https://stage-myapps.mozillalabs.com/apps/appdir/
This is a dupe of bug 697006 for which I have a rebased patch. It implements (c) in comment #1
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697006

Updated

6 years ago
Assignee: ttaubert → nobody
Component: General → Web Apps
QA Contact: general → webapps

Updated

6 years ago
No longer blocks: 731054
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.