Last Comment Bug 731590 - Update search engine list for Thunderbird
: Update search engine list for Thunderbird
Status: VERIFIED FIXED
[gs]
:
Product: Thunderbird
Classification: Client Software
Component: Search (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 13.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
http://gsfn.us/t/2ppuy
: 879873 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 06:56 PST by Mark Banner (:standard8)
Modified: 2013-11-09 06:01 PST (History)
15 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
+
fixed


Attachments
The fix (1.12 KB, patch)
2012-02-29 07:46 PST, Mark Banner (:standard8)
bwinton: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Mark Banner (:standard8) 2012-02-29 06:56:45 PST
The product team have agreed a new search engine list as follows:

Bing (default)
Yahoo
Amazon
AOL
eBay
Twitter
Wikipedia
Comment 1 Mark Banner (:standard8) 2012-02-29 07:46:23 PST
Created attachment 601611 [details] [diff] [review]
The fix

There's a couple of prefs etc being left in to support locales whilst we roll this out to them as well.
Comment 2 Blake Winton (:bwinton) (:☕️) 2012-02-29 07:54:35 PST
Comment on attachment 601611 [details] [diff] [review]
The fix

Looks reasonable by inspection.  rs=me.
Comment 3 Mark Banner (:standard8) 2012-02-29 08:00:25 PST
Checked in: http://hg.mozilla.org/comm-central/rev/3feeb4bdf852
Comment 4 Mark Banner (:standard8) 2012-02-29 08:00:42 PST
Comment on attachment 601611 [details] [diff] [review]
The fix

[Triage Comment]
Comment 6 Ludovic Hirlimann [:Usul] 2012-03-01 03:52:02 PST
Verified fixed on Trunk.
Comment 7 AlexIhrig 2012-03-02 11:05:19 PST
There was no comment to l10n teams. Wondering about the reasons and if we have to do this change, too?
Comment 8 Marcel Berteler 2012-03-16 03:28:12 PDT
I read 'product team have agreed' but may I ask why Google was removed and how do I get it back as my preferred search engine?
Comment 9 mitchell.perilstein 2012-03-30 05:44:06 PDT
Look, guys.  We all understand you have to strike business relationships to make money.  Default search engine settings to support those goals, okay, we get it.

But the reason we're using this product is choice and configurability. If you make it so hard to chose what we want, it will just confirm to users that you've jumped the shark and drive them away.

So okay, put bing as default if you must.  But leave a place to let me chose without a ton of hassle.
Comment 10 abourcier 2012-04-02 00:55:08 PDT
Hello, I hope this will answer your request.
https://support.mozillamessaging.com/en-US/kb/add-search-engine-open-search
Comment 11 mitchell.perilstein 2012-04-02 04:23:41 PDT
Hi Abourcier,

Yes I'm aware of the searchplugins xml hack, as well as the open_externally setting.  Sure, I can throw some xml around.

However, this is a "soft" customer interface issue, not a technical one.  It's about how marketing decisions can sometimes send a loud and clear messages to users. In this case, it's clear to us somebody struck some kind of exclusivity agreement to remove a popular, leading search engine and replace it with a distant, roundly disliked one, making no UX allowance to choose otherwise.  Not even DDG?

I've been a user of the Moz browsers--and the following various mail incarnations--since you guys were an alternative to Mosaic.  But now, for the first time in Moz, I've been made to feel like the product and not like the customer.  If I liked that feeling, I'd be using IE.

Thanks for reading.
Comment 12 abourcier 2012-04-02 04:39:56 PDT
Hello,
The Thunderbird default list of search engines reflects the agreements and authorizations we have with their respective owners. We do not have such agreement or authorization from  Google.
This is a change that's primarily driven by business agreements and we generally do not publicly discuss these details. We realize it can influence the community, but as it is, we believe that the default list of search providers will give great search results.
I hope we will keep you amongst our Thunderbird users!
Comment 13 Marcel Berteler 2012-04-02 05:08:46 PDT
@abourcier, so you are the 'Marketing' source that was quoted in getsatisfaction?

Well, as I said before, the statement is convenient for Business but not for the user. You know/knew it can influence the community and that is why you waited so long to make a statement, that is not even on the official blog? Seems to me the only reason why you made the statement is because people questioned the change after it was pushed through and not because you felt it was important to the end-user.

What worries me about these debate-less changes is that who knows what ever 'Marketing' is stopping / influencing in the development that is not in the best interest of the user but in the best interest of business agreements? Not a great feeling for an Open Source application.

If there is nothing to hide, why hide it? Play open card. If Google requested to be removed, than we can all ask Google why and stop bothering Mozilla. If Mozilla wanted money from Google for being listed and Google refused than we understand the search feature is just advertising space. We all understand Mozilla needs money, just be open about it. 

Continue hiding things and your support under contributors will reduce.
Comment 14 Wayne Mery (:wsmwk, NI for questions) 2012-04-02 05:18:02 PDT
please take this conversation to a newsgroup, or somewhere other than bugzilla
Comment 15 abourcier 2012-04-11 07:02:47 PDT
You can now find an add-on at https://addons.mozilla.org/en-US/thunderbird/addon/google-search-for-thunderbi/
Comment 16 Mitra Ardron 2012-08-20 12:04:37 PDT
The page listed in Comment #10
https://support.mozillamessaging.com/en-US/kb/add-search-engine-open-search
needs editing - it seems to be both incomplete AND wrong. 

I'm not sure if that is you abourcier? It says to create a searchplugins directory but its not clear if this should be at the same level as the Profile directory, in the Profile directory or in the actual profile of the user. 

And ... it appears to be wrong - adding that google.xml file into all three places and restarting TB and it still doesn't work. 

Also - that list of search engines (Bing...Wikipedia) doesn't show up anywhere - is there a bug for that ?
Comment 17 Mitra Ardron 2012-08-20 12:10:08 PDT
Sorry - slight correction - the instructions need to say that you should then perform a Bing search, you don't get the choice of engines until you've searched first on another one.
Comment 18 Wayne Mery (:wsmwk, NI for questions) 2013-11-09 06:01:07 PST
*** Bug 879873 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.